[PC-BSD Testing] Virtual box can't import appliance because not root

Kris Moore kris at pcbsd.org
Wed Dec 18 07:12:57 PST 2013


On 12/18/2013 03:29, Jeff wrote:
> I'm running PCBSD 9.2 and tried to import a Bitnami VMware appliance
> into Virtual Box (converts it to .OVF file) using this procedure:
> http://wiki.bitnami.com/Virtual_Appliances_Quick_Start_Guide#Virtual_Box
>
> But it failed with an error that the file
> (bitnami-alfresco-4.2.e-2-ubuntu-12.04.vmdk) wasn't owned by root.  I
> changed the ownership but it still failed.
>
> I deleted the virtual machine and created it again but since VB is not
> running as root it couldn't find the file in the "select existing hard
> drive" dialog box.
>
>
> Anyway out of this conundrum? Can I run VB as root some how?
>
> ...Jeff
>
>
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing

Are you running vbox as root?

I use "sudo <vbox command> <file>" and it should work fine.

-- 
Kris Moore
PC-BSD Software
iXsystems

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20131218/ccad4239/attachment.html>


More information about the Testing mailing list