[PC-BSD Testing] 9.1 RR post-`pkg upgrade -fy`

Bridger Dyson-Smith bdysonsmith at gmail.com
Tue Apr 23 05:43:15 PDT 2013


Hi all,

I wanted to report a couple of oddities, post `pkg upgrade -fy`. I ran pkg
upgrade in an attempt to fix the Control Panel > Printing dialog errors
I've been getting [1].

pkg upgrade ran without a hitch, but...
1) After rebooting, I noticed that a) GNOME was the default DE (I'm only
using LXDE), and b) all of the DE entries in the list box were doubled.
Both of these were *not* persistent as they went away after logging out &
back in. I didn't think to grab a screen shot.
2) I'm getting the same errors, post-pkg upgrade, with the Printer dialog.
3) I tried to install a pkg (mtpfs) for some testing and got the following
error when pkg attempts to upgrade itself [2].

Overall, RR is pretty solid and having the pkgNG infrastructure is nothing
short of super awesome. Thanks a bunch for all the time & hard work you all
are putting into it.

Bridger

[1] Error from .xsession-errors:
Qt conversation started.
Qt conversation finished.

** (process:81825): WARNING **: Trying to register gtype 'GMountMountFlags'
as enum when in fact it is of type 'GFlags'

** (process:81825): WARNING **: Trying to register gtype 'GDriveStartFlags'
as enum when in fact it is of type 'GFlags'

** (process:81825): WARNING **: Trying to register gtype 'GSocketMsgFlags'
as enum when in fact it is of type 'GFlags'

(system-config-printer.py:81825): IBUS-WARNING **: The owner of
/usr/home/bridger/.config/ibus/bus is not root!
GLib (gthread-posix.c): Unexpected error from C library during
'pthread_mutex_unlock': Operation not permitted.  Aborting.

[2] Error from pkg install:
# pkg install mtpfs
Updating repository catalogue
Repository catalogue is up-to-date, no need to fetch fresh copy
New version of pkg detected; it needs to be installed first.
After this upgrade it is recommended that you do a full upgrade using: 'pkg
upgrade'

The following packages will be installed:

Upgrading pkg: 1.0.9_2 -> 1.0.11

The installation will require 7 kB more space

1 MB to be downloaded

Proceed with installing packages [y/N]: y
pkg:
http://mirrors.nycbug.org/pub/PC-BSD/packages/9.1-RELEASE/amd64/All/pkg-1.0.11.txz:
Not Found
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20130423/1b6ffebb/attachment.html>


More information about the Testing mailing list