[PC-BSD Testing] Installation from usb corrupted by force shutdown

claive alvin Acedilla cabpacedilla at gmail.com
Sun Sep 9 20:34:05 PDT 2012


Unplugging the usb was reproduced in 9.1 RC1

On Mon, Sep 10, 2012 at 6:32 AM, claive alvin Acedilla <
cabpacedilla at gmail.com> wrote:

> Even just by unplugging the usb while the usblite installer is booting, on
> the next boot of the usblite installer, the installer will reach a prompt
> saying"Enter full pathname of shell or RETURN for /bin/sh".
>
> On Thu, Jul 26, 2012 at 9:46 PM, N V <vans9 at yandex.ru> wrote:
>
>> On 25 июля 2012 19:40:55 Dewey Hylton wrote:
>> > ----- Original Message -----
>> >
>> > > From: "Kris Moore" <kris at pcbsd.org>
>> > > To: testing at lists.pcbsd.org
>> > > Sent: Wednesday, July 25, 2012 11:30:23 AM
>> > > Subject: Re: [PC-BSD Testing] Installation from usb corrupted by
>> > > force shutdown
>> > >
>> > > On 07/21/2012 04:22, claive alvin Acedilla wrote:
>> > > > I tried to do force shutdown during my installation from USB
>> > > > because
>> > > > PCBSD is not displaying the GUI maybe it is not handling the intel
>> > > > video card.
>> > > >
>> > > > But when I tried to boot again the usb installer, the installer
>> > > > stopped and prompted "Enter full pathname of shell or RETURN for
>> > > > /bin/sh".
>> > > >
>> > > > I press enter prompt returned # prompt.
>> > > >
>> > > > Tried to do reboot with reboot command, installer goes back to
>> > > > /bin/sh message.
>> > > >
>> > > > I tried safe mode, still same problem.
>> > > >
>> > > > There was a message on the verbose screen that "/ was not clean
>> > > > properly" and installer cannot continue.
>> > > >
>> > > > Does the installer cache/writing on the USB stick which mangle the
>> > > > installer or to RAM?
>> > > >
>> > > > If you cannot reproduce try doing a force shutdown again on the
>> > > > power
>> > > > button until you reproduce the problem.
>> > > >
>> > > >
>> > > > Im using the PCBSD USBLite 9.1 Beta1 LXDE ZFS
>> > > >
>> > > >
>> > > > _______________________________________________
>> > > >
>> > > > Testing mailing list Testing at lists.pcbsd.org
>> > > > http://lists.pcbsd.org/mailman/listinfo/testing
>> > >
>> > > It shouldn't be writing anything to the USB media, its all mounted
>> > > read-only and then using memfs. I'll test it here, but it may have
>> > > been a fluke of something getting corrupted on the media.
>> > >
>> > > --
>> > > Kris Moore
>> > > PC-BSD Software
>> > > iXsystems
>> >
>> > I have run into the same thing multiple times (during the FreeBSD
>> > Server/ZFS issue i'm working on). fsck_ufs does fix the problem, but I
>> was
>> > surprised to see it, as i thought the usb media should have been mounted
>> > read-only as well.
>>
>> I confirm this. fsck_ufs fixes the issue.
>>
>> Regards,
>> Vans.
>> _______________________________________________
>> Testing mailing list
>> Testing at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/testing
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120910/c87291ad/attachment.html>


More information about the Testing mailing list