[PC-BSD Testing] Printer search function broken?

Dru Lavigne dru.lavigne at att.net
Tue Mar 27 11:00:29 PDT 2012


> I tried that but after installation of the PPD I got this
> error message:
> 
> Printer 'Epson-ME-340' requires the
> '/opt/epson-inkjet-printer-201101w/cups/lib/filter/epson_inkjet_printer_filter'
> program but it is not currently installed.? Please install
> it before using this printer.
> 
> I tried printing anyway, but the printer did not respond and
> there were no jobs in the queue.
> 
> 
> That program is a Linux compiled binary I'm guessing, so it
> would have to be run as a Linux compat.? Not sure how to do
> that. 
> 
> 
> There are several Linux distro choices for this driver
> package via: http://www.openprinting.org/driver/epson-201101w/.? I
> used the Debian version to get the PPD file.? There are
> others too, including a source version as an RPM file which
> I can't unpack.? I did notice an RPM manager via Freshports,
> which maybe I could use to unpack this (or do it on my
> Ubuntu laptop) and get at the source file and try to compile
> it on FreeBSD.
> 
> Then alter this line in the PPD: *cupsFilter:???
> "application/vnd.cups-raster 0
> /opt/epson-inkjet-printer-201101w/cups/lib/filter/epson_inkjet_printer_filter"
> 
> Would that likely work?? 
> 


It sounds like a FreeBSD port will be needed for this driver since cups/ghostscript isn't including one by default and it instead relies on a separate Linux driver.

Can you continue to futz with it to see if you can get any of the drivers to work (e.g. rpm, etc)? We can then summarize what works (if you're successful) or what is needed so that the info can be available to a porter.

Cheers,

Dru


More information about the Testing mailing list