[PC-BSD Testing] Printer search function broken?

Jeff dejamuse at yahoo.com
Tue Mar 27 10:41:57 PDT 2012


I tried that but after installation of the PPD I got this error message:

Printer 'Epson-ME-340' requires the '/opt/epson-inkjet-printer-201101w/cups/lib/filter/epson_inkjet_printer_filter' program but it is not currently installed.  Please install it before using this printer.

I tried printing anyway, but the printer did not respond and there were no jobs in the queue.


That program is a Linux compiled binary I'm guessing, so it would have to be run as a Linux compat.  Not sure how to do that. 


There are several Linux distro choices for this driver package via: http://www.openprinting.org/driver/epson-201101w/.  I used the Debian version to get the PPD file.  There are others too, including a source version as an RPM file which I can't unpack.  I did notice an RPM manager via Freshports, which maybe I could use to unpack this (or do it on my Ubuntu laptop) and get at the source file and try to compile it on FreeBSD.

Then alter this line in the PPD: *cupsFilter:    "application/vnd.cups-raster 0 /opt/epson-inkjet-printer-201101w/cups/lib/filter/epson_inkjet_printer_filter"

Would that likely work?  



>________________________________
> From: Dru Lavigne <dru.lavigne at att.net>
>To: testing at lists.pcbsd.org 
>Sent: Tuesday, March 27, 2012 11:42 PM
>Subject: Re: [PC-BSD Testing] Printer search function broken?
> 
>
>> Just bought a new Epson ME-340 printer (http://www.openprinting.org/printer/Epson/Epson-ME_340_Series)
>> but the system doesn't recognize it and the driver search
>> function seems broken - nothing happens even with other
>> common printer types.
>> 
>> I was able to install a driver for the ME-320 which was in
>> the list, but it's very slow and is not the full service
>> driver available from Epson for Linux: http://www.openprinting.org/driver/epson-201101w/
>> 
>> Other Epson models that use the same driver are not in the
>> printer list (ME 340, Epson Stylus NX130, Epson Stylus
>> SX130, Epson Stylus TX130, TX133, TX135).
>> 
>> 
>> I installed the printer on Kubuntu just fine using this
>> driver downloaded from Epson through the printer setup
>> dialog search function.
>> 
>> The driver is available here. Several choices are listed,
>> .rpm, .deb, etc.
>> 
>> 
>> Is there a way to use this driver on PCBSD?
>
>
>Do any of the sources or the drivers that came with the printer provide a .ppd file? If so, that is what you want and you can browse to its location following the PPD directions at:
>
>http://wiki.pcbsd.org/index.php/Printing#Manually_Adding_a_Driver
>
>Cheers,
>
>Dru
>_______________________________________________
>Testing mailing list
>Testing at lists.pcbsd.org
>http://lists.pcbsd.org/mailman/listinfo/testing
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120327/c075d77e/attachment-0001.html>


More information about the Testing mailing list