[PC-BSD Testing] New ports jails issues

Lars Engels lars.engels at 0x20.net
Fri Jun 15 09:25:18 PDT 2012


On Fri, Jun 15, 2012 at 10:17:32AM -0400, Kris Moore wrote:
> On 06/14/2012 20:12, Ben Milman wrote:
> > Hi, 
> >
> > So I tried to get a ports jail to install and run under the new
> > Warden. I opened the jail terminal only to find that /usr/ports was
> > empty. A 'portsnap fetch' within the jail failed. When I checked
> > /usr/ports on the outer system it was empty, I must have forgotten to
> > include it at install time. After performing 'portsnap fetch extract'
> > on the outer system, a new ports jail with the ports tree included
> > worked as expected. I presume that the ports checkbox in the new jail
> > wizard causes the ports tree from the outer system to be copied into
> > the jail? If that's the case, I have some objections: That doesn't
> > take into account the possibility of the outer ports tree being
> > missing or modified, and there is no warning for cases like what I
> > experienced.
> >
> > I didn't look into what caused portsnap to fail within the jail, but
> > that might be a related or unrelated issue.
> >
> > Thanks,
> > Ben
> >
> >
> > _______________________________________________
> > Testing mailing list
> > Testing at lists.pcbsd.org
> > http://lists.pcbsd.org/mailman/listinfo/testing
> 
> I've just improved this, so that it will checkout ports from portsnap
> instead of just copying from /usr/ports. Also, it will now display
> warnings if it fails. Ditto with system sources.

Could you make the fetch job optional? If you create a couple of (port-)
jails it always needs to fetch the whole ports tree.
It would be nice to select:

[ ] Copy Ports Tree from host system
[ ] Download current Ports Tree from the internet
[ ] Use the host system's Ports Tree (via nullmount)
[ ] Don't install a Ports Tree

BTW copying /usr/ports is not enough. If you want to use portsnap you
also need /var/db/portsnap.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120615/9345bb9c/attachment.bin>


More information about the Testing mailing list