[PC-BSD Testing] New ports jails issues

Kris Moore kris at pcbsd.org
Fri Jun 15 07:17:32 PDT 2012


On 06/14/2012 20:12, Ben Milman wrote:
> Hi, 
>
> So I tried to get a ports jail to install and run under the new
> Warden. I opened the jail terminal only to find that /usr/ports was
> empty. A 'portsnap fetch' within the jail failed. When I checked
> /usr/ports on the outer system it was empty, I must have forgotten to
> include it at install time. After performing 'portsnap fetch extract'
> on the outer system, a new ports jail with the ports tree included
> worked as expected. I presume that the ports checkbox in the new jail
> wizard causes the ports tree from the outer system to be copied into
> the jail? If that's the case, I have some objections: That doesn't
> take into account the possibility of the outer ports tree being
> missing or modified, and there is no warning for cases like what I
> experienced.
>
> I didn't look into what caused portsnap to fail within the jail, but
> that might be a related or unrelated issue.
>
> Thanks,
> Ben
>
>
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing

I've just improved this, so that it will checkout ports from portsnap
instead of just copying from /usr/ports. Also, it will now display
warnings if it fails. Ditto with system sources.

-- 
Kris Moore
PC-BSD Software
iXsystems

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120615/cd567a06/attachment.html>


More information about the Testing mailing list