[PC-BSD Testing] New ports jails issues

Ben Milman ben at ixsystems.com
Thu Jun 14 17:12:31 PDT 2012


Hi,

So I tried to get a ports jail to install and run under the new Warden. I
opened the jail terminal only to find that /usr/ports was empty. A
'portsnap fetch' within the jail failed. When I checked /usr/ports on the
outer system it was empty, I must have forgotten to include it at install
time. After performing 'portsnap fetch extract' on the outer system, a new
ports jail with the ports tree included worked as expected. I presume that
the ports checkbox in the new jail wizard causes the ports tree from the
outer system to be copied into the jail? If that's the case, I have some
objections: That doesn't take into account the possibility of the outer
ports tree being missing or modified, and there is no warning for cases
like what I experienced.

I didn't look into what caused portsnap to fail within the jail, but that
might be a related or unrelated issue.

Thanks,
Ben
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120614/1752f851/attachment-0001.html>


More information about the Testing mailing list