[PC-BSD Testing] Freeze after running display wizard

Lars Engels lars.engels at 0x20.net
Tue Jul 31 12:46:26 PDT 2012


On Tue, Jul 31, 2012 at 10:48:31AM -0400, Kris Moore wrote:
> On 07/30/2012 15:26, Lars Engels wrote:
> > On Mon, Jul 30, 2012 at 11:33:32AM -0400, Kris Moore wrote:
> >> On 07/28/2012 09:39, Lars Engels wrote:
> >>> On Sat, Jul 28, 2012 at 11:53:01AM +0200, Lars Engels wrote:
> >>>> I tried 9.1-BETA1 amd64 on a Thinkpad T61 and the installation went
> >>>> fine.
> >>>> After the first boot the display wizard shows the correct resolution and
> >>>> offers to use the intel driver. When I accept it the screen goes black
> >>>> and the system freezes. The same happens when I select the intel-3d
> >>>> driver manually.
> >>>> The graphics chips is "Intel Graphics Media Accelerator X3100"
> >>> I removed /var/.startxgui and can start X with the intel driver. What
> >>> does happen when the display wizard ends?
> >>>
> >>>
> >>> _______________________________________________
> >>> Testing mailing list
> >>> Testing at lists.pcbsd.org
> >>> http://lists.pcbsd.org/mailman/listinfo/testing
> >> Its a bug in the video driver. Some intel systems, when you close X, it
> >> hangs the video and wont come back up. That's what's happening in this
> >> case, when it tries to restart X, it fails and doesn't come back up.
> > Maybe it's better to offer a reboot, then? Otherwise the box is in an
> > endless loop until the flag file is deleted.
> >
> 
> I've done some looking into this now. It looks like even if we offer 
> "reboot" option, you are going to hit the same bug when the first boot
> wizard starts, since at the end, it shuts down X to load GDM for the
> first time..
> 
> Can you confirm that is really the issue, if you login and logout of a
> desktop, does the display go away when it tries to reload GDM?

I'm using the Thinkpad now with an xorg.conf generated by xorg
-configure. It has

    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"

And logging off from LXDE brings me back to GDM.
What does not work is switching to another virtual terminal (known issue
of the KMS driver) and when shutting down X ends, the screen is black
but it shuts down in the background.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120731/e6e2ac36/attachment.bin>


More information about the Testing mailing list