[PC-BSD Testing] 9.1-BETA1 now available! (Update)

Lars Engels lars.engels at 0x20.net
Thu Jul 26 12:50:50 PDT 2012


Sorry for the quoting style. My web mailer doesn't seem to like to 
quote bigger
mails, so I'm writing this with "kate". :)

> Thanks for the notes! Responses below:
>
> On 07/21/2012 07:36, Lars Engels wrote:
>
> Alright, you wanted us to test it, so I did. :-)
> Let me first say that I am very impressed with the warden and the 
> other
> new tools, but I also found some issues and proposals:
>
>
> Installer:
>
> - First screen: Tooltips for icons are hardly readable
> Fixed! Now the install / first boot wizard have a status bar, so you 
> get mouse-over text for each of the buttons.
>
> - Language selector: Lower / Upper cases are mixed
> Fixed
>
>
> - The Icons should be more prominent, a user doesn't know if he is to 
> click on
>   them or not
> The mouse-over effects make this much more usable now
>
> - The Help Icon still shows the help messages for the old installer
> Fixed!
>
> - The Virtual Keyboard is not closable
>
> It is, just not very intuitive. You can hold-click the xvkbd button 
> in bottom left, and go to "close". I've also added the Close button to 
> the window title, so that should help.
>
> - The Keyboard Selector has all languages in English, while the 
> Language
>   Selector has them localized
> That's something we'll have to investigate for 9.2. Those langs are 
> pulled right from xorg, and they are not localized.
> - The Customize Desktop Selection Window has Window Title "Form"
> Fixed!
>
> - There's no way to configure wired network and hostname
> You can do this for server installs. For desktop, its set to DHCP by 
> default, and the user can change it in the control panel later.
>
>
> - No option to start the sshd on boot
>
> This is present for the server install, but not desktop. User can 
> enable post-install in services gui. This is by design. Our last 
> install got so cluttered, since more and more features kept going into 
> it. I'm trying to make the install as minimal as possible, and not 
> duplicate functionality that we have good GUI's for post-install.
>
>
> First boot wizard:
>
> - Why again the language selection?
>
> - Keyboard layout is again English
> For both of these, this is by design. The install acts as an OEM. So 
> if you do an install, and give the system to a new user, they get to 
> pick their own language / keyboard settings at first boot.
>
>
> - The Wireless Connection screen doesn't offer to enter an SSID for a 
> hidden
>   network
>
> Correct. We offer that in the network manager post-install. Again, 
> trying to keep simplicity here.
>
>
> GDM:
>
> - Before gdm's start, error message "Could not update ICEauthority 
> file
>   /usr/local/etc/gdm/home/.ICEauthority
>
> - (translated from German): There was a problem with the 
> configuration server
>   /usr/local/libexec/gconf-sanity-check-2 ended with status 256
>
> - The keyboard settings are English again and it's not possible to 
> change it,
>   so you need to know where to find the keys on an US keyboard layout 
> or you're
>   not able to login
>
> - GDM configuration app doesn't have an option to set the locale, so 
> you're
>   still stuck with an US keyboard :)
> Can you look at /usr/local/etc/gdm/home? What user owns this 
> directory? I don't see this error here, and its owned by gdm:gdm. If 
> you run "chown -R gdm:gdm /usr/local/etc/gdm/home" does it fix it?

Hmmm, /usr/local/etc/gdm is owned by root:wheel, home is gdm:gdm with 
mode 0700. Inside home every file is owned by gdm:gdm but
without x rights for the directories:

root at pcbsd-3616] /usr/local/etc/gdm/home# ls -lR
total 4
drw-------  3 gdm  gdm    3 20 Jul 19:28 .gconf
drw-------  2 gdm  gdm    3 20 Jul 18:57 .gconf.mandatory
-rw-------  1 gdm  gdm  286 20 Jul 18:57 .gconf.path

./.gconf:
total 2
drw-------  3 gdm  gdm  3 20 Jul 19:28 apps

./.gconf/apps:
total 2
drw-------  3 gdm  gdm  3 20 Jul 19:28 gdm

./.gconf/apps/gdm:
total 2
drw-------  2 gdm  gdm  3 20 Jul 19:28 simple-greeter

./.gconf/apps/gdm/simple-greeter:
total 1
-rw-------  1 gdm  gdm  472 20 Jul 19:28 %gconf.xml

Running find /usr/local/etc/gdm -type d | xargs chmod u+x
fixed that and more:
GDM now offers to change the keyboard in the login window, and metacity 
is no longer started
but kwin. :-)




>
> KDE Taskbar:
> - I am able to change my keyboard layout to German with the help of 
> the locale
>   switcher icon! \o/ However it switched back to English a short time 
> after /o\
>   (2 times, now it seems to stay German)
> Odd, is that some KDE fluke?

Maybe. I just deactivated the switcher. Does anyone need it?


>
> - Inserting a FAT formatted and PC-BSD's installer stick doesn't show 
> anything
>   on the desktop, /var/log/messages shows they were recognized as 
> da4(s1) and
>   da5(s1) and volmand CREATEd the devices (Mount Tray is not started
>   automatically)
> Did the get mounted in the background? If you run mount do you see 
> them? How about in dolphin, on the left bar?

No, it's not mounted in the background, neither it shows up in dolphin. 
I can mount it manually however. When mount
tray is started, I am offered to mount it. Maybe it doesn't work with 
dolphin / KDE's own mounter because it's not
labeled? But that would be a regression, as this worked in earlier 
versions.

Why is tray mount not started at login?

> - The system clock in the tray went from the correct 18:00h to 20:00h 
> after
>   some seconds, its settings says UTC, although I selected 
> Europe/Berlin in the
>   installer
> We enable NTPD by default, possibly that caused the time jump? At the 
> command prompt what does the "date" command show, UTC?

Sorry, I can't reproduce, because I set the time with tzsetup 
eventually.

> - The quick locale switcher icon in the tray still happily jumps 
> between German
>   and English, whenever I click on an icon in the tray
> No clue there :(
> - Hibernate option in the logout section of KDE's menu and probably 
> also from
>   the other DEs and XBMC should be removed in the source, because 
> it's not
>   supported on FreeBSD and will crash your computer
>
> Yea, we will need to do that at some point. I dont know if I will 
> have time before 9.1. Of course patches are welcome from anybody who 
> wants to look into this :)
>
>
> AppCafe:
>
> - No space between value and unit in the download status bar (e.g. 
> 600KBs
>   instead of 600 KB/s)
> Fixed!
> - Appcafe could have a "most downloaded apps" section?
>
> Maybe eventually, at the moment we don't have the framework in place 
> to store that data.
>
> - When a Category is selected there should be a heading saying in 
> which
>   category one is at the moment, maybe like "Appcafe > Audio > 
> aTunes"
>
> Good idea! Added it to the 9.2 TODO wiki page.
>
> - Add a Close button at the bottom of the Appcafe?
> Don't think its needed, we have a File -> Quit, and the X top right 
> works fine :)
>
> - Maybe add one or more screenshots for the PBIs just like on 
> pbidir.com?
> I prefer to leave that up to the particular applications on their own 
> websites. Its a pain / messy to be trying to manage all of those for 
> every third party software out there.
>
>
> About:
>
> - Memory says 4.75 GB, but dmesg has 4096 MB real and 3883 MB avail 
> (same issue
>   in pc-sysmanager)
>
> What does "sysctl -a | grep hw.realmem" show?

hw.realmem: 5100273664


> Warden:
> - Configuration of network interfaces could be a dropdown list of 
> available
>   interfaces + the ability to change it manually and leave it empty
> I'll check into this, it may work, just need to make sure that we 
> show all interfaces properly, and dont miss any virtual ones, etc.
>
> - IP Address could be left blank for a portsjail?
> Probably could, but should the user then want to run a service that 
> needs it, it would be a pain to manually add it.
>
> - The fetch process could show a progress bar and the current 
> download speed
> Added to 9.2 TODO
>
> - A button for enabling / disabling a jail's autostart would be 
> useful,
>   right-clicking the jail isn't so obvious
> Added to 9.2 TODO
> - I created a Gentoo jail called "gentoojail" but jls shows Hostname
>   "localhost"
>
> Looking into it. We are seeing the hostname properly with the jail 
> command, but it looks like its getting changed back to localhost after 
> gentoo starts. Probably need to set the hostname inside the jail as 
> well.
>
> Misc:
>
> - All the PC-BSD Tools have a different scroll bar that the KDE apps 
> (probably
>   GTK vs. Qt, but there are ways to match their look :) )
> They seem to look the same here, using the QtCurve themes inside KDE. 
> Does that match properly?

It looks like this: http://imgur.com/VV1X3
In the GTK Styles config GUI I have "User my KDE style in GTK 
applications". Changing it to "QtCurve"
doesn't seem to apply to e.g. PC-BSD system settings. It's still the 
same look as before there.

> - KDE's Window decoration looks really 90ies (KDE 1.x style?), though 
> Oxygen is
>   selected and its preview looks much nicer, the style also doesn't 
> change after
>   logging out and in again -- Ahh, I just found out: The PC-BSD 
> system
>   configuration program just crashed and now there's a window if it 
> should be
>   closed forcefully. And this window has title "Metacity", so it's 
> Gnome 2's
>   window manager in a KDE 4 session, WTF? ;-)
> That is weird! What did you click to get to that metacity 
> configuration? Not seeing it here on my KDE install.

Fixed by changing permissions to /usr/local/etc/gdm/home ...

> - The tooltips on pc-controlpanel are white font on bright(est) blue
>   background, so they're unreadable
> Noted, working on a fix here
>
> - KSystemLog says: "Pango-WARNING: error opening config file
>   '/usr/local/etc/gdm/home/.pangorc": Permission denied
> See permissions issue mentioned way above.
>
> - A double click on the updater icon in the tray starts Appcafe 
> instead of the
>   system update tool
> Correct, its an updater for both PBI's and system. If no system 
> updates are available, it defaults to opening the appcafe on click.
>
> - The Hardware Compatibility Tool should not only display the device 
> names but
>   also their "real" names, especially for the sound device as you can 
> have a
>   bunch of devices
> Added to 9.2 TODO
>
> - The font in the service manager is too big
> Fixed!
>
> - Misc. in pc-sysmanager has Boot Screen disabled but it is active 
> nonetheless
> Fixed
>
> - pc-sysmanager only has a Save button but no Cancel button
> I may need to re-design some of that app to avoid confusion down the 
> road. The save button is only for the particular tab you are on, so you 
> can just not press it, or close the app to make no changes.
>
> - pc-pfmanger is missing Close / Cancel buttons
> The window manager provides that?

Yes, but for small tools like that I'd prefer Buttons instead of 
clicking the tiny "X" in the upper
right corner. :) But that's a matter of taste.


>
> - pc-updategui has the old icon in the control panel
> Fixed!
>
> - Dolphin shows the Windows 7 DVD as UDF_Volume but refuses to mount:
>   org.freedesktop.Hal.Device.Volume.UnknownFailure: mount_udf: 
> /dev/cd0: invalid
>   argument
> I'll check into this. It may be that we'll fix it with the new Mount 
> Tray.
>
> - Mount Tray doesn't show the DVD at all
> Not yet. The backend code for devd notifications of optical media 
> didn't make it into 9.1, wont be in until 9.2. At that point we will be 
> able to finish up the DVD / optical support in mount-tray, and then 
> look at turning off HAL completely for media mounting.

FreeBSD's old UDF implementation is to blame here. It doesn't know how 
to mount newer
UDF discs like Windows 7. :(


> - Wireless configuration: the psk for WPA networks should be hashed 
> with
>   wpa_passphrase(8)
> I'll think about this. There may be some benefit to having the phrase 
> available to be "looked up" after setting it, but perhaps not so much.
> - I configured my wireless network and it worked but when I removed 
> it's config
>   the tooltip in the tray's wireless icon still says that I am 
> connected to my
>   WLAN, although "ifconfig wlan0" shows I am disconnected
> Did it update after 15 -20 seconds? Its on a timer to check every so 
> often, so i may take a few before it updates.

No, it kept displaying the same info.

> - Maybe the workgroup in smb.conf should be named "WORKGROUP" as this 
> is the
>   standard group name in Windows, so you can easily browse for your 
> Windows
>   shares in Dolphin and XBMC
> Its set to the samba default right now. We may change it, or perhaps 
> add a graphical way to do so down the road.
> - Startup notification for XBMC should be disabled, the icon is still 
> jumping
>   up and down after XBMC started successfully
> That menu icon comes with the package, may need to do that upstream.
> - The component installer for the meta packages should have a 
> download speed and
>   remaining time display. Downloading a bigger meta package can take 
> a long time
>   so this would be very useful
> Agreed, on the wiki for 9.2 stuff to work on :)
>
> Lars

BTW the pre-installed gvim does not work. It only shows a gray window 
and hangs.
truss shows:
read(4,"" zipPlugin.vim: Handles browsin"...,4096) = 2123 (0x84b)
stat("/usr/local/share/vim/vim73/plugin/zipPlugin.vim",{ 
mode=-rw-r--r-- ,inode=92709,size=2123,blksize=4096 }) = 0 (0x0)
close(4)                                         = 0 (0x0)
stat("/usr/local/share/vim/vimfiles/after/plugin/",0x7fffffffccb0) 
ERR#2 'No such file or directory'
stat("/usr/local/share/vim/vimfiles/after/plugin/",0x7fffffffce00) 
ERR#2 'No such file or directory'
stat("/usr/home/lars/.vim/after/plugin/",0x7fffffffccb0) ERR#2 'No such 
file or directory'
stat("/usr/home/lars/.vim/after/plugin/",0x7fffffffce00) ERR#2 'No such 
file or directory'
pipe(0x7fffffffd1e0)                             = 0 (0x0)
fork()                                           = 38064 (0x94b0)
close(5)                                         = 0 (0x0)
read(4,0x7fffffffd1d0,9)                         ERR#4 'Interrupted 
system call'
SIGNAL 2 (SIGINT)



>
>
> Thanks for all the notes!

You're welcome. Thanks for a new evolving PC-BSD version. :)

Lars


More information about the Testing mailing list