[PC-BSD Testing] Installation from usb corrupted by force shutdown

N V vans9 at yandex.ru
Thu Jul 26 11:46:18 PDT 2012


On 25 июля 2012 19:40:55 Dewey Hylton wrote:
> ----- Original Message -----
> 
> > From: "Kris Moore" <kris at pcbsd.org>
> > To: testing at lists.pcbsd.org
> > Sent: Wednesday, July 25, 2012 11:30:23 AM
> > Subject: Re: [PC-BSD Testing] Installation from usb corrupted by
> > force shutdown
> > 
> > On 07/21/2012 04:22, claive alvin Acedilla wrote:
> > > I tried to do force shutdown during my installation from USB
> > > because
> > > PCBSD is not displaying the GUI maybe it is not handling the intel
> > > video card.
> > > 
> > > But when I tried to boot again the usb installer, the installer
> > > stopped and prompted "Enter full pathname of shell or RETURN for
> > > /bin/sh".
> > > 
> > > I press enter prompt returned # prompt.
> > > 
> > > Tried to do reboot with reboot command, installer goes back to
> > > /bin/sh message.
> > > 
> > > I tried safe mode, still same problem.
> > > 
> > > There was a message on the verbose screen that "/ was not clean
> > > properly" and installer cannot continue.
> > > 
> > > Does the installer cache/writing on the USB stick which mangle the
> > > installer or to RAM?
> > > 
> > > If you cannot reproduce try doing a force shutdown again on the
> > > power
> > > button until you reproduce the problem.
> > > 
> > > 
> > > Im using the PCBSD USBLite 9.1 Beta1 LXDE ZFS
> > > 
> > > 
> > > _______________________________________________
> > > 
> > > Testing mailing list Testing at lists.pcbsd.org
> > > http://lists.pcbsd.org/mailman/listinfo/testing
> > 
> > It shouldn't be writing anything to the USB media, its all mounted
> > read-only and then using memfs. I'll test it here, but it may have
> > been a fluke of something getting corrupted on the media.
> > 
> > --
> > Kris Moore
> > PC-BSD Software
> > iXsystems
> 
> I have run into the same thing multiple times (during the FreeBSD
> Server/ZFS issue i'm working on). fsck_ufs does fix the problem, but I was
> surprised to see it, as i thought the usb media should have been mounted
> read-only as well.

I confirm this. fsck_ufs fixes the issue.

Regards,
Vans.


More information about the Testing mailing list