[PC-BSD Testing] PCBSD9 and Eclipse

Kris Moore kris at pcbsd.org
Mon Feb 13 07:59:31 PST 2012


On 02/12/2012 09:27, Ron Georgia wrote:
> All,
>
> I am using PCBSD 9.0 (fresh install) amd64. I installed Eclipse from
> PBI and everything installed nicely. The first launch of eclipse
> worked. I was able to add Ruby and PyDev without a problem. However
> when I performed an update (for eclipse) the binary file was removed
> from the /usr/pbi/eclipse-amd64/lib/eclipse directory. When I launch
> from the command line I get this message (of course):
>
> Error: ECLIPSE_HOME is not defined correctly:
> /usr/pbi/eclipse-amd64/lib/eclipse
>        Unable to find eclipse launcher binary
>
> I reinstalled and copied the original binary, did the update (binary
> now gone) and copied the original binary to its proper location, and
> of course that generates a different error.
>
> After the "upgrade" I did a sudo find / -name eclipse -type f -print,
> alas! The file is gone. Any suggestions?
>
> Regards,
>
> Ron G
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing

I did some playing with this the other day, and it looks like this PBI
needed to be installed with root mode, otherwise when you do updates, it
trashes all kinds of its internal java files.

Grab one of these and install it as root to test:

64bit
ftp://ftp.pcbsd.org/pub/pbioutgoing/x64/9/java/eclipse/
32bit
ftp://ftp.pcbsd.org/pub/pbioutgoing/i386/9/java/eclipse/
<ftp://ftp.pcbsd.org/pub/pbioutgoing/x64/9/java/eclipse/>

-- 
Kris Moore
PC-BSD Software
iXsystems

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20120213/019238c4/attachment.html>


More information about the Testing mailing list