[PC-BSD Testing] PCBSD 9.1-x86 trial (Re: PCBSD9.1-x86-USBFULL.img.bz2 not bootable (after > bunzip2'ing))

Sam Lin semin2006 at gmail.com
Fri Dec 28 12:25:40 PST 2012


Hi Kris,

You might also want to check all i386 images as well as I have tried to  
directly upgrade from 9.1 to 9.1 and ended up unable to boot the system.  
(It says fatal error and find no screens or whatsoever... should have  
taken a picture)

I then tried clean install using 9.1-i386-dvd and ended up with quite a  
few issues. FYI below is my system:

Laptop: Compaq Presario 2166ae (8.5+ years old!)
CPU: AMD Athlon XP-M 2400+
RAM: 1GB
HD: 120GB
VGA: Ati Mobility IGP (cannot recall the model for now)
Wireless: usb wireless dongle TP-Link TL-WN321G (worked on PCBSD 9.0)

In short:

1. First I picked xfce and Enlightenment 17 to be installed and then  
picked xfce [desktop] and Chinese_tw [language] when logging into the  
system. The interface, or more specifically the font, is utterly ugly. The  
English alphabets and numerals appear as huge as a Chinese letter. Same  
for Chinese_cn mode. In Japanese mode on the other hand these characters  
appear properly. (Will upload the screenshots somewhere later).

2. In xfce the bottom toolbar didn't have any icon; it's just a short  
empty toolbar. Also there is no top toolbar at all so I could only open a  
tool menu by right click on desktop.

3. The mouse cursor blinks when I move it around the desktop or  
everywhere. To be more precise it blinks with any of my action - I click  
on desktop (even if there is nothing on that spot) and the cursor  
disappears and I move the mouse a bit and the cursor reappears again. The  
blinking is rather obvious and distracting if I move my mouse slowly. This  
is especially annoying when doing my work as the cursor just disappears  
whenever I click on menu button in any application and I have to "call  
back" the cursor by deliberately click / move my mouse.

4. Then I tried logout xfce and then login to Enlightenment 17. The  
Chinese_tw mode still looks unbearable, so I tried to logout and was about  
to login into E17 again but in English mode. Then alas E17 appears freeze  
- the E17 login splash screen seems still working (the light points in the  
splash screen keep bouncing) but it never get into E17 desktop forever.  
The harddrive seems no I/O. I had to switch to another terminal  
(Ctrl+Alt+F2) and reboot the whole system again. After reboot and try E17  
again, it still freezed at the same stage.

So I tried to re-install the whole 9.1 again but this time without xfce as  
well as Asian languages i.e. also installed E17 in English mode. But again  
after installation I was able to login to E17 desktop but then failed  
after logout and re-login (or reboot).

Also in E17 the cursor blinks - both at post-installation configuration  
stage and on E17 desktop. This is obviously not due to E17 or xfce but  
more likely because of X or somewhere else.

5. The wifi didn't work - the icon appeared "associated" but the network  
actually was not connected so I could not even connect to AppCafe server.  
I have tried several settings but none of them worked. Also the network  
configuration appeared sluggish - whenever I clicked the "apply" button  
(regardless of whether I have done any change in the window) it just tried  
to restart the network and the system appeared freeze for awhile, and then  
ended up with nothing. This laptop used to be able to connect wifi on 9.0.

6. During the installation the system failed to set the monitor properly.  
Apparently it detected the Ati video chipset but somehow it didn't work.  
So I was forced to use vesa rather than other ati, ati-3d-enable etc  
drivers. Also I noticed that after the system tried to use ati driver and  
failed, the colour for all buttons in the following window appears funny.  
(Will upload the screen shot somewhere later).

7. Haven't tried audio yet as I am not able to access to the internet e.g.  
youtube to try it out.

Regards,
Sam

> Date: Thu, 27 Dec 2012 18:01:52 -0500
> From: Kris Moore <kris at pcbsd.org>
> To: productnews at hvf.ch
> Cc: testing at lists.pcbsd.org
> Subject: Re: [PC-BSD Testing] PCBSD9.1-x86-USBFULL.img.bz2 not
> 	bootable (after bunzip2'ing)
> Message-ID: <50DCD360.2040902 at pcbsd.org>
> Content-Type: text/plain; charset=ISO-8859-15
>
> On 12/27/2012 05:31, Productnews wrote:
>>
>> Am 26.12.2012 19:36, schrieb Kris Moore:
>>> On 12/26/2012 13:08, Productnews wrote:
>>>> After the disastrous update exercise (9.1-RC3 to 9.1, see my earlier
>>>> mails) I downloaded (10 hours over cable modem) and verified  (md5)
>>>> PCBSD9.1-x86-USBFULL.img.bz2 before unbunzing and copying to an 8 GB  
>>>> USB
>>>> stick.
>>>> I found that there is *NO BOOTBLOCK* on the image (first 8kB is zero).
>>>> The image is not bootable by any stretch of the imagination.
>>>>
>>>> I am sorry to say that this release has apparently not undergone any  
>>>> QA
>>>> before publication. I cannot continue testing PCBSD under these
>>>> circumstances.
>>>>
>>>> Sorry for that
>>>>
>>>> Harald
>>>> _______________________________________________
>>>> Testing mailing list
>>>> Testing at lists.pcbsd.org
>>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>> Thanks for the heads up! I've found the problem are are re-rolling the
>>> x86 images. The x64 one should be fine, it was something in particular
>>> related to the 32bit builds failing to stamp the boot-blocks.
>>>
>> Is there a way to "upgrade" my downloaded file once the corrected
>> versions are available? I cannot download large files for the next 3
>> weeks or so (only satellite link with quota!). What abut copying the
>> first 8k or so?
>>
>> Harald
>>
> Harald,
>
> If you have another FreeBSD system, it should be possible to "stamp" the
> boot-sector on the USB media.
>
> Use this command:
>
> # gpart bootcode -b /boot/boot /dev/da0
>
> BTW, a new image is going to the mirrors now with this fix, and should
> be online in 24 hours or so. I'll make double-sure we test these in the
> future. Most of our testing is done with the 64bit stuff now, and these
> built successfully, but the boot-stamping had silently failed :(
>


-- 
Using Opera's revolutionary email client: http://www.opera.com/mail/


More information about the Testing mailing list