[PC-BSD Testing] KDE problem solved - Re: Cannot login after upgrade to PC-BSD 9.0-BETA2

Productnews productnews at hvf.ch
Tue Sep 27 03:17:06 PDT 2011


1. The problem with KDE has been solved: I disable the AIGLX option

in /etc/X11/xorg.conf

option     "AIGLX"  "false"

KDE now works, and so does GNOME.

2. Fluxbox still crashes with this info in ~/.xession-errors

/usr/local/etc/gdm/Xsession: Beginning session setup...
To see how much disk space is left on your partitions, use

     df -h
         -- Dru <genesis at istar.ca>
Setting the mixer ogain from 100:100 to 100:100.
/usr/local/etc/gdm/Xsession: Setup done, will execute: 
/usr/bin/ssh-agent -- startfluxbox
Locale: "de"
Starting Tray Application
pc-systemupdatertray: Fatal IO error: client killed
[idesk] Background's file not found.
[idesk] Background's source not found.
XIO:  fatal IO error 22 (Invalid argument) on X server ":0.0"
       after 14 requests (14 known processed) with 0 events remaining.
Locale: "de"
Application starting...

... and then the login screen reappears. Seems that idesk has some problems.

3. The upgraded Thunderbird 6.0.2 still does not save the account 
settings and thus remains unusable.

4. I still cannot use the beautiful TERMINAL font in any of the usual 
consoles, like KDE konsole 2.4.6, gnome-terminal 2.32.1, Xfce Terminal 
0.4.8, but I can configure it for xterm with

xterm -fn -bitstream-terminal-medium-*-*-*-*-*-*-*-*-*-iso8859-*

On PCBSD Hubble and FreeBSD 8.2 the TERMINAL font works both for konsole 
and gnome-terminal - is this because I have locally upgraded these 
systems and recompiled everything in the ports tree??

5. The KDE menu buttons for system reboot and shutdown looked much 
smarter in Hubble than they do now (now it's the standard KDE buttons). 
In fact it was the smart buttons that attracted my attention to PCBSD 
some years ago. I wish they came back to Isotope...

thanks, Harald

On 17.09.2011 12:10, Lars Engels wrote:
> On Thu, Sep 15, 2011 at 12:58:53PM +0200, Productnews wrote:
>> Hi
>>
>> I upgraded from BETA1.5 to BETA2 using the cmd line (as root)
>>
>> # pc-updatemanager install release-9.0-BETA2
>>
>> After a night's long download and two reboots, the system came up with
>> the usual login screen. After logging in, the KDE Isotope screen
>> appears, and after some seconds the X server dies and restarts with the
>> login screen.
>> Using a different user account than my usual one does not help.
>>
>> Graphics controller: VGA compatible controller: Intel Corporation
>> 82915G/GV/910GL Integrated Graphics Controller (rev 04), screen is
>> 1680x1050
>>
>> Do I have to do a full install (again)?
> I have the same issue. But after editing xorg.conf and removing the 3D
> support there, KDE starts. I also have an intel graphics chipset.



More information about the Testing mailing list