[PC-BSD Testing] PCBSD 9 beta2 x64 - installation problem - no HDD detected

rascal rascal at tiscali.cz
Sat Sep 24 04:25:40 PDT 2011



Dne 23.9.2011 16:29, Kris Moore napsal(a):
> On 09/21/11 17:50, rascal wrote:
>>
>> Dne 21.9.2011 14:58, Kris Moore napsal(a):
>>> On 09/19/11 17:54, rascal wrote:
>>>> Hi!
>>>> I tried 9.0-beta2 32bit USB installer and I have the same problem, no
>>>> HDD detected (the x64 versions I tried before were beta2 of course, I
>>>> made a typo in subject).
>>>>
>>>> I'd aprieciate any help.
>>>>
>>>> thank you.
>>>>
>>>> MM
>>>>
>>>> Dne 18.9.2011 23:23, rascal napsal(a):
>>>>> Hi!
>>>>>
>>>>> During the weekend I downloaded usb installation image and tried to
>>>>> install on 3rd partition (primary), but the installer showed only the
>>>>> usb drive itself as available storage. I tried more times to be sure.
>>>>>
>>>>> I assumed the usb installer is not good, so I grabbed the dvd ISO
>>>>> (again x64) and this time the installer did not show any available
>>>>> storage (no hdd was detected probably).
>>>>>
>>>>> I will try 32bit images in upcoming days, but I'd be happy for a
>>>>> advice.
>>>>>
>>>>> I have lenovo thinkpad r61 laptop with sata 250GB HDD. and I
>>>>> previously used windows xp (using at the moment), ubuntu, pcbsd,
>>>>> desktopbsd on my laptop and never had issues with my hard drive.
>>>>>
>>>>> I will add that I installed AiR-boot bootmanager (I had no success
>>>>> with GAG and I dont like its graphical interface), but in ideal case
>>>>> the boot manager should not interfere with hdd detection, right?
>>>>>
>>>>> Thx for any advice in advance.
>>>>>
>>>>> Michal M.
>>> Michal,
>>>
>>> Can you boot the installer, right click on the wallpaper and bring up
>>> xterm? Then send along the output of
>>> the following commands:
>>>
>>> # gpart show
>>> # ls /dev/ad*
>>> # ls /dev/da*
>>>
>> Thank you Kris for replying to my mail.
>> I did what you asked for using 32bit USB installer for 9.0-beta2, here
>> are the results:
>> # gpart show
>> =>       63  15646657  da0  MBR  (7.5G)
>>          63   8080632    1  freebsd  [active]  (3.9G)
>>     8080695   7566025       - free -  (3.6G)
>>
>> =>       0  8080632  da0s1  BSD  (3.9G)
>>          0       16         - free -  (8.0k)
>>         16  8080616      1  !0  (3.9G)
>>
>> =>        1  15695870  da1  MBR  (7.5G)
>>           1        61       - free -  (30k)
>>          62  15683458    1  fat32  [active]  (7.5G)
>>    15683520     12351       - free -  (6.0M)
>>
>> # ls /dev/ad*
>> ls: No match.
>>
>> # ls /dev/da*
>> /dev/da0
>> /dev/da0s1
>> /dev/da0s1a
>> /dev/da1
>> /dev/da1s1
>>
>>
>> da0 is the usb drive that contains the installation image file.
>> da1 is empty usb drive which I used to store the results from this
>> commands.
>>
>> Finally I'll add result from dmesg.
>>
>> IMHO there is too much mess with that KDB thing. I also changed
>> air-boot to gag just to be sure, but I had identical results I
>> switched back to air-boot. I did some partition resizing using gparted
>> on sysresccd, maybe I screwed something up?
>>
>> thank you for the advice
>>
>> Michal M.
> Well, looking at those logs shows that it indeed is finding no disk
> drives :( Do you have any BIOS settings that you can change for IDE/AHCI
> mode or similar?
>

Hi, actually sata settings in BIOS were set to "compatibility" mode. I 
hade it so for years, because problems with windows XP.
When I changed bios settings to AHCI, the installer could see my HDD and 
I installed PCBSD. The problem is windows xp boots only with 
compatibility mode and pcbsd boots only in AHCI mode. I'm currently 
trying to update some drivers in windows to make it work in ahci, so I 
can use both.

So from my perspective something was changed in freebsd 9 that it does 
not detect my HDD in compatibility mode. Not a big issue for me, but 
COULD be for some new users...

some things I noticed when installing PCBSD-9.0beta2-x86-USBFULL

1) live system boots quite fast, its nice.
2) installation took WAY TOO LONG. I chose to install all 4 desktop 
environments, but I was installing from pretty fast flash drive and it 
took aprox 30-40 minutes.
3) graphic card wizard works well, it used to hang on my laptop all the 
time when I chose nvidia driver, but this time was just working nice.
4) easy to set-up wifi connection (intel iwn driver), really nice.
5) no boot manager - I'm using AiR-boot and it's really nice text boot 
manager, which fits into MBR (alternative to GAG). Since pcbsd has no 
boot manager, maybe you can offer an option in installer to install 
air-boot (I think the .bin file could be "dd-ed" into MBR, right?). I'm 
not sure about licencing issues though, its GPLv3.

In general I'm very impressed, easy installation, nice results. I'll try 
cathing up with czech translations in pootle before next beta.

Michal M.


More information about the Testing mailing list