[PC-BSD Testing] PCBSD 9 beta2 x64 - installation problem - no HDD detected

rascal rascal at tiscali.cz
Wed Sep 21 14:50:10 PDT 2011



Dne 21.9.2011 14:58, Kris Moore napsal(a):
> On 09/19/11 17:54, rascal wrote:
>> Hi!
>> I tried 9.0-beta2 32bit USB installer and I have the same problem, no
>> HDD detected (the x64 versions I tried before were beta2 of course, I
>> made a typo in subject).
>>
>> I'd aprieciate any help.
>>
>> thank you.
>>
>> MM
>>
>> Dne 18.9.2011 23:23, rascal napsal(a):
>>> Hi!
>>>
>>> During the weekend I downloaded usb installation image and tried to
>>> install on 3rd partition (primary), but the installer showed only the
>>> usb drive itself as available storage. I tried more times to be sure.
>>>
>>> I assumed the usb installer is not good, so I grabbed the dvd ISO
>>> (again x64) and this time the installer did not show any available
>>> storage (no hdd was detected probably).
>>>
>>> I will try 32bit images in upcoming days, but I'd be happy for a advice.
>>>
>>> I have lenovo thinkpad r61 laptop with sata 250GB HDD. and I
>>> previously used windows xp (using at the moment), ubuntu, pcbsd,
>>> desktopbsd on my laptop and never had issues with my hard drive.
>>>
>>> I will add that I installed AiR-boot bootmanager (I had no success
>>> with GAG and I dont like its graphical interface), but in ideal case
>>> the boot manager should not interfere with hdd detection, right?
>>>
>>> Thx for any advice in advance.
>>>
>>> Michal M.
>
> Michal,
>
> Can you boot the installer, right click on the wallpaper and bring up
> xterm? Then send along the output of
> the following commands:
>
> # gpart show
> # ls /dev/ad*
> # ls /dev/da*
>

Thank you Kris for replying to my mail.
I did what you asked for using 32bit USB installer for 9.0-beta2, here 
are the results:
# gpart show
=>      63  15646657  da0  MBR  (7.5G)
         63   8080632    1  freebsd  [active]  (3.9G)
    8080695   7566025       - free -  (3.6G)

=>      0  8080632  da0s1  BSD  (3.9G)
         0       16         - free -  (8.0k)
        16  8080616      1  !0  (3.9G)

=>       1  15695870  da1  MBR  (7.5G)
          1        61       - free -  (30k)
         62  15683458    1  fat32  [active]  (7.5G)
   15683520     12351       - free -  (6.0M)

# ls /dev/ad*
ls: No match.

# ls /dev/da*
/dev/da0
/dev/da0s1
/dev/da0s1a
/dev/da1
/dev/da1s1


da0 is the usb drive that contains the installation image file.
da1 is empty usb drive which I used to store the results from this commands.

Finally I'll add result from dmesg.

IMHO there is too much mess with that KDB thing. I also changed air-boot to gag just to be sure, but I had identical results I switched back to air-boot. I did some partition resizing using gparted on sysresccd, maybe I screwed something up?

thank you for the advice

Michal M.
  
# dmesg
Copyright (c) 1992-2011 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.0-BETA2 #6: Sat Sep  3 17:23:58 UTC 2011
     root at build9x64.pcbsd.org:/usr/obj/pcbsd-build90/fbsd-source/9.0/sys/GENERIC i386
WARNING: WITNESS option enabled, expect reduced performance.
CPU: Intel(R) Core(TM)2 Duo CPU     T7100  @ 1.80GHz (1795.54-MHz 686-class CPU)
   Origin = "GenuineIntel"  Id = 0x6fd  Family = 6  Model = f  Stepping = 13
   Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
   Features2=0xe3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM>
   AMD Features=0x20100000<NX,LM>
   AMD Features2=0x1<LAHF>
   TSC: P-state invariant, performance statistics
real memory  = 2147483648 (2048 MB)
avail memory = 2051321856 (1956 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table:<LENOVO TP-7K>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
  cpu0 (BSP): APIC ID:  0
  cpu1 (AP): APIC ID:  1
ACPI Warning: 32/64X length mismatch in Gpe1Block: 0/32 (20110527/tbfadt-556)
ACPI Warning: Optional field Gpe1Block has zero address or length: 0x000000000000102C/0x0 (20110527/tbfadt-586)
ioapic0: Changing APIC ID to 1
ioapic0<Version 2.0>  irqs 0-23 on motherboard
kbd1 at kbdmux0
cryptosoft0:<software crypto>  on motherboard
acpi0:<LENOVO TP-7K>  on motherboard
CPU0: local APIC error 0x40
acpi_ec0:<Embedded Controller: GPE 0x12, ECDT>  port 0x62,0x66 on acpi0
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 7ff00000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0:<24-bit timer at 3.579545MHz>  port 0x1008-0x100b on acpi0
cpu0:<ACPI CPU>  on acpi0
cpu1:<ACPI CPU>  on acpi0
acpi_lid0:<Control Method Lid Switch>  on acpi0
acpi_button0:<Sleep Button>  on acpi0
pcib0:<ACPI Host-PCI bridge>  port 0xcf8-0xcff on acpi0
pci0:<ACPI PCI bus>  on pcib0
pcib1:<ACPI PCI-PCI bridge>  irq 16 at device 1.0 on pci0
pci1:<ACPI PCI bus>  on pcib1
vgapci0:<VGA-compatible display>  port 0x2000-0x207f mem 0xd6000000-0xd6ffffff,0xe0000000-0xefffffff,0xd4000000-0xd5ffffff irq 16 at device 0.0 on pci1
em0:<Intel(R) PRO/1000 Network Connection 7.2.3>  port 0x1800-0x181f mem 0xfe200000-0xfe21ffff,0xfe224000-0xfe224fff irq 20 at device 25.0 on pci0
em0: Using an MSI interrupt
acquiring duplicate lock of same type: "network driver"
  1st&dev_spec->swflag_mutex @ /pcbsd-build90/fbsd-source/9.0/sys/dev/e1000/e1000_ich8lan.c:785
  2nd&dev_spec->nvm_mutex @ /pcbsd-build90/fbsd-source/9.0/sys/dev/e1000/e1000_ich8lan.c:751
KDB: stack backtrace:
db_trace_self_wrapper(c0f00262,392f6563,732f302e,642f7379,652f7665,...) at db_trace_self_wrapper+0x26
kdb_backtrace(c0a419bb,c0f03c88,c0e89fb2,c7561fd8,c34207fc,...) at kdb_backtrace+0x2a
_witness_debugger(c0f03c88,c0e89fef,c0e89fb2,2ef,c0f041ad,...) at _witness_debugger+0x25
witness_checkorder(c77ce460,9,c0e89fb2,2ef,0,...) at witness_checkorder+0x469
_mtx_lock_flags(c77ce460,0,c0e89fb2,2ef,c3420868,...) at _mtx_lock_flags+0xc4
e1000_acquire_nvm_ich8lan(c77ca004,c77ce474,0,c0e89fb2,0,...) at e1000_acquire_nvm_ich8lan+0x2e
e1000_read_nvm_ich8lan(c77ca004,40,1,c3420890,a004,...) at e1000_read_nvm_ich8lan+0x59
e1000_post_phy_reset_ich8lan(c77ca004,c77ce48c,0,c0a12990,0,...) at e1000_post_phy_reset_ich8lan+0x7b4
e1000_reset_hw_ich8lan(c77ca004,c34209c0,c066b6b2,c77ca004,0,...) at e1000_reset_hw_ich8lan+0x2c2
e1000_reset_hw(c77ca004,0,1,ffffffff,ffffffff,...) at e1000_reset_hw+0x1a
em_attach(c77a6780,c772085c,c1025d70,c0ed7890,80000003,...) at em_attach+0x13b2
device_attach(c77a6780,4,c0eff414,a55) at device_attach+0x36f
device_probe_and_attach(c77a6780,c7667b00,c3420a60,c0501da4,c77a6900,...) at device_probe_and_attach+0x4e
bus_generic_attach(c77a6900,c775c600,1,c0501a70,0,c77a6900,0,c775c600) at bus_generic_attach+0x19
acpi_pci_attach(c77a6900,c769c85c,c1025d70,c0ed7890,80000003,...) at acpi_pci_attach+0x194
device_attach(c77a6900,4,c0eff414,a55) at device_attach+0x36f
device_probe_and_attach(c77a6900,c7538300,c3420af4,c0503d94,c7667b00,...) at device_probe_and_attach+0x4e
bus_generic_attach(c7667b00,c0f43e91,0,c3420ae4,c775c600,...) at bus_generic_attach+0x19
acpi_pcib_attach(c7667b00,c76d4554,0,c76d4540,2,...) at acpi_pcib_attach+0x194
acpi_pcib_acpi_attach(c7667b00,c76c005c,c1025d70,c0ed7890,80000003,...) at acpi_pcib_acpi_attach+0x2c6
device_attach(c7667b00,4,c0eff414,a55) at device_attach+0x36f
device_probe_and_attach(c7667b00,0,c3420c20,c04f8b32,c7538300,...) at device_probe_and_attach+0x4e
bus_generic_attach(c7538300,c102dae0,c0f70aa0,3,c771ba08,...) at bus_generic_attach+0x19
acpi_attach(c7538300,c76c085c,c1025d70,c0ed7890,80000003,...) at acpi_attach+0xdd2
device_attach(c7538300,4,c0eff414,a55) at device_attach+0x36f
device_probe_and_attach(c7538300,c7538780,c3420ca8,c0d2135e,c7538780,...) at device_probe_and_attach+0x4e
bus_generic_attach(c7538780,a,c0d7bd59,0) at bus_generic_attach+0x19
nexus_acpi_attach(c7538780,c76e385c,c1025d70,c0ed7890,80000003,...) at nexus_acpi_attach+0x7e
device_attach(c7538780,4,c0eff414,a55) at device_attach+0x36f
device_probe_and_attach(c7538780,c7538d00,c7538d00,c7547e00,c7538d00,...) at device_probe_and_attach+0x4e
bus_generic_new_pass(c7538d00,c7582800,c1025ca0,c7590778,fffffff,...) at bus_generic_new_pass+0xc5
bus_set_pass(7fffffff,c3420d5c,c0d2241c,c10b3030,c3420d78,...) at bus_set_pass+0x81
root_bus_configure(c10b3030,c3420d78,c09bdecc,0,341ec00,...) at root_bus_configure+0x12
configure(0,341ec00,341ec00,341e000,3425000,...) at configure+0xc
mi_startup() at mi_startup+0xac
begin() at begin+0x2c
em0: Ethernet address: 00:1a:6b:cd:99:65
uhci0:<Intel 82801H (ICH8) USB controller USB-D>  port 0x1820-0x183f irq 20 at device 26.0 on pci0
usbus0:<Intel 82801H (ICH8) USB controller USB-D>  on uhci0
uhci1:<Intel 82801H (ICH8) USB controller USB-E>  port 0x1840-0x185f irq 21 at device 26.1 on pci0
usbus1:<Intel 82801H (ICH8) USB controller USB-E>  on uhci1
ehci0:<Intel 82801H (ICH8) USB 2.0 controller USB2-B>  mem 0xfe225000-0xfe2253ff irq 22 at device 26.7 on pci0
usbus2: EHCI version 1.0
usbus2:<Intel 82801H (ICH8) USB 2.0 controller USB2-B>  on ehci0
hdac0:<Intel 82801H High Definition Audio Controller>  mem 0xfe220000-0xfe223fff irq 17 at device 27.0 on pci0
pcib2:<ACPI PCI-PCI bridge>  irq 20 at device 28.0 on pci0
pci2:<ACPI PCI bus>  on pcib2
pcib3:<ACPI PCI-PCI bridge>  irq 21 at device 28.1 on pci0
pci3:<ACPI PCI bus>  on pcib3
iwn0:<Intel(R) Wireless WiFi Link 4965>  mem 0xdf2fe000-0xdf2fffff irq 17 at device 0.0 on pci3
pcib4:<ACPI PCI-PCI bridge>  irq 22 at device 28.2 on pci0
pci4:<ACPI PCI bus>  on pcib4
pcib5:<ACPI PCI-PCI bridge>  irq 23 at device 28.3 on pci0
pci5:<ACPI PCI bus>  on pcib5
pcib6:<ACPI PCI-PCI bridge>  irq 20 at device 28.4 on pci0
pci13:<ACPI PCI bus>  on pcib6
uhci2:<Intel 82801H (ICH8) USB controller USB-A>  port 0x1860-0x187f irq 16 at device 29.0 on pci0
usbus3:<Intel 82801H (ICH8) USB controller USB-A>  on uhci2
uhci3:<Intel 82801H (ICH8) USB controller USB-B>  port 0x1880-0x189f irq 17 at device 29.1 on pci0
usbus4:<Intel 82801H (ICH8) USB controller USB-B>  on uhci3
uhci4:<Intel 82801H (ICH8) USB controller USB-C>  port 0x18a0-0x18bf irq 18 at device 29.2 on pci0
usbus5:<Intel 82801H (ICH8) USB controller USB-C>  on uhci4
ehci1:<Intel 82801H (ICH8) USB 2.0 controller USB2-A>  mem 0xfe225400-0xfe2257ff irq 19 at device 29.7 on pci0
usbus6: EHCI version 1.0
usbus6:<Intel 82801H (ICH8) USB 2.0 controller USB2-A>  on ehci1
pcib7:<ACPI PCI-PCI bridge>  at device 30.0 on pci0
pci21:<ACPI PCI bus>  on pcib7
cbb0:<RF5C476 PCI-CardBus Bridge>  mem 0xf8100000-0xf8100fff irq 16 at device 0.0 on pci21
cardbus0:<CardBus bus>  on cbb0
pccard0:<16-bit PCCard bus>  on cbb0
fwohci0:<1394 Open Host Controller Interface>  mem 0xf8101000-0xf81017ff irq 17 at device 0.1 on pci21
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:06:1b:03:2a:14:40:ef
fwohci0: Phy 1394a available S400, 1 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0:<IEEE1394(FireWire) bus>  on fwohci0
fwe0:<Ethernet over FireWire>  on firewire0
if_fwe0: Fake Ethernet address: 02:06:1b:14:40:ef
fwe0: Ethernet address: 02:06:1b:14:40:ef
fwip0:<IP over FireWire>  on firewire0
fwip0: Firewire address: 00:06:1b:03:2a:14:40:ef @ 0xfffe00000000, S400, maxrec 2048
sbp0:<SBP-2/SCSI over FireWire>  on firewire0
dcons_crom0:<dcons configuration ROM>  on firewire0
dcons_crom0: bus_addr 0x348c000
fwohci0: Initiate bus reset
fwohci0: fwohci_intr_core: BUS reset
fwohci0: fwohci_intr_core: node_id=0x00000000, SelfID Count=1, CYCLEMASTER mode
sdhci0:<RICOH R5C822 SD>  mem 0xf8101800-0xf81018ff irq 18 at device 0.2 on pci21
sdhci0: 1 slot(s) allocated
pci21:<base peripheral>  at device 0.3 (no driver attached)
pci21:<base peripheral>  at device 0.4 (no driver attached)
pci21:<base peripheral>  at device 0.5 (no driver attached)
isab0:<PCI-ISA bridge>  at device 31.0 on pci0
isa0:<ISA bus>  on isab0
atapci0:<Intel ICH8M SATA300 controller>  port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1c00-0x1c0f,0x18f0-0x18ff at device 31.2 on pci0
ata0:<ATA channel 0>  on atapci0
ata1:<ATA channel 1>  on atapci0
pci0:<serial bus, SMBus>  at device 31.3 (no driver attached)
acpi_tz0:<Thermal Zone>  on acpi0
acpi_tz1:<Thermal Zone>  on acpi0
attimer0:<AT timer>  port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
hpet0:<High Precision Event Timer>  iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 450
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
atrtc0:<AT realtime clock>  port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
atkbdc0:<Keyboard controller (i8042)>  port 0x60,0x64 irq 1 on acpi0
atkbd0:<AT Keyboard>  irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0:<PS/2 Mouse>  flags 0x1000 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
battery0:<ACPI Control Method Battery>  on acpi0
acpi_acad0:<AC Adapter>  on acpi0
pmtimer0 on isa0
sc0:<System console>  at flags 0x100 on isa0
sc0: VGA<16 virtual consoles, flags=0x300>
vga0:<Generic ISA VGA>  at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
est0:<Enhanced SpeedStep Frequency Control>  on cpu0
p4tcc0:<CPU Frequency Thermal Control>  on cpu0
est1:<Enhanced SpeedStep Frequency Control>  on cpu1
p4tcc1:<CPU Frequency Thermal Control>  on cpu1
firewire0: 1 nodes, maxhop<= 0 cable IRM irm(0)  (me)
firewire0: bus manager 0
ZFS NOTICE: Prefetch is disabled by default on i386 -- to enable,
             add "vfs.zfs.prefetch_disable=0" to /boot/loader.conf.
ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
              Consider tuning vm.kmem_size and vm.kmem_size_max
              in /boot/loader.conf.
ZFS filesystem version 5
ZFS storage pool version 28
Timecounters tick every 1.000 msec
hdac0: HDA Codec #0: Analog Devices AD1984
hdac0: HDA Codec #1: Conexant (Unknown)
pcm0:<HDA Analog Devices AD1984 PCM #0 Analog>  at cad 0 nid 1 on hdac0
pcm1:<HDA Analog Devices AD1984 PCM #1 Digital>  at cad 0 nid 1 on hdac0
md0: Preloaded image</boot/mfsroot>  28672000 bytes at 0xc1679b50
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 480Mbps High Speed USB v2.0
usbus3: 12Mbps Full Speed USB v1.0
usbus4: 12Mbps Full Speed USB v1.0
usbus5: 12Mbps Full Speed USB v1.0
usbus6: 480Mbps High Speed USB v2.0
ugen0.1:<Intel>  at usbus0
uhub0:<Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>  on usbus0
ugen1.1:<Intel>  at usbus1
uhub1:<Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>  on usbus1
ugen2.1:<Intel>  at usbus2
uhub2:<Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1>  on usbus2
ugen3.1:<Intel>  at usbus3
uhub3:<Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>  on usbus3
ugen4.1:<Intel>  at usbus4
uhub4:<Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>  on usbus4
ugen5.1:<Intel>  at usbus5
uhub5:<Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>  on usbus5
ugen6.1:<Intel>  at usbus6
uhub6:<Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1>  on usbus6
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
uhub4: 2 ports with 2 removable, self powered
uhub5: 2 ports with 2 removable, self powered
uhub2: 4 ports with 4 removable, self powered
uhub6: 6 ports with 6 removable, self powered
ugen0.2:<TouchStrip>  at usbus0
ugen2.2:<vendor 0x13fe>  at usbus2
umass0:<vendor 0x13fe Patriot Memory, class 0/0, rev 2.00/1.00, addr 2>  on usbus2
umass0:  SCSI over Bulk-Only; quirks = 0x0000
umass0:3:0:-1: Attached to scbus3
da0 at umass-sim0 bus 0 scbus3 target 0 lun 0
da0:<  Patriot Memory PMAP>  Removable Direct Access SCSI-0 device
da0: 40.000MB/s transfers
da0: 7640MB (15646720 512 byte sectors: 255H 63S/T 973C)
cd0 at ata1 bus 0 scbus2 target 0 lun 0
cd0:<HL-DT-ST DVDRAM GMA-4082N PX07>  Removable CD-ROM SCSI-0 device
cd0: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present
SMP: AP CPU #1 Launched!
WARNING: WITNESS option enabled, expect reduced performance.
ugen3.2:<Microsoft>  at usbus3
ukbd0:<Microsoft Microsoft Nano Transceiver v2.0, class 0/0, rev 2.00/6.34, addr 2>  on usbus3
kbd2 at ukbd0
ums0:<Microsoft Microsoft Nano Transceiver v2.0, class 0/0, rev 2.00/6.34, addr 2>  on usbus3
ums0: 5 buttons and [XYZT] coordinates ID=26
ums0: 0 buttons and [T] coordinates ID=0
uhid0:<Microsoft Microsoft Nano Transceiver v2.0, class 0/0, rev 2.00/6.34, addr 2>  on usbus3
GEOM: da0s1: geometry does not match label (128h,63s != 255h,63s).
Trying to mount root from ufs:/dev/ufs/ROOTFS []...
g_vfs_done():cd0[READ(offset=32768, length=2048)]error = 6
md1.uzip: 18241 x 65536 blocks
nvidia0:<Quadro NVS 140M>  on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
lock order reversal:
  1st 0xc7a3c278 ufs (ufs) @ /pcbsd-build90/fbsd-source/9.0/sys/kern/vfs_mount.c:1194
  2nd 0xc7f1b388 devfs (devfs) @ /pcbsd-build90/fbsd-source/9.0/sys/ufs/ffs/ffs_vfsops.c:1371
KDB: stack backtrace:
db_trace_self_wrapper(c0f00262,72756f73,392f6563,732f302e,752f7379,...) at db_trace_self_wrapper+0x26
kdb_backtrace(c0a419bb,c0f03d95,c7569f00,c7569e30,e131aa1c,...) at kdb_backtrace+0x2a
_witness_debugger(c0f03d95,c7f1b388,c0eea341,c7569e30,c0f32a50,...) at _witness_debugger+0x25
witness_checkorder(c7f1b388,9,c0f32a50,55b,c7f1b3a8,...) at witness_checkorder+0x839
__lockmgr_args(c7f1b388,80400,c7f1b3a8,0,0,...) at __lockmgr_args+0x824
vop_stdlock(e131ab3c,c09f8984,c10b3c9c,80400,c7f1b330,...) at vop_stdlock+0x62
VOP_LOCK1_APV(c1020520,e131ab3c,c80b9220,c105aea0,c7f1b330,...) at VOP_LOCK1_APV+0xb5
_vn_lock(c7f1b330,80400,c0f32a50,55b,c77dc400,...) at _vn_lock+0x5e
ffs_flushfiles(c7f56000,0,c7f88b80,0,c7f56000,...) at ffs_flushfiles+0xa7
ffs_unmount(c7f56000,8000000,c0f0b422,4ef,c7424000,...) at ffs_unmount+0x180
dounmount(c7f56000,8000000,c7f88b80,474,285786c1,...) at dounmount+0x4a1
unmount(c7f88b80,e131acec,28178385,1,0,...) at unmount+0x331
syscallenter(c7f88b80,e131ace4,c0d3cb0d,c1095d10,0,...) at syscallenter+0x263
syscall(e131ad28) at syscall+0x34
Xint0x80_syscall() at Xint0x80_syscall+0x21
--- syscall (22, FreeBSD ELF32, unmount), eip = 0x280de99b, esp = 0xbfbfe63c, ebp = 0xbfbfe708 ---
lock order reversal:
  1st 0xe0f11878 bufwait (bufwait) @ /pcbsd-build90/fbsd-source/9.0/sys/kern/vfs_bio.c:2658
  2nd 0xc90c8800 dirhash (dirhash) @ /pcbsd-build90/fbsd-source/9.0/sys/ufs/ufs/ufs_dirhash.c:284
KDB: stack backtrace:
db_trace_self_wrapper(c0f00262,2d647362,72756f73,392f6563,732f302e,...) at db_trace_self_wrapper+0x26
kdb_backtrace(c0a419bb,c0f03d95,c75654a8,c7569f68,e13237cc,...) at kdb_backtrace+0x2a
_witness_debugger(c0f03d95,c90c8800,c0f339d4,c7569f68,c0f33643,...) at _witness_debugger+0x25
witness_checkorder(c90c8800,9,c0f33643,11c,0,...) at witness_checkorder+0x839
_sx_xlock(c90c8800,0,c0f33643,11c,c911d910,...) at _sx_xlock+0x85
ufsdirhash_acquire(e0f11818,c911d910,e13238fc,e2460f88,e132389c,...) at ufsdirhash_acquire+0x35
ufsdirhash_add(c911d910,e13238fc,f88,e1323888,e132388c,...) at ufsdirhash_add+0x13
ufs_direnter(c9124aa0,c9126660,e13238fc,e1323ba4,0,...) at ufs_direnter+0x739
ufs_makeinode(e1323ba4,0,e1323ae8,e1323a44,c0d5e945,...) at ufs_makeinode+0x59d
ufs_create(e1323ae8,e1323b00,0,0,e1323b64,...) at ufs_create+0x30
VOP_CREATE_APV(c104a800,e1323ae8,e1323ba4,e1323a80,0,...) at VOP_CREATE_APV+0xa5
vn_open_cred(e1323b64,e1323c2c,180,0,c75cf980,...) at vn_open_cred+0x215
vn_open(e1323b64,e1323c2c,180,c7f25dc8,4e6eb7f5,...) at vn_open+0x3b
kern_openat(c7f882e0,ffffff9c,29c88223,0,a03,...) at kern_openat+0x1ec
kern_open(c7f882e0,29c88223,0,a02,180,...) at kern_open+0x35
open(c7f882e0,e1323cec,e1323d28,c0f02632,0,...) at open+0x30
syscallenter(c7f882e0,e1323ce4,e1323ce4,0,74b,...) at syscallenter+0x263
syscall(e1323d28) at syscall+0x34
Xint0x80_syscall() at Xint0x80_syscall+0x21
--- syscall (5, FreeBSD ELF32, open), eip = 0x29400323, esp = 0xbfbfd7ec, ebp = 0xbfbfdc98 ---
/tmp: optimization changed from SPACE to TIME
ugen6.2:<SanDisk>  at usbus6
umass1:<SanDisk U3 Cruzer Micro, class 0/0, rev 2.00/2.00, addr 2>  on usbus6
umass1:  SCSI over Bulk-Only; quirks = 0x4000
umass1:4:1:-1: Attached to scbus4
(probe0:umass-sim1:1:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
(probe0:umass-sim1:1:0:0): CAM status: SCSI Status Error
(probe0:umass-sim1:1:0:0): SCSI status: Check Condition
(probe0:umass-sim1:1:0:0): SCSI sense: UNIT ATTENTION asc:3a,0 (Medium not present)
da1 at umass-sim1 bus 1 scbus4 target 0 lun 0
da1:<SanDisk U3 Cruzer Micro 8.02>  Removable Direct Access SCSI-0 device
da1: 40.000MB/s transfers
da1: 7663MB (15695871 512 byte sectors: 255H 63S/T 977C)

------end of dmesg output------





More information about the Testing mailing list