[PC-BSD Testing] [BETA2] Appcafe doesn't work (maybe proxy related)

Lars Engels lars.engels at 0x20.net
Wed Oct 19 06:19:08 PDT 2011


On Tue, Oct 18, 2011 at 11:52:00AM -0400, Kris Moore wrote:
> On 10/18/11 05:13, Lars Engels wrote:
> > On Mon, 17 Oct 2011 16:08:31 -0400, Kris Moore wrote:
> >> On 10/17/11 09:54, Lars Engels wrote:
> >>> Hi all,
> >>>
> >>> I just tried BETA2 (I know it's not the latest version...) in
> >>> Virtualbox.
> >>> So far it seems to run nicely, but Appcafe doesn't work. I can only
> >>> access
> >>> the internet via a http proxy with auth, which I entered in the network
> >>> settings and this works with the system updater. I already installed
> >>> the
> >>> system updater fix with it.
> >>> But when I start Appcafe, I only get a small error window saying "001"
> >>> and
> >>> this on the related terminal:
> >>> /etc> appcafe
> >>> Locale: "de"
> >>> Application starting...
> >>> Populating list...
> >>> Reading PBI List
> >>> RealUser: "engels"
> >>> Adding Repos...
> >>> Getting details for repoID: "001"
> >>> Loading translations for repoid: "001"
> >>> Adding Categories for repoID: "001"
> >>> Getting PBIs for repo: "001"
> >>> Updating mirrors...
> >>> Adding Repos...
> >>> Getting details for repoID: "001"
> >>> Loading translations for repoid: "001"
> >>> Adding Categories for repoID: "001"
> >>> Getting PBIs for repo: "001"
> >>>
> >>> That's the output of starting it and updating the repos.
> >>>
> >>> Setting HTTP_PROXY manually doesn't work either.
> >>> _______________________________________________
> >>> Testing mailing list
> >>> Testing at lists.pcbsd.org
> >>> http://lists.pcbsd.org/mailman/listinfo/testing
> >>
> >> Sounds like its failing to load / set the proxy info properly. Can you
> >> sent this data:
> >>
> >> cat /usr/local/etc/pcbsd.conf
> >> cat /usr/local/etc/pbi.conf
> >
> > [engels at notebook-1] ~> cat /usr/local/etc/pbi.conf
> > # PBI Configuration Defaults
> > # See the manpage for pbi.conf for more details
> >
> > # Set the number of hours for pbid to refresh the index/meta files
> > from repos
> > PBI_INDEXREFRESH: 24
> >
> > # Wakeup time in seconds for pbid to run checks
> > PBID_REFRESH: 300
> > [engels at notebook-1] ~> cat /usr/local/etc/pcbsd.conf
> > # PC-BSD Configuration Defaults
> >
> > # Default PC-BSD Mirror for System Updates / Meta-Pkgs
> > PCBSD_MIRROR: ftp://ftp.pcbsd.org/pub/mirror
> > PCBSD_PROXYURL: proxy-server
> > PCBSD_PROXYUSER: myuser
> > PCBSD_PROXYPASS: mypassword
> > PCBSD_PROXYTYPE: HTTP
> > PCBSD_PROXYPORT: 8080
> >
> >
> > Maybe it doesn't like special chars like * or $ in the password?
> >
> > _______________________________________________
> > Testing mailing list
> > Testing at lists.pcbsd.org
> > http://lists.pcbsd.org/mailman/listinfo/testing
> 
> Fixed! Turns out it was a simple shell syntax error :P
> 
> http://trac.pcbsd.org/changeset/13424

Yup, after changing that in my local installation, Appcafe works. :)

Thanks!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20111019/c3bc4cd7/attachment-0001.bin>


More information about the Testing mailing list