[PC-BSD Testing] KDE problem solved - Re: Cannot login after upgrade to PC-BSD 9.0-BETA2

productnews productnews at hvf.ch
Mon Oct 3 10:39:54 PDT 2011


On -10.01.-28163 20:59, Kris Moore wrote:
> 2. Fluxbox still crashes with this info in ~/.xession-errors
>
> /usr/local/etc/gdm/Xsession: Beginning session setup...
> To see how much disk space is left on your partitions, use
>
>     df -h
>         -- Dru <genesis at istar.ca>
> Setting the mixer ogain from 100:100 to 100:100.
> /usr/local/etc/gdm/Xsession: Setup done, will execute:
> /usr/bin/ssh-agent -- startfluxbox
> Locale: "de"
> Starting Tray Application
> pc-systemupdatertray: Fatal IO error: client killed
> [idesk] Background's file not found.
> [idesk] Background's source not found.
> XIO:  fatal IO error 22 (Invalid argument) on X server ":0.0"
>       after 14 requests (14 known processed) with 0 events remaining.
> Locale: "de"
> Application starting...
>
> ... and then the login screen reappears. Seems that idesk has some
> problems.
>
> That's what it looks like. You may need to copy over the .fluxbox and
> .idesk directories from /usr/share/skel to your homedir and try again.
Success: I deleted the existing .fluxbox directory and then copied the
/usr/share/skel/.fluxbox directory into my home dir
>
>> 3. The upgraded Thunderbird 6.0.2 still does not save the account
>> settings and thus remains unusable.
>>
> I'm not seeing those issues here... Is anything different about your
> homedir that I can test with here?
I removed the existing .thunderbird directory, now it works
>
>> 4. I still cannot use the beautiful TERMINAL font in any of the usual
>> consoles, like KDE konsole 2.4.6, gnome-terminal 2.32.1, Xfce Terminal
>> 0.4.8, but I can configure it for xterm with
>>
>> xterm -fn -bitstream-terminal-medium-*-*-*-*-*-*-*-*-*-iso8859-*
>>
>> On PCBSD Hubble and FreeBSD 8.2 the TERMINAL font works both for
>> konsole and gnome-terminal - is this because I have locally upgraded
>> these systems and recompiled everything in the ports tree??
>>
> Is it that the terminal font just isn't showing up in their list of
> available fonts? If that's the case it may be that we just need to add
> another package to the base system which includes the terminal font you
> want.
The fonts I like are in the x11-fonts/font-bitstream-100dpi port and
have been installed and mkfontdir'ed.
 However, konsole only shows these fonts in the profile setting menu for
choosing a font: Monospace, Bitstream Vera Sans Mono, Courier, Courier
10 Pitch, Cursor, DejaVu Sans Mono, and Luxi mono.
Gnome-terminal shows these fonts: AMS Mathematical Symbols, 4 Bitstream
fonts (Charter, Vera Sans, Vera Sans Mono, Vera Serif), Cantarell,
Computer Modern, 2 Courier, Cursor, 3 DejaVu, several Middle eastern
names, Monospace, and some more, but no Terminal.
So it is not a problem of missing fonts per se, but of konsole and
gnome-terminal not picking them up.

thanks


More information about the Testing mailing list