[PC-BSD Testing] several problems

Sebastian Rehne sebastian.rehne at web.de
Wed Nov 16 09:58:33 PST 2011


Hi Ken,

thank you for the feedback.

On 15.11.2011 16:30, Ken Moore wrote:
> On 11/15/11 08:53, Sebastian Rehne wrote:
>> Hello everybody,
>> 
>> At first: thank you for the pbi-innovation. Installing pbi's with
>> one click instead of worrying about the dependency-issues just
>> makes fun ... and is a great security improvement, no doubt.
>> 
>> Last week i have installed PC-BSD 9.0 on my acer notebook and i
>> am faced with several problems you might can help me with.
>> 
>> 1) My headphones didn't work: The headphone-connector didn't
>> work: When connecting my headphones to the notebook, the music
>> still sounds out of the speakers. My colleague Lars Engels, who
>> is member of the freebsd-team, has already helped me with that
>> issue: Adding
>> 
>> hint.hdac.0.cad0.nid20.config="as=1 seq=15" 
>> hint.hdac.0.cad0.nid21.config="as=1 seq=0"
>> 
>> in device.hints routes the bass directly to the ear. Maybe you
>> find a way to solve that issue during the installation.
>> 
>> 
>> 2) Also in the category "sound": "clementine" does not play my
>> music (regardless of the style of music): Error message says,
>> that the gstreamer plugin is missing. The message pop up when i
>> click on one of my albums in the left panel of the application.
>> Internetradio works. The celemtine feature "all glory to
>> hypnotaud" is no longer funny, when the application crashes and
>> only a reboot can stop the noise.
> 
> How did you install Clementine? I just installed it via the AppCafe
> a moment ago and it played music without any problems at all.

Clementine is install as regular pbi. I attached a screenshot, where you
can see the error message and the installed pbi.
> 
>> Something likewise mysterious as "hypnotaud": Manualy installing
>> amarok with pbimaker was successful and i startet the application
>> succesfully once from my desktop. But then the binary file
>> mystical "is missing" and can't neither be found in
>> /usr/local/bin nor in home/sebastian/bin/amarok-9/. I get no
>> results with "find . -name amarok" or "find . name amarok-0". 
>> This happend after switching from xfce to kde and back.
> PBI's that have been installed have their main binaries located
> at: /usr/pbi/(program-name-arch)/.sbin Links to these binaries
> should be located in the (home-dir)/bin folder as well. Amarok is
> so integrated with KDE now that we stopped creating a PBI for it
> simply because it does not work without installing all of KDE to
> run it. As such, we simply included it with the KDE multimedia
> system package if you would like to use it.

I have switched to KDE now and will add the multimedia-package later.
Did you moved Keepass and gwenview to the kde-Multimedia-package as well?
As i did with amarok, i have created these pbis with pbi_maker and now
these binaries are also lost. I definitely didn't remove anything
manually. I have add a file-listing of /usr/pbi and /home-dir/bin, where
you can see that these applications has been installed.
> 
>> 3) CPU0: local APIC error 0x40 dmesg shows the above
>> error-message frequently. I found an advice in the freebsd-forum,
>> to set
>> 
>> 'hint.apic.0.disabled' in /boot/device.hints
>> 
>> But that didn't help me. I assume that this error might be the
>> reason for some other "application-crashes" i have to deal with.
>> For example the submarine-game downdeep crashes just before i
>> shot the first tropedo. Also xbmc crashes "very constantly" after
>> a few minutes. Switching to an other tty, i can see that the
>> cpu-message appears multiple times in messages. Just a reboot
>> brings me back to a working x-environment.
>> 
>> 4) LibreOffice Writer crashes: When i try to chang the font, the
>> writer immediately crashes: pid 32347 (soffice.bin), uid 1001:
>> exited on signal 11 Changing the font in the other
>> libre-applications works. If it is helpful for troubleshooting i
>> could start the application with truss next time.
> I am seeing this same error with LibreOffice as well, and it
> appears to be a problem with the program/port itself. You should
> contact the port maintainer (office at freebsd.org I think?) with any
> additional information you can provide about this error.
> 
>> 5) Scanning doesn't work: I have installed the xsane-pbi, but i
>> can't start the application: [sebastian at pcbsd-4328
>> /usr/home/sebastian/bin]$ ./xsane Shared object "libcam.so.5" not
>> found, required by "xsane" [sebastian at pcbsd-4328
>> /usr/home/sebastian/bin]$
>> 
>> 6) I can't configure the printer: Printer: LaserJet 1022 I didn't
>> found a appropiate driver, generic etc. didn't work.
>> 
>> 7) virtual box: Last but not least: i was not able to install a
>> working virtualbox. If i understand it correctly, the
>> "system-panel" just contains the additions for pc-bsd as guest in
>> a virtualbox but not the virtualbox itself. But neither with
>> installed additions or without, creating a virtualbox from ports
>> fail with the following messages:
>> 
>> kBuild: Packing
>> /usr/ports/emulators/virtualbox-ose/work/VirtualBox-4.0.12_OSE/out/freebsd.x86/release/bin/vboxkeyboard.tar.bz2
>>
>> 
rm
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-4.0.12_OSE/out/freebsd.x86/release/obj/pcnet32.rom.rt1.bin
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-4.0.12_OSE/out/freebsd.x86/release/obj/pcnet32.rom.rt2.zbin
/usr/ports/emulators/virtualbox-ose/work/VirtualBox-4.0.12_OSE/out/freebsd.x86/release/obj/pcnet32.rom.rt2.bin
>> ===>  Installing for virtualbox-ose-4.0.12
>> 
>> ===>  virtualbox-ose-4.0.12 conflicts with installed package(s): 
>> virtualbox-ose-additions-4.0.12
>> 
>> They install files into the same place. Please remove them first
>> with pkg_delete(1). *** Error code 1
>> 
>> Stop in /usr/ports/emulators/virtualbox-ose. *** Error code 1
>> 
>> Stop in /usr/ports/emulators/virtualbox-ose. [root at pcbsd-4328]
>> /usr/ports/emulators/virtualbox-ose# pkg_info |grep virtual 
>> gvfs-1.6.6_1        GNOME virtual file system qt4-qvfb-4.7.3
>> Qt virtual framebuffer utility thunar-vfs-1.2.0_1  The virtual
>> filesystem for Thunar virtualbox-ose-additions-4.0.12 VirtualBox
>> additions for FreeBSD guests
> It appears that you are building virtualbox into the base system, 
> resulting in the conflicts. I would recommend using either the 
> VirtualBox PBI (I use it without any issues) or build virtualbox in
> a port jail as it will prevent issues like this and also prevent
> you from (possibly) corrupting your base system and causing a chain
> reaction throughout the rest of PC-BSD.

Because i didn't found keepass and virtualbox within the app-cafe,
i downloaded it form pbi-dir.com and tried to install them.
But i get an error-message, that pbi-metadata can't be load and
the file is not valid or corrupted. So i made the conclusion, that
applications from pbi-dir cannot be used for PC-BSD 9.


> 
>> 
>> It seems to me, that removing the check in the "system-panel"
>> does not remove the software from the system. A similar
>> experience a have made with kde, which is still on my system,
>> althought it is "removed" in the gui.
> 
> Just to make sure, you did click the "Apply changes" button after 
> unchecking the system packages you did not want?

> 
>> Thanks to anybody, who has the patience to read so far. I'am
>> thankful for every helping advice.
>> 
>> Sebastian 
>> ___________________________________________________________ SMS
>> schreiben mit WEB.DE FreeMail - einfach, schnell und 
>> kostenguenstig. Jetzt gleich testen! http://f.web.de/?mc=021192 
>> _______________________________________________ Testing mailing
>> list Testing at lists.pcbsd.org 
>> http://lists.pcbsd.org/mailman/listinfo/testing
> 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: clementine2.png
Type: image/png
Size: 342399 bytes
Desc: not available
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20111116/cb4215af/attachment-0001.png>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: lost_binaries.txt
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20111116/cb4215af/attachment-0001.txt>


More information about the Testing mailing list