[PC-BSD Testing] 9.0-RC1 ... not really ready

Kris Moore kris at pcbsd.org
Fri Nov 4 09:52:27 PDT 2011


On 10/30/2011 09:17, Paul Dufresne wrote:
> Hi!
> I am a 56k user, trying 9.0-RC1.
> Had tried 8 in the past, but really not much... don't remember what
> was the problem(s).
>
> Coming mainly to see how .pbi compares with Nix package manager.
> Mostly because nix-env would need more than 512 Mb, and that this is
> not acceptable for me.
> I am not sure yet, but I think you finally installed .pbi in the
> normal 'Linux' filesystem hierarchy, rather than inside a single Nix
> store... so in the end you would loose the main advantage: being able
> to install multiple versions of the same program without risk of
> conflict.
>
> But now, let's come back to 9.0-RC1.
>
> The first big problem is the disk partitioner.
> It is really dangerous, because it seems to applicate immediately the changes.
> I am now used to have disk partitioner that records the wanted result
> (or the changes needed to get the wanted results), and that would not
> change the disk partition until the last step of installation
> (confirmation).
> It would not be so bad, if the disk partitioner did not seems so ...
> stupid, sorry.
> I had Windows on the low part of my HD, and Linux at the end.
> I wanted to let PC-BSD install over the Windows partition.
> At the beginning, I was using in Beginner mode.
> Seems I had only Remove and Add (not install on this partition).
> So I removed Windows partition. Then try Add.
> Add would report there was no available sectors.
>
> So I tried to go back in step. Was not working.
> Had to cancel installation and reboot.
> To my great surprise, when I rebooted, I discovered that the Windows
> partition had really been removed (I was expecting no change to really
> have been done to partition table).
>
> Still, Add would report no way to Add a patition (no available sectors).
> So I removed Linux.
> But then again, no space.
> Removed the extended partition in which Linux (and maybe Windows???) was.
> Then I began to have some space!
> So I guess the big problem here would be that the disk partitioner
> would not know about extended partition. Hey... that's not new...
> parition table with UUID would be new... but not extended partitions!

BSD doesn't work well with extended partitions, so in this case you
can't add a new one until the extended is gone. One way around this is
to use some other tool to create the primary partition you want to
install to, then just select it during our install.

When you click to remove a partition, it does warn you about doing it,
but I'll add some extra wordage like "Immediate" so there is no confusion.


> There was in the Control Panel an option for me to give my user and
> password for my ppp account. I think there was no phone number option
> allowed however. Although it would propose between skge (my ethernet
> card I don't use) and cuau0 (that's it, my serial port for my external
> 56 modem), even after save. When I would come back, cuau0 was replaced
> by skge. System really does not want to believe me I intend to use 56k
> ;-)
> Finally, I open lxterminal, read a bit about ppp. Was able to connect
> but with a terminal and manually typing AT&F ADTD555-5555 etc. Need to
> read more for -auto mode to work.
So far nobody has stepped up and really created a PPP / dial-up GUI. I
don't use it here, and have only done some small bits and pieces here
and there.

> Anyway, let's come to AppCafe.
> At first, it would not work at all, saying that some files were not
> there, probably meaning Internet connection was down. I believed in
> first. So I got to Flash window, and try Update Flash. Seen my lights
> on modem begin to download stuff. So I concluded my connection was Ok.
> I think I give up on Flash update. Retry AppCafe... not better.
> Then got to Update Manager... which responded that my system was up to
> date (after some packets going through modem). Fine. Retried
> AppCafe... was working now.
>
> Then I got to install Dillo.
> It was quite long, so while it was downloading, browse AppCafe.
> Discovered a Bobble Bubble clone! BroBubble it was called or something similar.
> Asked for it. Downloaded put in standby, until Dillo finished.
>
> At this point let me say that I would have wished AppCafe would show
> size of the download, before it begin to download (well for Dillo I
> was seeing I was about 3 of 12 Mb... but would not know the size of
> BroBubble). Later I discovered that the web AppCafe shows the size and
> the rating. I wish for at least the size to be shown in the AppCafe
> application.
The sizes will be shown in an updated version soon.

>
> Dillo download was way much slower than expected 56k download.
> So I begin to try to know why. Lights on modem were showing very fast
> download (RD light never going down, SD confirmation going fast).
>
> I would eventually discovered that pbid, was downloading all the icons
> for almost all the applications in AppCafe. That was done without
> asking me, without an option to disable it.
> And at a very bad moment... when I was discovering AppCafe and
> downloading a web browser.
The icon download takes place at first run. Once it finishes it'll not
need to do it again for a while.

> Now, after Dillo finished downloading... BroBubble would begin
> download, and now realize that it is a 127 Mb download. No need to get
> it on 56k, would go tomorrow download it in a public library at
> high-speed Internet. So I 'Removed' Bubble while it was downloading.
> Seems to go fine. But later, I discovered that there was still a fetch
> operation for it. And it was very active (as the lights on modems
> showed me). Had to manually kill the fetch operation. This is very
> bad. AppCafe should really kill the fetch operation!
Fixed it to make sure the fetch is killed for RC2 :)

> So it is my experience up to now with 9.0-RC1.
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing


-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Testing mailing list