[PC-BSD Testing] RC1 - laptops : SUDO + SUSPEND + SHUTDOWN

Silvio - Banzai ° silvio.taverna at banzai.it
Wed Nov 2 09:04:18 PDT 2011


On Wed, 02 Nov 2011 16:00:52 +0100, Kris Moore <kris at pcbsd.org> wrote:

hi kris, thanx for the response ...

> On 11/02/2011 04:48, Silvio - Banzai ° wrote:
>>
>> Hi there,
>> reporting a very strange behavior occurring with RC1, on various
>> different laptops [Toshiba Satellite Pro A300, Acer Aspire 5742G] :
>> sudo asks for *root* password to execute a command, instead of user's
>> password ... don't think it has anything to do with hardware issue,
>> but just reporting the incident environment ...
>
> That is correct and by design. If you want to change it to use the user
> password you are welcome to modify sudoers.

ok, solved thanx ... the following line :

Defaults targetpw  # Ask for the password of the target user

introduced that behavior i was not used to ...

>
>> moreover, on those same systems, even though the suspend action is not
>> enabled in any of the power profiles, and the selected action for lid
>> closed is to turn the screen off, upon opening of the lid a system
>> suspend is triggered none the less, freezing the machine.
> This is in KDE correct? my other systems here don't try to suspend when
> I close the screen...

neither do mine ... the go on suspend upon *reopening* the lid, that's the  
strangest part of it ...

>> third, none of the entries of the 'leave' startup menu actually work,
>> whether the action is forced by a second click or the countdown is
>> left to expire, in the end nothing happens and from that moment on the
>> 'leave' menu does not pop up any more command window ...
>
>> am i just missing something here ? can all of these issues connected
>> somehow, maybe a hardware/acpi problem or what ?
>>
> I'm thinking its something along those lines. I'm not sure where to fix
> / disable those options in KDE at the moment. Maybe HAL?

sorry, i'm clueless here, xcept for saying that the same machine could be  
halted via that same panel under PCBSD8.2 ...


>> on the 'eyecandy' side, on both laptops no sound worked until i
>> port-installed the phono-xine backend and configured it instead of the
>> default [and only] gstreamer ...
>>
> Interesting.. Any errors or information when running as gstreamer?

nothing in console or /var/log/*, as far as i saw ... i had to use amarok  
as the 'debugging tool', and it printed something about my system not able  
to play mp3s, and a suggestion to check backend configuration ... in fact,  
no sound at all was produced, not just mp3/lame related, not even the  
'test' sound from the very phonon configuration panel was issued before  
xine ...


hope it helps !

>
>> Thanx All !
>
>


-- 

banzai • CONSULTING

Silvio Taverna
Via Gian Battista Vico, 42
20123  Milano
Tel:   +39 02 00643341
Cel:   +39 345 700 11 20
Skype: surt_5555
http://www.banzai.it


More information about the Testing mailing list