[PC-BSD Testing] mirror fails again (was Re: Next 64bit Snapshot)

Gour gour at atmarama.net
Tue Mar 29 01:17:59 PDT 2011


On Mon, 28 Mar 2011 15:43:57 -0400
Kris Moore <kris at pcbsd.org> wrote:

Hiya,

> As usual, please let us know of problems here at the -testing mailing
> list.

I've tried to do normal mirror install using 2 disks under vbox, but
it fails:

Running: find-update-parts
mount: no : No such file or directory
Stopping mirror gm0 ad0
Running: gmirror remove gm0 ad0
Running: dd if=/dev/zero of=/dev/ad0 count=4096
4096+0 records in
4096+0 records out
2097152 bytes transferred in 0.809458 secs (2590810 bytes/sec)
kern.geom.debugflags: 0 -> 16
Deleting all gparts
Running: gpart destroy ad0
gpart: arg0 'ad0': Invalid argument
Running: dd if=/dev/zero of=/dev/ad0 count=3000
3000+0 records in
3000+0 records out
1536000 bytes transferred in 0.490686 secs (3130312 bytes/sec)
Running gpart on ad0
Running: gpart create -s mbr ad0
ad0 created
Running gpart add on ad0
Running: gpart add -b 2016 -s 41940864 -t freebsd -i 1 ad0
ad0s1 added
Cleaning up ad0s1
Running: dd if=/dev/zero of=/dev/ad0s1 count=1024
1024+0 records in
1024+0 records out
524288 bytes transferred in 0.181191 secs (2893566 bytes/sec)
Stamping boot1 on ad0
Running: gpart bootcode -b /boot/boot1 ad0
bootcode written to ad0
Running: gpart create -s BSD ad0s1
ad0s1 created
Running: gpart add -s 1024M -t freebsd-ufs -i 1 ad0s1
ad0s1a added
Running: gpart add -s 2046M -t freebsd-swap -i 2 ad0s1
ad0s1b added
Running: gpart add -s 17405M -t freebsd-zfs -i 4 ad0s1
ad0s1d added
Running: gpart bootcode -b /boot/boot ad0s1
bootcode written to ad0s1
NEWFS: /dev/ad0s1a - UFS
Running: newfs /dev/ad0s1a
/dev/ad0s1a: 1024.0MB (2097152 sectors) block size 16384, fragment size 2048
	using 6 cylinder groups of 183.72MB, 11758 blks, 23552 inodes.
super-block backups (for fsck -b #) at:
 160, 376416, 752672, 1128928, 1505184, 1881440
Running: sync
Running: glabel label boot0 /dev/ad0s1a
Running: sync
Running: sync
Running: glabel label swap0 /dev/ad0s1b
Running: sync
NEWFS: /dev/ad0s1d - ZFS
Running: zpool create -m none -f tank0 ad0s1d
Running: zfs set atime=off tank0
Running: zfs set mountpoint=/mnt tank0
Running: zfs set atime=off tank0
zfs create -p tank0/var
Running: zfs create -p tank0/var
Running: zfs set mountpoint=/mnt/var tank0/var
Running: zfs set atime=off tank0/var
zfs create -p tank0/usr
Running: zfs create -p tank0/usr
Running: zfs set mountpoint=/mnt/usr tank0/usr
Running: zfs set atime=off tank0/usr
mount -o rw /dev/ad0s1a -> /mnt/boot
Running: mount -o rw /dev/ad0s1a /mnt/boot
swapon ad0s1b
Running: swapon /dev/ad0s1b
FOUND DVD: /dev/acd0
pc-sysinstall: Starting Extraction
pc-sysinstall: Extraction Finished
INSTALL COMPONENT: src
Extracting FREEBSD source tree...
/usr/.componenttmp/install.sh: cannot create /dev/null: Invalid argument
Running chroot command: /usr/bin/cap_mkdb /etc/login.conf
Setting em0 to DHCP on the system.
Running chroot command: cat /.tmpPass | pw useradd -n gour -c "Gour" -h 0 -s "/usr/local/bin/zsh" -m -d "/home/gour" -G "wheel,operator"
Running: rm /mnt/.tmpPass
Running external command: mount -t devfs devfs ${FSMNT}/dev
Running chroot command: touch /var/.runxsetup
Running chroot command: /usr/local/bin/pc-xdgutil updatemenu
Running external command: cp /etc/X11/xorg.conf ${FSMNT}/usr/local/share/pcbsd/xorg-gui/conf/xorg.conf.basic
Running chroot command: sh /usr/local/share/pcbsd/scripts/reset-firewall
Running external command: sh /root/insMetaPkgs.sh base-system,Base-Devel,Base-I18N,XFCE4,XFCE4-Plugins CD
Running external command: umount ${FSMNT}/dev
Running: gmirror label -vb load gm0 /dev/ad0
Metadata value stored on /dev/ad0.
Done.
Setting hostname: nitai
Setting root password
Running chroot command: cat /.rootpw | pw usermod root -h 0
Running: rm /mnt/.rootpw
Running: mkdir -p /mnt//boot-mount/boot
Running: mv /mnt/boot/* /mnt/boot-mount/boot/
Running: mv /mnt/boot-mount/boot /mnt/boot/
Running: umount /dev/ad0s1a
Running: mount /dev/ad0s1a /mnt/boot-mount
Running: rmdir /mnt/boot
Running: chroot /mnt ln -s boot-mount/boot /boot
Running: zfs set mountpoint=/usr tank0/usr
Running: zfs unmount tank0/usr
Running: zfs set mountpoint=/var tank0/var
Running: zfs unmount tank0/var
Running: umount -f /dev/ad0s1a
Running: umount -f /mnt
Running: zfs set mountpoint=legacy tank0
Running: umount -f /cdmnt-install
Running: gmirror insert gm0 /dev/ad1
gmirror: No such device: gm0.
Error 1: gmirror insert gm0 /dev/ad1
Running: umount -f /dev/ad0s1a
umount: /dev/ad0s1a: unknown file system
Running: umount -f /mnt/boot
umount: /mnt/boot: statfs: No such file or directory
umount: /mnt/boot: unknown file system
Running: umount -f /mnt
umount: /mnt: not a file system root directory
Running: umount /cdmnt-install
umount: /cdmnt-install: not a file system root directory


Any hint?

I also tried to do mirror with encrypted, but installer behaved
strangely - generating some passwds/keys...I'll try again and provide
log.


Sincerely,
Gour (still waiting to migrate to PC-BSD)

-- 
“In the material world, conceptions of good and bad are
all mental speculations…” (Sri Caitanya Mahaprabhu)

http://atmarama.net | Hlapicina (Croatia) | GPG: CDBF17CA


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20110329/f767e762/attachment.pgp>


More information about the Testing mailing list