[PC-BSD Testing] 8.2 RC2 x64 install issues

Bruce Cran bruce at cran.org.uk
Mon Jan 31 13:01:32 PST 2011


On Mon, 31 Jan 2011 15:19:57 -0500
Kris Moore <kris at pcbsd.org> wrote:

> Possible, does it do that with any other obvious key-combos?

I tried several other shift combinations and all the others worked.

> Typically you'll setup "ada1" with your mounts, such as /home, then
> select the device "ada2" as its mirror. Is that how you did it? What
> was the full intended partition layout of this system? I can try to
> duplicate it here.

I selected the "mirror" option and selected ada2 as an additional pool
device. I then entered all the mountpoints in the space below. The full
layout I wanted was:

/dev/ada0, /dev/ada1, /dev/ada2, /dev/ada3, /dev/ada4: 1 TB disks

/dev/ada0: 200GB zfs
 /, /usr, /var/, /tmp, /usr/src, /usr/ports, /usr/ports/distfiles, /usr/ports/packages,
 /var/tmp, /var/empty, /var/run, /var/db, /var/db/pkg, /var/mail, /var/log

/dev/ada0: 8GB SWAP

/dev/ada1, /dev/ada2: 1TB zfs mirror
 /home

/dev/ada3, /dev/ada4 - existing NTFS mirror

With Ubuntu and OS X having switched to making the distinction
between MB and MiB I wonder if it might make sense to consider switching
to 1 MB being 1000000 bytes in the installer when partitioning?

> I get a 403 forbidden on that log file :(

Sorry I'd forgotten to fix the permissions - fixed.

> Did you do both of these install attempts on the same boot? I.E. did
> you reboot between them. I've seen some inconsistenties here when
> using gpart, and after a failed install, the device is "locked",
> getting these operation not permitted errors. A reboot and fresh try
> fixes it.

I always reboot between installation attempts.

-- 
Bruce Cran


More information about the Testing mailing list