[PC-BSD Testing] 8.2 RC2 x64 install issues

Bruce Cran bruce at cran.org.uk
Sun Jan 30 03:16:54 PST 2011


Hi,

I tried installing 8.2 RC2 x64 and came across a few issues:

Typing in the keyboard test area: it seems to need two presses of
shift-2 to produce a single " with a GB layout which I suspect may be
a display problem?
The partition editor lets you create duplicate ZFS mount points.
It seems ZFS mirror doesn't work: selecting ada1 and ada2 as devices
and setting the mountpoint to /home failed when the installer said it
didn't have any partitions to work with.

I had previously tried to install using GPT and got an error when the
installer was trying to create / and SWAP on ada0:

Running: gpart destroy ada2
gpart: geom 'ada2': Invalid argument

[...]

Running: gpart bootcode -p /boot/gptzfsboot -i 1 ada2
gpart: /dev/ada2p1: Operation not permitted

[...]

glabel: Can't store metadata on /dev/ada0p3: Operation not permitted.
Error 1: glabel label swap0 /dev/ada0p3

The full log is at http://www.cran.org.uk/~brucec/pc-sysinstall.log

It would be nice to have an option to choose between MBR or GPT on a
per-disk basis. For example I want GPT on my mirrored /home (ada1 and
ada2) but since I'm going to be installing Windows on ada0 I'd like to
keep that with an MBR scheme; I know that's probably a more advanced
use case than you're aiming for with pcbsd though.

--
Bruce Cran


More information about the Testing mailing list