[PC-BSD Testing] [pcbsd]kde/konqueror error

Xavier Alvelo bebuxe90 at gmail.com
Sun Jan 16 22:54:57 PST 2011


I dunno why, but since an error i got by terminating in my machine the
command /etc/rc.d/netif forceful by shutdown after the xserver fails
and everything else stall; it flushed out rc.conf completely (the bwn
driver running).
and even after i wrote everything like i had, it would not mount the in board
mouse or su in konsole. so I installed 8.2 RC1 of pcbsd x64, konsole
would still not let me su. I can in the virtual consoles, but not in
konsole. the mouse works though.... some one liners using kdesu works,
but su fails. it reports
"sorry" like i typed in the wrong password (IOW, it was the same error
in the previous setup, but using 8.1 x86 of pcbsd, only it had
the no mount/usage).

I also was able to replicate the same error using the bwn driver on
this OS (8.2RC1x64).
After I swrote a change in rc.conf for the device
(ifconfig_wlan0="DHCP" to ifconfig_wlan0="WPA DHCP")
and the did /etc/rc.d/netif restart, the system would stall forever.
After a forceful shutdown, rc.conf is flushed out.
This is of course using bwn-firmware-kmod from the ports.
I assume its replicable on any arch and os after 8.0.
I have a BCM4311. it works smoothly, better than ndis compilation i made.


anything else please reply me back here on the email, I often hang in the irc.

PS
attached is my dmesg, and I will try next time bwn but with a shutdown
after my rc.conf changes.
-------------- next part --------------
Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.1-RELEASE #1: Sat Jul 17 14:19:59 PDT 2010
    root at build8x64.pcbsd.org:/usr/obj/usr/pcbsd-build81/fbsd-source/8.1/sys/PCBSD amd64
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Turion(tm) 64 X2 Mobile Technology TL-58 (1900.08-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x60f81  Family = f  Model = 68  Stepping = 1
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x2001<SSE3,CX16>
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x11f<LAHF,CMP,SVM,ExtAPIC,CR8,Prefetch>
real memory  = 2147483648 (2048 MB)
avail memory = 1920065536 (1831 MB)
ACPI APIC Table: <PTLTD  	 APIC  >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 2.1> irqs 0-23 on motherboard
Cuse4BSD v0.1.11 @ /dev/cuse
kbd1 at kbdmux0
splash_pcx: invalid PCX image
module_register_init: MOD_LOAD (splash_pcx, 0xffffffff80ec2010, 0) error 19
cryptosoft0: <software crypto> on motherboard
acpi0: <DELL M08    > on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
unknown: I/O range not supported
acpi0: reservation of 0, 1000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_ec0: <Embedded Controller: GPE 0x14> port 0x62,0x66 on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x9000-0x90ff mem 0xc8000000-0xcfffffff,0xc0100000-0xc010ffff irq 17 at device 5.0 on pci1
pcib2: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci5: <ACPI PCI bus> on pcib3
pci5: <network> at device 0.0 (no driver attached)
ahci0: <ATI IXP600 AHCI SATA controller> port 0x8438-0x843f,0x8454-0x8457,0x8430-0x8437,0x8450-0x8453,0x8400-0x840f mem 0xc0004000-0xc00043ff irq 22 at device 18.0 on pci0
ahci0: [ITHREAD]
ahci0: AHCI v1.10 with 4 3Gbps ports, Port Multiplier supported
ahcich0: <AHCI channel> at channel 0 on ahci0
ahcich0: [ITHREAD]
ahcich1: <AHCI channel> at channel 1 on ahci0
ahcich1: [ITHREAD]
ahcich2: <AHCI channel> at channel 2 on ahci0
ahcich2: [ITHREAD]
ahcich3: <AHCI channel> at channel 3 on ahci0
ahcich3: [ITHREAD]
ohci0: <OHCI (generic) USB controller> mem 0xc0005000-0xc0005fff irq 16 at device 19.0 on pci0
ohci0: [ITHREAD]
usbus0: <OHCI (generic) USB controller> on ohci0
ohci1: <OHCI (generic) USB controller> mem 0xc0006000-0xc0006fff irq 17 at device 19.1 on pci0
ohci1: [ITHREAD]
usbus1: <OHCI (generic) USB controller> on ohci1
ohci2: <OHCI (generic) USB controller> mem 0xc0007000-0xc0007fff irq 18 at device 19.2 on pci0
ohci2: [ITHREAD]
usbus2: <OHCI (generic) USB controller> on ohci2
ohci3: <OHCI (generic) USB controller> mem 0xc0008000-0xc0008fff irq 17 at device 19.3 on pci0
ohci3: [ITHREAD]
usbus3: <OHCI (generic) USB controller> on ohci3
ohci4: <OHCI (generic) USB controller> mem 0xc0009000-0xc0009fff irq 18 at device 19.4 on pci0
ohci4: [ITHREAD]
usbus4: <OHCI (generic) USB controller> on ohci4
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xc0004400-0xc00044ff irq 19 at device 19.5 on pci0
ehci0: [ITHREAD]
ehci0: AMD SB600/700 quirk applied
usbus5: EHCI version 1.0
usbus5: <EHCI (generic) USB 2.0 controller> on ehci0
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci0: <ATI IXP600 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x8420-0x842f at device 20.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
pci0: <multimedia, HDA> at device 20.2 (no driver attached)
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib4: <ACPI PCI-PCI bridge> at device 20.4 on pci0
pci8: <ACPI PCI bus> on pcib4
bfe0: <Broadcom BCM4401-B0 Fast Ethernet> mem 0xc0300000-0xc0301fff irq 21 at device 0.0 on pci8
miibus0: <MII bus> on bfe0
bmtphy0: <BCM4401 10/100baseTX PHY> PHY 1 on miibus0
bmtphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bfe0: Ethernet address: 00:1c:23:ae:4b:51
bfe0: [ITHREAD]
sdhci0: <RICOH R5C822 SD> mem 0xc0302800-0xc03028ff irq 20 at device 1.0 on pci8
sdhci0: 1 slot(s) allocated
sdhci0: [ITHREAD]
pci8: <base peripheral> at device 1.1 (no driver attached)
acpi_button1: <Sleep Button> on acpi0
acpi_button1: enable wake failed
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> flags 0x1000 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model Generic PS/2 mouse, device ID 0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xcd000-0xcdfff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
acpi_throttle0: <ACPI CPU Throttling> on cpu0
powernow0: <PowerNow! K8> on cpu0
powernow1: <PowerNow! K8> on cpu1
ZFS NOTICE: Prefetch is disabled by default if less than 4GB of RAM is present;
            to enable, add "vfs.zfs.prefetch_disable=0" to /boot/loader.conf.
ZFS filesystem version 3
ZFS storage pool version 14
Timecounters tick every 1.000 msec
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
usbus3: 12Mbps Full Speed USB v1.0
usbus4: 12Mbps Full Speed USB v1.0
usbus5: 480Mbps High Speed USB v2.0
ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
ada0: <ST9160821AS 3.CDD> ATA-7 SATA 1.x device
ada0: 150.000MB/s transfers (SATA 1.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 152627MB (312581808 512 byte sectors: 16H 63S/T 16383C)
ugen0.1: <ATI> at usbus0
uhub0: <ATI OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <ATI> at usbus1
uhub1: <ATI OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <ATI> at usbus2
uhub2: <ATI OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
ugen3.1: <ATI> at usbus3
uhub3: <ATI OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
ugen4.1: <ATI> at usbus4
uhub4: <ATI OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus4
ugen5.1: <ATI> at usbus5
uhub5: <ATI EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus5
acd0: DVDR <PBDS DVD+/-RW DS-8W1P/BD1C> at ata0-master UDMA33 
SMP: AP CPU #1 Launched!
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
uhub4: 2 ports with 2 removable, self powered
Root mount waiting for: usbus5
Root mount waiting for: usbus5
Root mount waiting for: usbus5
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 
(probe0:ata0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0 
(probe0:ata0:0:0:0): CAM status: SCSI Status Error
(probe0:ata0:0:0:0): SCSI status: Check Condition
(probe0:ata0:0:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
cd0 at ata0 bus 0 scbus4 target 0 lun 0
cd0: <PBDS DVD+-RW DS-8W1P BD1C> Removable CD-ROM SCSI-0 device 
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Root mount waiting for: usbus5
uhub5: 10 ports with 10 removable, self powered
Trying to mount root from ufs:/dev/label/rootfs0
WARNING: / was not properly dismounted
WARNING: /var was not properly dismounted
WARNING: /usr was not properly dismounted
/usr: mount pending error: blocks 8 files 2
WARNING: TMPFS is considered to be a highly experimental feature in FreeBSD.
hdac0: <ATI SB600 High Definition Audio Controller> mem 0xc0000000-0xc0003fff irq 16 at device 20.2 on pci0
hdac0: HDA Driver Revision: 20100226_0142
hdac0: [ITHREAD]
hdac0: HDA Codec #0: Conexant (Unknown)
hdac0: HDA Codec #1: Sigmatel STAC9220
pcm0: <HDA Sigmatel STAC9220 PCM #0 Analog> at cad 1 nid 1 on hdac0
bfe0: link state changed to UP


More information about the Testing mailing list