[PC-BSD Testing] PBI for PC-BSD 9

jmdennis @dslextreme.com jmdennis at dslextreme.com
Wed Jan 5 22:23:07 PST 2011


On Tue, Jan 4, 2011 at 8:02 AM, jmdennis @dslextreme.com <
jmdennis at dslextreme.com> wrote:

> I can understand that.  I wonder why they told me to do it instead of
> fixing the port.  I know they are not the maintainer of it though.
> When I did a search for the problem this seemed to be a problem with
> FreeBSD 7 as well.  I guess each time a new one is released this port
> seems to have problems with it which makes sense as I am sure each one
> changes things a bit.
>
> On 1/4/11, Kris Moore <kris at pcbsd.org> wrote:
> > On Tue, Jan 04, 2011 at 06:43:00AM -0800, jmdennis @dslextreme.comwrote:
> >> I emailed the freebsd ports people and they mentioned the fix that I
> told
> >> you about.  This does not seem to be a problem in FreeBSD 8 just 9.
> >
> > This is correct, however the underlying problem is that the port itself
> is
> > broken
> > on FreeBSD 9-Current. We'll need to have the port updated to fix building
> on
> > 9,
> > then the PBI will build properly again. I prefer to not
> > start maintaining seperate port patches in our tree if at all possible :)
> >
> >>
> >> On Tue, Jan 4, 2011 at 6:41 AM, Kris Moore <kris at pcbsd.org> wrote:
> >>
> >> > On Tue, Jan 04, 2011 at 03:21:53AM -0800, jmdennis @dslextreme.com
> >> > wrote:
> >> > > For the PBI for desktopbsd-tools it gets an error at the end.  I got
> >> > > the
> >> > > same error when I tried to install it from ports.  I was given the
> >> > > instructions below for this.  I will try this later on today but
> think
> >> > that
> >> > > the PBI would work as well if this was changed as instructed.
> >> > >
> >> > > "Edit moddevinfo.ui.h and change DIS_ATTACHED to DS_ATTACHED.  Then
> >> > > compile it."
> >> >
> >> > This seems like something the port should fix. Have you filed a PR, or
> >> > is
> >> > there one
> >> > for this port bug already?
> >> >
> >> >
> >> > --
> >> > Kris Moore
> >> > PC-BSD Software
> >> > _______________________________________________
> >> > Testing mailing list
> >> > Testing at lists.pcbsd.org
> >> > http://lists.pcbsd.org/mailman/listinfo/testing
> >> >
> >
> >> _______________________________________________
> >> Testing mailing list
> >> Testing at lists.pcbsd.org
> >> http://lists.pcbsd.org/mailman/listinfo/testing
> >
> >
> > --
> > Kris Moore
> > PC-BSD Software
> > _______________________________________________
> > Testing mailing list
> > Testing at lists.pcbsd.org
> > http://lists.pcbsd.org/mailman/listinfo/testing
> >
>

I have not heard back from the FreeBSD folks on this but did get it working
on my system by making this change but it was interesting what the screen
looked like.  I know back in the day that desktopbsd said that the PBI's
would run in there own environment or some thing like this.  For this
application that is a good thing.  Because it was build for KDE 3.5.10 I had
the PCBSD menu at the bottom of the screen with most of the applications not
working and just above this I had the menu for KDE 3.5.10.  I updated all
the packages but only used the packages this time as it did not keep my
settings and thus when I went to reboot to see if the problem was fixed it
went to a screen that kind of looked like it locked up and no longer went to
the login prompt so I broke PCBSD 9 but that was my fault.  I will wait
until this is a working PBI.  I installed PCBSD 8.2 beta for the time being
and will use PCBSD 9 when you release another update for it since you have
so many fixes for it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20110105/0940386a/attachment.html>


More information about the Testing mailing list