[PC-BSD Testing] portjail delete nukes /usr/home

Ben Milman ben at ixsystems.com
Tue Dec 20 11:41:31 PST 2011


Grab a seat, there's a bit of a story, and it includes three bugs.

In PC-BSD 9 RC3, upgraded that day from RC2, I decided to try out
gmail-notifier from ports as a preliminary to making a pbi. I ran portjail
init and selected download but it failed with a message I no longer have
recorded for reasons that will become apparent. However, part of the
message was that it had tried to download the portjail for RC2. When I
checked my system manager in gnome, it opened and then promptly crashed (it
didn't crash in KDE and doesn't crash on my new fresh RC3 in gnome, so this
may be a symptom of another update-related bug), but since it froze on the
first screen I could see that the system was showing PC-BSD version RC2 but
base version RC3. I assume this was the cause of the portjail download
failure. I compiled the portjail instead, to check if that was working (I
included system source and ports tree in my original install). It did, so I
decided to delete the portjail so that I could show the first error to
someone. However, upon running portjail delete, all my desktop icons
disappeared.

Further investigation showed that all the directories in my /usr/home
directory were now gone. I didn't check other directories in /usr because I
was in too much of a rush to get back up and running (this is a work
computer). I decided to reinstall rather than reconstruct in place, so I'm
now on RC3 straight and can no longer reproduce the portjail download
failure bug. However, it remains that the PC-BSD version apparently failed
to increment during the standard update from RC2 to RC3, and that portjail
delete wiped my /usr/home directory on the OUTER system. IRC conversations
suggested that a bug such as this:
https://github.com/MrMEEE/bumblebee/issues/123 might be responsible, but
it's still odd that the outer system experienced changes from portjail
delete.

There's also a typo in line 317 of portjail.sh - "Enter d tor download"
should be "Enter d for download".

Ben Milman
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20111220/4accf11a/attachment.html>


More information about the Testing mailing list