[PC-BSD Testing] Automated install failed on RC3

Marc von go. info at godot.de
Sat Dec 17 15:02:35 PST 2011


Hi,

testing scripts on RC3 stops after partitioning with cust-install.cfg:
Fail:
File Sanity Check -> OK
/usr/share/pc-sysinstall/backend/parseconfig.sh: arithmetic expression:
variable conversion Error: "LASTSLICE+1"
ERROR: Installation failed, press Enter to drop to shell.

...
doublechecked the ZFS Line with the examples, getting similar errors with UFS with and without geli


--
godot.de 



Am 08.12.2011 um 19:34 schrieb Kris Moore:

> On 12/07/2011 16:40, Marc von go wrote:
>> Tested with following own configuration in /boot/ 
>> (without .go ending)
>> 
>> 
>> 
>> 
>> 
>> and tested with following example files
>> 
>> 
>> 
>> 
>> 
>> 
>> Thanks a lot 
>> 
>> Marcus
>> --
>> godot.de 
>> 
>> 
>> Am 07.12.2011 um 20:48 schrieb Kris Moore:
>> 
>> 
>>> On 12/05/2011 17:28, Marc von go wrote:
>>> 
>>>> Hi Kris,
>>>> 
>>>> i am new on the trac-system.
>>>> Same failure in RC2.
>>>> Seems do we have to wait for next RC3 build or is this part of a script i can update local, wich path/file?
>>>> 
>>>> http://trac.pcbsd.org/browser/pcbsd/current/build-files/src-patches/patch-pc-sysinstall-autoinstall?rev=14080
>>>> 
>>>> 
>>>> Best regards
>>>> 
>>>> --
>>>> godot.de 
>>>> Inh. M. Maschke
>>>> 
>>>> 
>>>> Am 30.11.2011 um 18:32 schrieb Kris Moore:
>>>> 
>>>> 
>>>>> On 11/24/2011 14:06, Marc v. go. wrote:
>>>>> 
>>>>>> Hi, 
>>>>>> 
>>>>>> following the Wiki there are some questions: 
>>>>>> Creating an Automated Installation with pc-sysinstall
>>>>>> with own customized PC-SYSINSTALL.CFG and  PC-AUTOINSTALL.CONF 
>>>>>> 
>>>>>> Here i have failure on the new ISO-Boot:
>>>>>> Error: /tmp/pc-sysinstall... not found
>>>>>> (Files already copied to /boot)
>>>>>> Is the wiki correct, is there a Solution beside the wiki?
>>>>>> 
>>>>>> Trying to take the Example files:
>>>>>> with renamed CUST-INSTALL.CFG and  PC-AUTOINSTALL.CONF 
>>>>>> getting following error with:
>>>>>> pc-sysinstall start-autoinstall /boot/pc-autoinstall.conf
>>>>>> Error: Config fails sanity test! Missing installTMode 
>>>>>> (but I see this line is in EXAMPLE CUST-INSTALL.CFG )
>>>>>> 
>>> Can you attach the config files you are trying to use? It sounds like
>>> "installMode" isn't set properly in one of them.
>>> 
>>> 
>>> 
>>>>>> so going to start the ISO and after boot getting:
>>>>>> /usr/share/pc-sysinstall/pc-sysinstall: not found...Installation failed... drop to shell.
>>>>>> 
>>>>>> Any Hints?
>>>>>> 
>>>>>> Best regards from Berlin
>>>>>> 
>>>>>> Marc
>>>>>> _______________________________________________
>>>>>> Testing mailing list
>>>>>> 
>>>>>> 
>>>>>> Testing at lists.pcbsd.org
>>>>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>>>>> 
>>>>>> 
>>>>>> 
>>> -- 
>>> Kris Moore
>>> PC-BSD Software
>>> iXsystems
>>> 
>>> _______________________________________________
>>> Testing mailing list
>>> 
>>> Testing at lists.pcbsd.org
>>> http://lists.pcbsd.org/mailman/listinfo/testing
>>> 
>>> 
>>> 
>> 
>> 
>> _______________________________________________
>> Testing mailing list
>> 
>> Testing at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/testing
> 
> Try with the attached files.
> 
> put cust-install.cfg.go in /boot of the mfsroot on the DVD along with /boot/pc-autoinstall.conf
> 
> 
> 
> 
> -- 
> Kris Moore
> PC-BSD Software
> iXsystems
> 
> <cust-install.cfg.go><pc-autoinstall.conf>_______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing



More information about the Testing mailing list