[PC-BSD Testing] Installation error subject to MBR

Serghey Suvorov serghey.suvorov at gmail.com
Tue Aug 30 12:17:20 PDT 2011


Hi Kris,
in order that you have no any doubt.

1) I start in Windows, and do not anything with a body of hd1.
Only I write the image 2MBR.dat (i.e. bad) into MBR, by HDHacker.exe.
Then I install PCBSD with the same options as before: the same error is.

2) I restart Windows, and only write 1MBR.dat (i.e. good); then
install PCBSD: success.

Serghey

On 29 August 2011 23:49, Serghey Suvorov <serghey.suvorov at gmail.com> wrote:

> Hi,
>
> 1) No, I didn't.
> 2) I took notice that information about MBR is absent in that strings.
> But my experiments showed this connection. Maybe I'll repeat this
> with your detailed instructions?
>
> Regards, Serghey.
>
>
> On 29 August 2011 22:03, Kris Moore <kris at pcbsd.org> wrote:
>
>>  On 08/27/11 09:05, Serghey Suvorov wrote:
>>
>>
>> Hi,
>>
>> Comp configuration: CPU P4 650 model; MB ASUS P5GD1Pro with on-board ICH6
>> sound;
>> NVIDIA 9400 GT; 4GB DDR-SDRAM; HD0 (WinXP/C, WinXP/D, Scientific Linux),
>> HD1 (WinXP/E, PCBSD).
>>
>> Installation: PCBSD9.0-BETA1.5-x64-DVD.iso, ZFS, GNOME, NVIDIA,
>> Base-Devel, Base-l18N; sys.lang=En, keyb=default.
>>
>> The attached *.zip contains 3 files.
>>
>> 1MBR.dat is MBR in HD1 after full ntfs-formatting; partition deletion;
>> and creation of 2 primary partitions: 1st with ntfs, and 2nd without
>> formatting. PCBSD was installed on 2nd partition without problems.
>>
>> 2MBR.dat is the MBR after deletion PCBSD partition (which had been
>> installed before), and creation the primary one without formatting.
>> PCBSD installation on that partition was halted.
>> 3rd file contains the report.
>>
>> These MBRs are different in 2 bytes in FreeBSD range.
>>
>> Main: the same error had occured, when I had installed
>> PCBSD over already installed one without preceding its deletion.
>>
>> The check experiments were realized with the same results.
>>
>> Best regards
>> Serghey
>>
>> _______________________________________________
>> Testing mailing listTesting at lists.pcbsd.orghttp://lists.pcbsd.org/mailman/listinfo/testing
>>
>>
>> Thanks for the error report!
>>
>> In this particular error, the MBR doesn't seem to have anything to do with
>> it. The real error message is in the logfile here:
>>
>> Running: umount /dev/ada1s2a
>> umount: unmount of /mnt/boot failed: Device busy
>> EXITERROR: Error 1: umount /dev/ada1s2a
>>
>>
>> I'm trying to duplicate this, but haven't been able to so far. The second
>> time you loaded the system, did you have xterm open or anything running in
>> /mnt while the install was going?
>>
>>
>> --
>> Kris Moore
>> PC-BSD Software
>> iXsystems
>>
>>
>> _______________________________________________
>> Testing mailing list
>> Testing at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/testing
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20110830/9e67b679/attachment.html>


More information about the Testing mailing list