[PC-BSD Testing] strangeness with v9.0 beta1.5

Tigersharke . tigersharke at gmail.com
Mon Aug 22 06:44:41 PDT 2011


On Sun, Aug 21, 2011 at 5:45 AM, Tigersharke . <tigersharke at gmail.com>wrote:


> My system is AMD 64bit, ATI 3100 graphics on the motherboard.  PC-BSD
> v9.0beta1 was installed and then updated to beta1.5 after reboot (an
> interesting new experience for me).
>
> *This* is what is strange:
>
> I added Firefox as a PBI, then discovered it is version 4.0.1, so I removed
> the PBI to build/install the most current version by port/pkg.  Whether I
> put Firefox 6.x onto my system as a manually built port (pretty sure thats
> how I did it) or as a FreeBSD package, it should still be on my system
> somewhere.
>
> Within KDE, I had Firefox running, Quassel added via pkg, and wine added
> via PBI.
>
> In a terminal, I initiated an install of Bioshock with wine
> /media/cd0/setup.exe  which was working fine until the last seconds of the
> install.  I believe it did/tried something related to graphics, then what
> happened was a partial restart or something. The screen blanked and I think
> the KDE session was ended. When I got back to the desktop in KDE, the
> firefox icon in the kickstart/kicker/kickoff was gone but the text was
> present. However, *Firefox was no longer on my system*? I did look in
> /usr/local/bin, but no firefox. This is definitely something I need to pay
> better attention to- of course "fun" things like these are a surprise. If I
> can repeat it, I will give more information next time (assuming there is any
> to give).
>

I am still unsure exactly how the above result was reached (vanishing
Firefox).. but have done some additional testing:

With Firefox v6.x installed via ports, a konsole, quassel and firefox
running, I tried installing Bioshock as before (though I typoed the previous
email- the correct command is wine start /unix /media/cd0/setup.exe) after
changing the setting in the gui wine configurator to default vista instead
of windows 2000. It installed very quickly, since it only seemed to verify
each file that I had not removed (of Bioshock), but then it got to the point
of downloading the current patches. This seems to be what triggered an end
of the KDE session that briefly brought me to the console and then back to
the user login screen. Upon returning to the KDE desktop, the only thing to
repopulate was a konsole session, but both Firefox and Quassel were still
present on my system, as were the PBIs clementine-player and wine.

*Something* new I have discovered is that the PBI paths are not part of the
standard search path. As root, I was eventually able to attempt to initiate
wine but it resulted in a second a search path error as below:

>su -m
Password:
# wine start /unix /media/cd0/setup.exe
wine: /home/tigersharke/.wine is not owned by you
[tigersharke at mutant] ~# exit
exit
[tigersharke at mutant] ~> su
Password:
# wine start /unix /media/cd0/setup.exe
wine: Command not found.
# /usr/pbi/wine-i386/bin/wine start /unix /media/cd0/setup.exe
/libexec/ld-elf.so.1: Shared object "libwine.so.1" not found, required by
"wine"

Attempting as my ordinary user account does succeed, without needing the
full path to wine, but imperfectly:

>wine start /unix /media/cd0/setup.exe
/libexec/ld-elf.so.1: /usr/pbi/wine-i386/lib/libxml2.so.5: unsupported file
layout
/libexec/ld-elf.so.1: /usr/pbi/wine-i386/lib/libglib-2.0.so.0: unsupported
file layout

When I actually try to initiate Bioshock, I'll be back here if there are
more issues..


Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20110822/0f951195/attachment.html>


More information about the Testing mailing list