[PC-BSD Testing] strangeness with v9.0 beta1.5

Tigersharke . tigersharke at gmail.com
Sun Aug 21 03:45:01 PDT 2011


Hey there..

My system is AMD 64bit, ATI 3100 graphics on the motherboard.  PC-BSD
v9.0beta1 was installed and then updated to beta1.5 after reboot (an
interesting new experience for me).

*This* is what is strange:

I added Firefox as a PBI, then discovered it is version 4.0.1, so I removed
the PBI to build/install the most current version by port/pkg.  Whether I
put Firefox 6.x onto my system as a manually built port (pretty sure thats
how I did it) or as a FreeBSD package, it should still be on my system
somewhere.

Within KDE, I had Firefox running, Quassel added via pkg, and wine added via
PBI.

In a terminal, I initiated an install of Bioshock with wine
/media/cd0/setup.exe  which was working fine until the last seconds of the
install.  I believe it did/tried something related to graphics, then what
happened was a partial restart or something. The screen blanked and I think
the KDE session was ended. When I got back to the desktop in KDE, the
firefox icon in the kickstart/kicker/kickoff was gone but the text was
present. However, *Firefox was no longer on my system*? I did look in
/usr/local/bin, but no firefox. This is definitely something I need to pay
better attention to- of course "fun" things like these are a surprise. If I
can repeat it, I will give more information next time (assuming there is any
to give).

The only thing that springs to mind, is an earlier mention of PBI removals
leaving something behind, but how that could have combined with anything
else to cause firefox to become hidden/gone, I don't know.

*Other* things I did:

   - Used system manager to add lxde, seemed to work fine but I haven't
   tested the DE.


   - Used system manager to add hplip, and after some effort to configure my
   networked HP printer, could print again! :)


The printer configurator loses the section name highlight on the left panel
when any changes in the right panel are applied.  If there are is no title
for the right panel, *and* the highlight in the left panel vanishes, there
is no way to be certain which section is opened.  Ease of use wise, this
needs to be corrected, but everything does seem to function. I could even
ask my HP CP2025n the toner levels.. I did not need to open the separate
Hplip utility.
Communication with my printer seems a little slow to initiate the print,
either due to the content size/complexity or my network setup. I will know
in a few days if adding memory improves it, and I can check whether a more
direct network connection would help.
*
Another *crash:

While only having KDE available, and using KDE, I opened the control panel.
On a whim, I tried the DE/WM switcher. It allowed me to choose Gnome, but
this dimmed the icons in the panel then eventually caused the control panel
to crash.

If a DE/WM is *not* installed, it should not be visible as an option, or
display a message "this DE/WM is not installed", or even just display the
dimmed-out panel items for that unavailable DE/WM.

Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20110821/7d6fd97b/attachment-0001.html>


More information about the Testing mailing list