[PC-BSD Testing] notes on latest 9 snapshot (GNOME install)

Koop Mast kwm at rainbow-runner.nl
Mon Apr 11 02:30:00 PDT 2011


On Thu, 2011-04-07 at 11:52 +0000, Dru Lavigne wrote:
> These notes are for the 32 bit full version running in VirtualBox with
> GNOME installed as the only desktop.
> 
> During installation:
> 
> Auto-login user checkbox has been removed from Users screen; what is
> the default and how does it get changed?
> 
> The path for bash in the shell drop down menu is truncated. Do we need
> to put in the full path names or are users only interested in the
> shell name?
> 
> Either the font is funky or there is a typo when referring to
> localization in Desktop selection screen. The first reference looks
> like Base-I18N and the second like L10N (under KDE4)
> 
> Really like the new progress bars!
> 
> In the GNOME desktop:
> 
> The following may be issues with the games/gnome-games
> and /games/gnome-games-extra-data ports:
> 
> Applications -> Games -> Arcade -> Nibbles launches but doesn't seem
> to do anything (unless I'm missing the point of this game)
> 
> Applications -> Games ->Board Games -> lagno launches but doesn't seem
> to do anything (unless I'm missing the point of this game)
> 
> Applications -> Games ->Logic Games -> Lights Off does not launch
> 
> Applications -> Games ->Logic Games -> Swell Foop does not launch
> 
> Applications -> Games -> Quadrapassel does not launch

This is a known issue. Gnibbels is a clutter game and lights Off is a
seed game. Both needs acceleration to work.

> More GNOME issues:
> 
> Internet -> Epiphany web browser works great until you go to a website
> that uses flash (e.g. it crashed when I went to youtube)

This seems to be a problem with nspluginwrapper. When I run epiphany
from console it complains about a assertion and makes epiphany exit.

> Applications -> Multimedia -> Sound recorder gives this error when it
> launches:
> 
> "Your audio capture settings are invalid. Please correct them with the
> "Sound Preferences" under the System Preferences menu."
> 
> Going there results in the message "waiting for sound system to
> respond" which stays there forever until you close it (still no sound,
> still no preferences menu that opened to set it)

Works for me, but maybe a virtualbox thing? It probably doesn't help my
virtualbox host is a windows box...

> Applications -> Office -> Evolution Mail & Calendar opened up too
> large so that you could not see or access the forward/next buttons to
> go through the setup wizard. I tried tabbing but since I could not see
> the buttons I kept finding the cancel buttons  within the setup.

Well not much I can do about this ... Only thing I can say is that if
you keep alt pressed, you can left click drag the window up so you can
see the buttons.

> Applications -> Services -> Shared Folders gives this error on launch:
> "You need to install at least either Samba or NFS in order to share
> your folders".

Maybe it wants tools one of the samba ports installs. This seems to be
one of the spot that is tested very little or not at all.

> Applications -> System is a little confusing as it mixes both PC-BSD
> utilities with GNOME utilities. Should all the PC-BSD utilities be
> placed in "PC-BSD Control Panel" and not repeated in System menu? A
> screenshot can be seen at
> http://wiki.pcbsd.org/index.php/File:Gnome-system.png.

Good point, it will clear up for users what belongs where.

> Applications -> System -> Root Terminal does not launch

Root terminal does: "gksu /usr/bin/x-terminal-emulator". gksu works, but
I can't find any x-terminal-emulator on my install. So that seems to be
the problem here.

-Koop

> It makes sense to add an entry for the PC-BSD Control Panel to System
> -> Administration menu. Or at least its contents, only about 1/3 of
> the items are here, see the screenshot at
> http://wiki.pcbsd.org/index.php/File:Gnome-system1.png.
> 
> There are 2 icons to the Handbook on the desktop. The one named "Users
> Handbook" has correct icon and location. The one named "PC-BSD
> Handbook" has wrong location and no icon (the icon looks like a white
> sheet of paper). The icon to the PC-BSD website is also incorrect
> (blank sheet of paper), but its link works.
> 
> Everything else in GNOME worked, the PC-BSD wallpapers were the
> default, the PC-BSD icons were there, and it logged into GNOME no
> problem with GNOME being the only desktop installed.
> 
> Cheers,
> 
> Dru




More information about the Testing mailing list