[PC-BSD Testing] ZFS pools and the installer

Jack Downes jdownes at krmc.org
Tue Nov 16 09:26:42 PST 2010


Hello, I'm new to PC BSD.  have worked with OpenSolaris and FreeBSD.  My problem:

First off I'm using the PC BSD 8.1 installer.

I've booted the PC with the dvd, zfs/osol kernel modules did load.  There are 3 drives in this box.  I've destroyed all the partitions on them, installed the GPT labels, and put in a freebsd-boot, freebsd-swap, and freebsd-zfs slice in each.  Using the 3 freebsd-zfs slices, I've created a single raidz called "rpool". 

Reboot the PC again.

PC-BSD boots up, appears to recognize everything.  In the X client, I can use an xterm and get information via zpool list and zfs list which make sense according to my setup.

However, the Disk Setup portion of SysInstaller doesn't appear to see this rpool.  What it sees are the three slices on each of the drives, and seemingly won't let me setup a zpool using existing partitions.  now, i've tried to just use the gui for this, but it is not particularly helpful, and i cannot get it to let me make an rpool.

So, now my question:

is this being worked on in the Testing Version?  Can I try it out? 

 
thanks,

Jack Downes
Health Information Technology, KRMC

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20101116/028d5711/attachment.html>


More information about the Testing mailing list