[PC-BSD Testing] Upgrade to 8.1 fails

Jeff dejamuse at yahoo.com
Wed Jul 28 12:02:57 PDT 2010


I can extract PBIs if I use Dolphin as user Jeff, but it fails if I use root Dolphin.

Reinstalled MS TT fonts and that's working now.

I couldn't get the Warden to start so I just reinstalled it.

Question:  I was assuming just saving the jail directory, i.e. jails/192.168.1.12 containing my jail would be enough since the old Warden PBI was supposed to just carry over, well oops, now that may not be possible.  Can I just create a new jail and put the directory structure in place and expect it to work, or do I put the directory structure in place and expect the Warden to figure it out, or none of the above?

I can always import a slightly older version of my jail that was exported as .wdn, and change some of the files manually.

Also, for some reason when I start root Dolphin, the default directory is /root/home/Jeff but the correct path should be /home/Jeff as it is when using Dolphin non-root. Somehow I must have copied the /Jeff directory wrong - I was making a lot of mistakes late at night half asleep when restoring my files - not smart.  But the weird thing is that the Jeff directory only contains a subset of files from the backup - missing some files randomly.

I hate when things get messy like this - inclined to blow it all away and start from scratch with fresh PBIs, etc.  Probably take a day or two but at least I know it will be clean.

--- On Wed, 7/28/10, Jeff <dejamuse at yahoo.com> wrote:

From: Jeff <dejamuse at yahoo.com>
Subject: Re: [PC-BSD Testing] Upgrade to 8.1 fails
To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
Date: Wednesday, July 28, 2010, 2:17 PM

By -text I thought you meant ./gimp-2.6 for example to see if the program starts from the CLI.  The Gimp directory was missing library files for some reason - I just recopied the PBI files and now it works.

But with Kompozer I get this error when trying to start it from the command line (as root):

[Jeff at pcbsd] /usr/Programs/bin# kompozer

/: write failed, filesystem is full
/root/.config/qtcurve/gtk-icons:85: error: scanner: unterminated string constant
:1: error: unexpected character `\274', expected keyword - e.g. `style'
/root/.config/qtcurve/gtk-icons:85: error: scanner: unterminated string constant
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for
 information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
----------------
Then I get a popup asking to make a new user profile for Kompozer.

But doing the same as user Jeff:

[Jeff at pcbsd]/usr/Programs/bin(76)% kompozer
:1: error: unexpected character `\274', expected keyword - e.g. `style'
/libexec/ld-elf.so.1: /usr/local/lib/libORBit-2.so.0: Undefined symbol "g_malloc0_n"
Locale: "en" 
(18034) KIconCache::Private::themeDirsChanged: Theme directory has been modified

And then the program crashes spitting out the same error in a popup.

There is a hidden directory at: /home/Jeff/.kompozer.net/  that contains config and user profile stuff, but it seems Kompozer can't find it or
 something.

I've checked to make sure all the files are intact at /usr/Programs/kompozer

I rebooted the system but now any PBI won't extract - reports corrupt.

Very strange...


--- On Wed, 7/28/10, Kris Moore <kris at pcbsd.org> wrote:

From: Kris Moore <kris at pcbsd.org>
Subject: Re: [PC-BSD Testing] Upgrade to 8.1 fails
To: testing at lists.pcbsd.org
Date: Wednesday, July 28, 2010, 1:35 PM





  
On 07/28/2010 12:41, Jeff wrote:

  
    
      
        
        
        
          
            
              What
would prevent me from extracting a PBI?  I've seen this in the past and
it was always something in the PBI that needed updating.  Did you
download the latest PBI to try extracting?

              

I restored the /usr/Programs directory and files, and my /usr/home
directory.

              

              
            
          
        
        
        
      
    
  

Did you try that -text command I suggested? It sounds like its missing
a library to finish the PBI installation properly.






  
    
      
        
        
        
          
            
              From
the bin directory for gimp:

              

/media/disk2/program2/Gimp/bin# ./gimp-2.6

/libexec/ld-elf.so.1: Shared object "libgimpwidgets-2.0.so.0" not
found, required by "gimp-2.6"

Discovered that only a fraction of the files in /gimp... got copied -
strange, because all I did was drag all the directory icons from one
pane to another in Dolphin and told it to copy.  Not sure why some
files made it but others didn't.

              

              
            
          
        
        
        
      
    
  


  
    
      
        
        
        
          
            
              Just
recopied and overwrote the existing gimp directory and now it works. 

              

I think the problem with some of these PBIs is that I copied them over
in the root version of Dolphin so that all the PBI files are owned by
root/wheel.  I assume they should all be Jeff/Jeff so that they can
find their config files in my home directory, right?  If I just chown
all the files in the /usr/Programs directory I assume they will wake up
and find the old config stuff in /home/Jeff.  Correct?

              

Almost there!

              
            
          
        
        
        
      
    
  



PBIs are installed as "root:wheel", so thats normal. To test running
one, try this:



/usr/Programs/Gimp/.sbin/gimp



(Note the .sbin, that is the directory we use to execute PBI binaries,
it contains the wrapper for shared library support)







-- 
Kris Moore
PC-BSD Software
iXsystems
 

-----Inline Attachment Follows-----

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-----Inline Attachment Follows-----

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20100728/c0cf5249/attachment.html>


More information about the Testing mailing list