[PC-BSD Testing] Upgrade to 8.1 fails

Jeff dejamuse at yahoo.com
Tue Jul 27 23:03:44 PDT 2010


Oops, I believe I accidentally deleted the Xorg.conf file in /home.  

Ran the CD again and selected 'update'.

Now login works ok, no entropy error, apps work (but still don't show up in software update manager) and icons are back on the desktop, numlock comes on but then disappears as soon as the desktop loads, and no more hanging GUI after startup (and no file index thingy that was popping up in the lower left that seemed to be the source of the hanging before).

System settings like fonts and color scheme didn't get applied.  Firewall exceptions were all blown away.

Oddly, the Xorg.conf file seemed to exist and then disappear again...

MS True Type Fonts PB I is installed
 (from the old system) but not working in Firefox.  Same problem as before when I had to manually create symlinks and reinstall the PBI.  Can't do that now because the software manager isn't showing any PBIs.  Also the old symlink won't work because the fonts apparently have been moved - there is no /PCBSD/local... anymore.

The Warden crashes with stderr: /libexc/ld-elf.so.1: /usr/local/lib/libXi.so: Undefined symbol "XESetWireToEventCookie" Locale: "en"

Starting Gimp gives error: Stderr: /Programs/bin/gimp: /Programs/Gimp/bin/gimp: not found  Locale: "en"
(13212)KIconCache::Private::themeDirsChanged: Theme directory has been modified

Starting Kompozer failed: Stderr: :1: error: unexpected character `e', expected keyword - e.g. `style'
/libexec/ld-elf.so.1: /usr/local/lib/libORBit-2.so.0: Undefined symbol "g_malloc0_n"
Locale: "en" 

All the other PBIs work, but VLC isn't in the menu and can't be found in a app search with the menu updating tool.

I can reinstall the failing PBIs, but I'm wondering just how stable this system is now.  Has anyone else reported any of this?

Might be better to start over cleanly and reinstall all PBIs.  Ugh.

....Jeff









--- On Tue, 7/27/10, Jeff <dejamuse at yahoo.com> wrote:

From: Jeff
 <dejamuse at yahoo.com>
Subject: Re: [PC-BSD Testing] Upgrade to 8.1 fails
To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
Date: Tuesday, July 27, 2010, 10:51 PM

Oh yeah, duh. /usr is a mount point not a directory...

Got all my files saved and installed 8.1 from scratch.

Copied over /usr/Programs and /usr/home

Some issues:

I copied over ../applnk icons but they don't appear in the menu or on the desktop.  Running the software update tool finds no installed apps.

On
 power down, system reports when writing entropy file "write
 failed - file system full"

After PCBSD desktop comes alive on power up, and after about 30 seconds the system is crunching away doing something that hangs the GUI for a while and eventually recovers.

Numlock doesn't default to on at power up.

None of
 the system settings, and preferences were re-instituted.

After the 5th or so restart, auto login stopped working, and now I CAN'T LOGIN!  I'm locked out.  I just get the "Welcome to pcbsd-1693" screen and the login box.  Refuses to recognize user and password.

I backed up the etc directory too.  Is there something in there I should copy over to get the system back the way it was?

Thanks, Jeff

--- On Tue, 7/27/10, Kris Moore <kris at pcbsd.org> wrote:

From: Kris Moore <kris at pcbsd.org>
Subject: Re: [PC-BSD Testing] Upgrade to 8.1 fails
To: testing at lists.pcbsd.org
Date: Tuesday, July 27, 2010, 3:24 PM





  
On 07/27/2010 15:19, Jeff wrote:

  
    
      
        Ok, typing error.

        

I was able to mount the drive to /old but can't get anything off of it.

        

I don't understand how to chroot in or why that's necessary even.

        

Tried using chroot as a command and ended up with a prompt like this:
@#pcbsd.

        

Rebooted and tried remount the drive but now says it wasn't properly
dismounted.

        

HELP!

        
      
    
  



If you just plan on backing up some files you can skip the chroot part.



Go ahead and mount ad0s1a -> /mnt



Then you may need to mount "/usr" as well, so try:



mount /dev/ad0s1d /mnt/usr



Then if you cd to /mnt/usr you should see "Programs" and "home" and the
various other stuff in the old /usr partition.



(If you don't see those files, try mounting ad0s1e or ad0s1f, since it
may depend upon how the original disk was setup)





-- 
Kris Moore
PC-BSD Software
iXsystems
 

-----Inline Attachment Follows-----

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-----Inline Attachment Follows-----

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20100727/5303fa37/attachment-0001.html>


More information about the Testing mailing list