[PC-BSD Testing] PCBSD 8.1-RELEASE, couple of things I've found

Arthur Koziol A-Koziol at neiu.edu
Thu Jul 22 07:56:31 PDT 2010


Kris,

Already kicking the tires on the new release and it's very snappy. I did 
find a couple of things:

1. Depending on the Suspend mode set in the BIOS (S1 or S3), the Sleep 
icon may not appear. I've discovered that if it is set to S1, the Sleep 
icon does not appear. Are Sleep and Hibernate some new in KDE 4.4.5 or 
something introduced in FBSD 8.1?

2. Put the system into Sleep mode does work but resuming from sleep 
causes a total system and screen lockup. I had to do a hard shutdown to 
get out of the lockup. It ran a fsck on next boot. This was with the 
Intel 3D Enable driver. I tried the non-3D Intel driver and when I tried 
to put it into Sleep mode, I saw the KDE Crash Handler appear for a 
brief second before it went into Sleep mode. When I tried to resume from 
Sleep, the system locked up but this time the monitor didn't even 
initialize. Gee, I wonder if it's the Intel driver? :-P

3. Hibernate actually launches the screensaver but does not actually 
hibernate. If I move the mouse, a password prompt letting me know the 
screen is locked appears. If I log in and try to initiate Hibernate 
again, I get a screen lock-up with no keyboard or mouse available. I was 
able to hit the power button and it seemed to perform a graceful 
shutdown. This was with the Intel 3D Enable driver. I tried the non-3D 
Intel driver and when I tried to put it into Hibernate mode, the KDE 
Crash Handler popped up letting me know "We are sorry, KDE Screen Locker 
closed unexpectedly." The culprit is kscreenlocker. I'm sure it's KDE's 
fault but here's what the crash info said:

Application: KDE Screen Locker (kscreenlocker), signal: Segmentation 
fault: 11
[KCrash Handler]
#6  0x29b46dbc in free () from /lib/libc.so.7
#7  0x2861666d in XFree () from /usr/local/lib/libX11.so.6
#8  0x08053b8b in ?? ()
#9  0x08061435 in ?? ()
#10 0x08061982 in ?? ()
#11 0x0806cc1b in ?? ()
#12 0x08053257 in ?? ()
#13 0x00000002 in ?? ()
#14 0xbfbfe764 in ?? ()
#15 0xbfbfe770 in ?? ()
#16 0xbfbfe750 in ?? ()
#17 0xbfbfe760 in ?? ()
#18 0x00000000 in ?? ()
#19 0xbfbfe75c in ?? ()
#20 0x080531c5 in ?? ()
#21 0x2807ff40 in dlclose () from /libexec/ld-elf.so.1

Probably the Intel driver's fault again.

4. Kicker > System > Firewall Builder & Kicker > Settings > Firewall 
Builder icon is a box with a ? but does seem to launch ok.

5. If you launch Konqueror, the Home Folder and Network Folders icons 
seem to be missing but do open their respective locations just fine.

6. On shutdown, I noticed it complaining about: "grep: 
//.kde4/share/config/kdeglobals/ no such file or directory" and "eval: 
/script/rc.d/shutdown.sh not found." right after "Stopping swap 
monitor..." Don't know if that's important but thought I'd mention it.

7. The Intel driver is the suckingest suck that ever sucked a suck.

thanks,
Arthur


More information about the Testing mailing list