[PC-BSD Testing] PC-BSD 8.1 RC1 + ZFS

Bill Sun billksun at gmail.com
Sat Jul 10 20:45:12 PDT 2010


I was also having troubles with mirrored zfs setup before.  But after
upgrading my motherboard, CPU, and RAM, I was able to successfully install
PC-BSD 8.1 RC1 in a mirrored zfs configuration.  However, I put the SWAP on
the first drive only (the one that I designated a partition as zfs).  I
recall that when I was playing with zfs setup prior to my upgrade, I was not
able to add the second disk to my mirrored zpool when I had set up a second
SWAP partition on the second disk.  The device was simply grayed out.

Here's my zpool setup that I'm running now:

% zpool status
  pool: tank0
 state: ONLINE
 scrub: none requested
config:

        NAME         STATE     READ WRITE CKSUM
        tank0         ONLINE       0     0     0
          mirror      ONLINE       0     0     0
            ada0p2  ONLINE       0     0     0
            ada1p2  ONLINE       0     0     0

So the good news is that mirrored zfs setup does have a working
configuration.

On a side note, how do you access the logs of a failed install?  Maybe we
should put this on the wiki for newbies like me?

-Bill

On Sat, Jul 10, 2010 at 4:51 AM, Johann Hugo <jhugo at meraka.csir.co.za>wrote:

> On Friday 09 July 2010 04:57:33 pm Kris Moore wrote:
> > On 07/09/2010 09:29, Johann Hugo wrote:
> > > Hi
> > >
> > > I've been playing with ZFS during installation. It works fine with only
> > > one disk and a basic ZFS partition on it.
> > >
> > > When I try to create ZFS with a type mirror with two physical disks
> then
> > > it does not work. Seems like the freebsd-zfs geom slice on the second
> > > disk is never created. See attached install log file.
> > >
> > > Johann
> > >
> > >
> > >
> > > _______________________________________________
> > > Testing mailing list
> > > Testing at lists.pcbsd.org
> > > http://lists.pcbsd.org/mailman/listinfo/testing
> >
> > Johann,
> >
> > Can you send me the /tmp/sys-install.cfg file that was used during the
> > failed installation?
> I can't give you the .cfg from that PC, because it is at work, but I've
> just
> tried it at home as well, with almost the same results. This time it did
> not
> create the swap space on the second drive. See attached files.
>
> > Looking at the log, it appears to be doing
> > something a bit weird, trying to format ada1 twice,
> Saw that.
>
> > which makes me think
> > its a configuration problem, possibly something the GUI did wrong.
> Or something weird that I did :-)
>
> Johann
>
> _______________________________________________
> Testing mailing list
> Testing at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/testing
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20100710/350cffc3/attachment.html>


More information about the Testing mailing list