[PC-BSD Testing] Upgrade from Alpha to Beta works!

Kris Moore kris at pcbsd.com
Mon Jan 4 07:20:22 PST 2010


On 01/01/2010 19:09, Ian Robinson wrote:
> Testing PCBSD 8.0-BETA-x64 on HP xw8200, dual Xeon 3.4 / 4 Gb RAM / Nvidia
> Quadro 3400 using NVidia x64 driver
>
> 1.  Performed "Upgrade" successfully.  There was a little glitch in it's
> adoption of xorg.conf.  The upgrade does not require setting the video
> settings, and after reboot it could not load xserver.  The solution was to
> restart and boot with Option #7 to reinstall the xorg drivers.  All other
> pbis, programs, and setting, including ports previously installed via ports
> console, were retained without problem.  Bottom line on the upgrade -- it's
> functioning great.

Thanks for the report! I just fixed the issue and it should now run the 
display setup wizard
post-upgrade properly, was a bug in the new backend.


> 2.  Question about ports console -- I need to have access other hard disks
> when I am using programs (Kaffeine) installed via ports console.  Although
> mounted in the regular GUI, they are not available in the ports console.  In
> my first attempt, I set up /etc/fstab in ports console.  That did not work.
>   Then I tried to set up mountpoints and mount the disks manually.  For
> example, where the target disk is an ide which the system identifies as
> ad0s1 and the mount point is /mnt/ide0, the command "mount /dev/ad0s1
> /mnt/ide0" results in the error message "mount: /dev/ad0s1 : Operation not
> permitted"  Same result if I try to add the slice identifier "a" to the end
> (ad0s1a).  What is the secret to mounting disks in ports console?
>

The ports-console is running within a jail, and there are only a few 
ways to access files
from the "outside". I would recommend using mount_nullfs from outside 
the ports console:

# As root in regular Konsole
# mkdir -p /usr/jails/portjail/mnt/ide0
# mount_nullfs /mnt/ide0 /usr/jails/portjail/mnt/ide0

-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com


More information about the Testing mailing list