[PC-BSD Testing] PCBSD 8.0-x86, nVidia 173.14.xx install problems solved

Ian Robinson fitchkendall at gmail.com
Sun Feb 28 12:06:48 PST 2010


Dear Kris --

nVidia installation problems with 173-14.xx solved.

Please forgive the long-winded history, but I put it there to avoid your
having to go back through the many messages posted in the mailing list.
However, if you don't want to read any further for the explanation of the
initial problem and how I got to the solution, then know this:  The solution
is to add the following lines before attempting to install the nvidia
driver:

add nvidia_load="YES" to /boot/loader.config
add hint.agp.0.disabled="1" to /boot/device.hints


========== 1.  Background Information: ==========

I had written earlier to report on troubles with Nvidia driver installs
under PCBSD 8.0-RCx and RELEASE using two older nVidia cards, a GeForce 4
Ti4200 (using the "legacy" 96.43.xx series) and a GeForce FX 5500 (using the
"older" unified driver 173.14.xx series).  The legacy card (Ti4200) involved
significant screen corruption and sytem freezes.  The FX 5500 failed to
install "out of the box" and I had to resort to the vesa driver.

Using the PCBSD 8.0 nvidia drivers in the PCBSD base install caused errors.
The video install routine looped endlessly reporting that the previous
install attempt had failed, and it cycled back to the video driver graphic
installation page.

Kris Moore rode to the rescue to report nVidia's newer drivers would be
released to ports, and he provided the instructions for updating:

1.  Update ports:  # portsnap fetch extract
2.  Update source: # csup -g -L 2 /root/standard-supfile
3.  Install updated driver:
    # cd /us/ports/x11/nvidia-driver-96/  or (/nvidia-driver-173/)
    # make
    # make deinstall
    # make install

He also recommended trying a removal of ibus from autostarting by deleting
it from /usr/local/etc/xdg/autostart/ibus.desktop.

========== 2. GeForce 4 Ti4200 (96.43.16) worked ==========

For the GeForce 4 Ti4200, Kris' instructions to upgrade from nVidia 96.43.13
to 96.43.16 worked very well, and any signs of screen corruption were
limited to only a few speckles along the right margin of the window in
focus.  It was critical to turn off screen effects in order to avoid
freezes.  The removal of ibus had no effect for me.


========== 3. GeForce FX 5500 (173.14.xx) initial failure ==========

But for the GeForce FX 5500, the upgrade from 173.14.20 to 173.14.25 did
not. I could not break past the install routine except to use vesa as the
driver.  Switching to a console and logging in a root showed error messages
saying:

NVRM: detected agp.ko, aborting NVIDIA AGP setup!

A few lines down the console screen it said:

NVRM: failed to copy vbios to system memory.
RmInitAdapter failed! (0x30:0xffffffff:899)
NVRM: rm_init_adapter() failed!

========== 4. FX 5500 Success ==========

I continued to attempt to install the nVidia drivers.  Eventually, I did
three things that solved the install problem.  <<Thanks to the venerable
dracheflieger, antik, and others @
http://forums.pcbsd.org/viewtopic.php?p=31084>>  I did them BEFORE rebooting
and runing the start-option #7 (install video routine).

(1) I went to /usr/ports/x11/nvidia-drivers (yes, /nvidia-drivers, not
/nvidia-driver-173) and I ran make config, then make install

(2) I added nvidia_load="YES" to /boot/loader.config

(3) I added hint.agp.0.disabled="1" to /boot/device.hints

[Comment:  I believe that editing /boot/loader.conf and /boot/device.hints
in Steps #(2) and #(3) were the critical steps]

Code:
% su
<password>
# portsnap fetch update
# csup -g -L 2 /root/standard-supfile
# cd /usr/ports/x11/nvidia-drivers
# make config
# make install clean
# echo 'nvidia_load="YES"' >> /boot/loader.conf
# echo 'linux_enable="YES"' >> /etc/rc.conf
# echo 'hint.agp.0.disabled="1"' >> /boot/device.hints

I re-ran the PCBSD install routine and to my pleasant surprise, the nvidia
driver was loaded.

After the successful installation of 173.14.20, I then followed Kris Moore's
upgrade instructions to install the 173.14.25 upgrade from ports.  The
upgrade also took successfully.


========== 5.  Comments ==========

The failure to install issue is probably caused by PCBSD/FreeBSD's built-in
agp.ko being in conflict with nvidia's driver.  Steps #(2) and #(3) address
that issue.

After rerunning the PCBSD install video driver routine, the driver listed in
the pick box (and what ended up being installed) was 173.14.20 instead of
the updated 173.14.25.  The pick box does not show 173.14.25 as an option
because the file containing the pick list menu and its pointers to the files
does not get upgraded by a ports update.

I am therefore also guessing that the PCBSD install routine loads the driver
from /PCBSD/packages/i386 instead of from /usr/ports/distfiles or
/usr/ports/x11/nvidia-driver-173.  The naming structure of these two target
files is different as well.  For example, the built-in PCBSD file at
/PCBSD/packages/i386/ is called nvidia-driver-173.14.20.tbz while the
version installed from /ports/x11/nvidia-driver-173 and placed into
/ports/distfiles/ is called NVIDIA-FreeBSD-x86-173.14.25.tar.gz.

Since the upgraded port was not used, I am doubtful that Step #(1) above was
critical to the initial success, and that is why I attribute the success to
Steps #(2) and #(3).  It would be good if the PCBSD install nvidia driver
routine could address these two items, and perhaps it used to  do this,
because agp.ko is built into the kernel and loaded by default.


Ian Robinson
Salem, Ohio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20100228/e2f3adba/attachment.html>


More information about the Testing mailing list