[PC-BSD Testing] PCBSD 8.0-x86 -- Nvidia Legacy Driver173.14.xx fails to install

Ian Robinson fitchkendall at gmail.com
Wed Feb 24 07:26:32 PST 2010


Follow-up on nvidia 173.14.2x failure on PCBSD 8.0-x86:

On Wed, Feb 24, 2010 at 9:54 AM, Ian Robinson <fitchkendall at gmail.com>wrote:

> Dear Kris --
>
> Although previous attempts with nVidia GeForce 4 series was successful
> after upgrading the driver and turning off desktop effects, numerous
> attempts to install an nVidia FX 5500, Video Bios Version 4.34.20.54J [NV
> 34.6] have failed.  Hardware details are at the end of this report.
>
> PCBSD 8.0-x86 includes nVidia's binary driver, 173.14.20, but several
> installation attempts failed with the following error message showing it
> failed to copy vbios to system memory, etc.:
>
> nvidia0: <GeForce FX 5500> on vgapci0
> vgapci0: child nvidia0 requested pci_enable_busmaster
> vgapci0: child nvidia0 requested pci_enable_io
> nvidia0: [GIANT-LOCKED]
> nvidia0: [ITHREAD]
> NVRM: failed to copy vbios to system memory.
> RmInitAdapter failed! (0x30:0xffffffff:899)
> NVRM: rm_init_adapter() failed!
>
> I switched to the vesa driver and went through the upgrade to nVidia driver
> 173.14.25.  It failed with the same error message.
>
> There was no access to nvidia-xconfigure or nvidia-settings, but perhaps
> that is because no nvidia driver was installed.
>
> Additionally, because I could not get boot option 7 video installer routine
> to install a driver, I attempted to copy the working xorg.conf file from the
> previous -RC installation.  That failed too.
>
> Previously this computer and video card combination worked in PCBSD 7.1.1,
> 8.0-BETA, and  8.0-RC.
>
> ======== Further Equipment/Software Details ======
>
> 1.  Excerpts from dmesg output:
>
> FreeBSD 8.0-RELEASE-p2 #4: Thu Jan  7 09:20:42 PST 2010
>     root at build8x32.pcbsd.org:
> /usr/obj/usr/pcbsd-build80/fbsd-source/8.0-src/sys/PCBSD
> Timecounter "i8254" frequency 1193182 Hz quality 0
> CPU: Intel(R) Pentium(R) 4 CPU 2.00GHz (1992.63-MHz 686-class CPU)
>   Origin = "GenuineIntel"  Id = 0xf24  Stepping = 4
>
> Features=0x3febfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM>
> real memory  = 1610612736 (1536 MB)
> avail memory = 1530015744 (1459 MB)
>
>           <* * * other output omitted * * *>
>
> sc0: <System console> at flags 0x100 on isa0
> sc0: VGA <16 virtual consoles, flags=0x300>
> vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
>           <* * * other output omitted * * *>
> nvidia0: <GeForce FX 5500> on vgapci0
> vgapci0: child nvidia0 requested pci_enable_busmaster
> vgapci0: child nvidia0 requested pci_enable_io
> nvidia0: [GIANT-LOCKED]
> nvidia0: [ITHREAD]
> NVRM: failed to copy vbios to system memory.
> NVRM: RmInitAdapter failed! (0x30:0xffffffff:899)
> nvidia0: NVRM: rm_init_adapter() failed!
> nvidia0: detached
> nvidia0: <GeForce FX 5500> on vgapci0
> vgapci0: child nvidia0 requested pci_enable_busmaster
> vgapci0: child nvidia0 requested pci_enable_io
> nvidia0: [GIANT-LOCKED]
> nvidia0: [ITHREAD]
> NVRM: failed to copy vbios to system memory.
> NVRM: RmInitAdapter failed! (0x30:0xffffffff:899)
> nvidia0: NVRM: rm_init_adapter() failed!
>
> 2.  Hardware details:
>
> vgapci0: <VGA-compatible display> mem
> 0xde000000-0xdeffffff,0xc0000000-0xcfffffff irq 16 at device 0.0 on pci1
> nvidia0: <GeForce FX 5500> on vgapci0
>
> vgapci0 at pci0:1:0:0:    class=0x030000 card=0x00000000 chip=0x032610de
> rev=0xa1 hdr=0x00
>     vendor     = 'Nvidia Corp'
>     device     = 'GeForce FX 5500 [NV34.6]'
>     class      = display
>     subclass   = VGA
>
> 3.  list of nvidia-related files (including ports "work" subdirectory)
>
> root at pcbsd-8989# find /usr -name 'nvidia*'
> /usr/local/lib/xine/plugins/1.26/vidix/nvidia_vid.so
> /usr/PCBSD/xorg-gui/templates/scripts/nvidia.sh
>
> /usr/PCBSD/xorg-gui/templates/header/nvidia.xorg.conf
>
> /usr/PCBSD/xorg-gui/templates/driver/nvidia.template
>
> /usr/PCBSD/xorg-gui/nvidia-detect
>
> /usr/PCBSD/xorg-gui/nvidia-detect/nvidia17-pciid.txt
>
> /usr/PCBSD/xorg-gui/nvidia-detect/nvidia9x-pciid.txt
>
> /usr/PCBSD/packages/i386/nvidia-driver-195.22.tbz
>
> /usr/PCBSD/packages/i386/nvidia-driver-96.43.13.tbz
>
> /usr/PCBSD/packages/i386/nvidia-settings-195.22.tbz
>
> /usr/PCBSD/packages/i386/nvidia-driver-173.14.20.tbz
>
> /usr/PCBSD/pc-sysinstall/conf/licenses/nvidia-en.txt
>
> /usr/ports/x11/nvidia-driver
>
> /usr/ports/x11/nvidia-driver-173
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/x11/man/nvidia-settings.1
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/x11/man/nvidia-xconfig.1
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/mk/
> nvidia.lib.mk
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/obj/nvidia_drv.so
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/obj/nvidia-settings
>
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/obj/nvidia-xconfig
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/obj/nvidia-bug-report.sh
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_sysctl.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_subr.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_pci.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_os_registry.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_os_pci.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_os.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_linux.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_i2c.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_dev.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_ctl.c
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_ctl.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_dev.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_linux.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_os.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_os_pci.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_os_registry.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_pci.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_subr.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_sysctl.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia_i2c.o
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia.kld
>
> /usr/ports/x11/nvidia-driver-173/work/NVIDIA-FreeBSD-x86-173.14.25/src/nvidia.ko
> /usr/ports/x11/nvidia-driver-71
> /usr/ports/x11/nvidia-driver-96
> /usr/ports/x11/nvidia-settings
> /usr/ports/x11/nvidia-xconfig
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig.c
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig.h
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-cfg.h
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig.1.m4
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig.d
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig.o
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig
> /usr/ports/x11/nvidia-xconfig/work/nvidia-xconfig-1.0/nvidia-xconfig.1
> /usr/ports/graphics/nvidia-texture-tools
> /usr/ports/distfiles/nvidia-xconfig-195.36.03.tar.gz
> root at pcbsd-8989#
>
> I cannot give you a kldstat listing of any relevance since I am running
> under the vesa driver at this time.
>
> Please advise if you would like any additional information provided.
>
> Ian Robinson
> Salem, Ohio
>
>

Here is the nVidia-related output from /var/log/Xorg.0.log which I have also
attached as a txt file because email will truncate these lines:


X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 8.0-RC3 i386
Current Operating System: FreeBSD pcbsd-8989 8.0-RELEASE-p2 FreeBSD
8.0-RELEASE-p2 #4: Thu Jan  7 09:20:42 PST 2010
root at build8x32.pcbsd.org:/usr/obj/usr/pcbsd-build80/fbsd-source/8.0-src/sys/PCBSD
i386
Build Date: 08 February 2010  06:12:23PM

    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Feb 23 23:50:03 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "AllowEmptyInput" "Off"
(**) Option "AutoAddDevices" "False"
(**) Not automatically adding devices
(==) Automatically enabling devices
(WW) `fonts.dir' not found (or not valid) in "/Programs/fonts/".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/Programs/fonts/").
(WW) The directory "/usr/local/lib/X11/fonts/webfonts/" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/local/lib/X11/fonts/CID/" does not exist.
    Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in
"/usr/local/lib/X11/fonts/dejavu/".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/local/lib/X11/fonts/dejavu/").
(WW) `fonts.dir' not found (or not valid) in
"/usr/local/lib/X11/fonts/local/".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/usr/local/lib/X11/fonts/local/").
(**) FontPath set to:
    /usr/local/lib/X11/fonts/cyrillic/,
    /usr/local/lib/X11/fonts/TrueType/,
    /usr/local/lib/X11/fonts/misc/,
    /usr/local/lib/X11/fonts/TTF/,
    /usr/local/lib/X11/fonts/Type1/,
    /usr/local/lib/X11/fonts/75dpi/,
    /usr/local/lib/X11/fonts/100dpi/,
    /usr/local/lib/X11/fonts/misc/,
    /usr/local/lib/X11/fonts/TTF/,
    /usr/local/lib/X11/fonts/OTF,
    /usr/local/lib/X11/fonts/Type1/,
    /usr/local/lib/X11/fonts/100dpi/,
    /usr/local/lib/X11/fonts/75dpi/
(**) ModulePath set to "/usr/local/lib/xorg/modules"
(II) Loader magic: 0x7a0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 5.0
    X.Org XInput driver : 4.0
    X.Org Server Extension : 2.0
(II) Loader running on freebsd
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(0:1:0:0) 10de:0326:0000:0000 nVidia Corporation NV34 [GeForce FX
5500] rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, BIOS @
0x????????/65536
(II) System resource ranges:
    [0] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
    [1] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
    [2] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [3] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
    [4] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified
in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in
the config file.
(II) "glx" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) LoadModule: "dbe"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/local/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/local/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(==) AIGLX disabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/local/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "vesa"

<* * * omitted the rest of log relating to vesa install * * *>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20100224/0ed89ff3/attachment-0001.html>
-------------- next part --------------

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 8.0-RC3 i386 
Current Operating System: FreeBSD pcbsd-8989 8.0-RELEASE-p2 FreeBSD 8.0-RELEASE-p2 #4: Thu Jan  7 09:20:42 PST 2010     root at build8x32.pcbsd.org:/usr/obj/usr/pcbsd-build80/fbsd-source/8.0-src/sys/PCBSD i386
Build Date: 08 February 2010  06:12:23PM
 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Feb 23 23:50:03 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "AllowEmptyInput" "Off"
(**) Option "AutoAddDevices" "False"
(**) Not automatically adding devices
(==) Automatically enabling devices
(WW) `fonts.dir' not found (or not valid) in "/Programs/fonts/".
	Entry deleted from font path.
	(Run 'mkfontdir' on "/Programs/fonts/").
(WW) The directory "/usr/local/lib/X11/fonts/webfonts/" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/local/lib/X11/fonts/CID/" does not exist.
	Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/usr/local/lib/X11/fonts/dejavu/".
	Entry deleted from font path.
	(Run 'mkfontdir' on "/usr/local/lib/X11/fonts/dejavu/").
(WW) `fonts.dir' not found (or not valid) in "/usr/local/lib/X11/fonts/local/".
	Entry deleted from font path.
	(Run 'mkfontdir' on "/usr/local/lib/X11/fonts/local/").
(**) FontPath set to:
	/usr/local/lib/X11/fonts/cyrillic/,
	/usr/local/lib/X11/fonts/TrueType/,
	/usr/local/lib/X11/fonts/misc/,
	/usr/local/lib/X11/fonts/TTF/,
	/usr/local/lib/X11/fonts/Type1/,
	/usr/local/lib/X11/fonts/75dpi/,
	/usr/local/lib/X11/fonts/100dpi/,
	/usr/local/lib/X11/fonts/misc/,
	/usr/local/lib/X11/fonts/TTF/,
	/usr/local/lib/X11/fonts/OTF,
	/usr/local/lib/X11/fonts/Type1/,
	/usr/local/lib/X11/fonts/100dpi/,
	/usr/local/lib/X11/fonts/75dpi/
(**) ModulePath set to "/usr/local/lib/xorg/modules"
(II) Loader magic: 0x7a0
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 5.0
	X.Org XInput driver : 4.0
	X.Org Server Extension : 2.0
(II) Loader running on freebsd
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(0:1:0:0) 10de:0326:0000:0000 nVidia Corporation NV34 [GeForce FX 5500] rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, BIOS @ 0x????????/65536
(II) System resource ranges:
	[0] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[1] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[2] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[3] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[4] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) LoadModule: "dbe"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.6.5, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/local/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.6.5, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/local/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 1.6.5, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(==) AIGLX disabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/local/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.6.5, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.6.5, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.6.5, module version = 1.1.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "vesa"


More information about the Testing mailing list