[PC-BSD Testing] PCBSD 8.0-RC2-x86 & Nvidia Legacy Drivers -- Follow-up

Ian Robinson fitchkendall at gmail.com
Wed Feb 17 20:03:45 PST 2010


Re:  Follow-up on screen corruption with PCBSD 8.0-RC2-x86 & Nvidia Legacy
Driver 96.43.13.

Ian Robinson's original post said:

>> -RC2 x64 with Nvidia 192.22 is behaving very nicely for me, but -RC2 and
>> legacy drivers caused grief when I did a fresh install of -RC2-x86 on an
>> older computer.  The older computer uses an Nvidia GeoForce 4 card (a Ti
>> 4200) and the legacy driver installed is 96.43.13 . . . .
>> The 96.43.xx driver worked well under PCBSD 7.1.1.  Under PCBSD
8.0-Alpha,
>> it worked but not without some screen corruption such as random speckled
>> dots across the display and an occasional but not major horizontal line
or
>> two distorting the text or graphic which would go away if you scrolled
the
>> item beneath them up or down off the screen and brought it back.  I have
not
>> tested this computer with 8.0-BETA or 8.0-RC.  The behavior in -RC2 is
worse
>> that the Alpha series. . . .
>> After the passage of some minutes, the screen corrupts badly with thick
>> black horizontal bands across the display.  Ultimately, the system will
>> freeze.
>>
>> I wonder if that is part of the problem?  We all know that FreeBSD is at
>> RELEASE stage.  Given that Nvidia 96.43.16 is newer than 96.43.13, are
they
>> both living in a FreeBSD 7.x world rather than FreeBSD 8.0?  That would
>> explain why the drivers worked great with FreeBSD 7.x and did not work
with
>> FreeBSD 8.0.  There could be other reasons, though.  Is PCBSD 8.0-RC2
>> breaking something because of its recent upgrade to xorg-server 1.6.1?

Kris Moore said:

>Ian,
>
>Since the driver actually installs and starts to work at first, I'm
>guessing its a compat issue with the FreeBSD 8.0 base, or the new
>xorg-server 1.6.5. If you want, you can grab a copy of 8.0-RC, which has
>the older Xorg-server, that way we can narrow it down to the system itself.

================= Follow-up==========================

I grabbed PCBSD 8.0-RC-x86, put the nVidia card back in and installed the
-RC with a fresh install using the nVidia 96.43.13.

I have had no problems, so it may well be that the new xorg-server 1.6.5 is
involved to some degree in causing conflict with 96.43.13.

Ian Robinson
Salem,  Ohio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20100217/fa1025df/attachment.html 


More information about the Testing mailing list