[PC-BSD Testing] python plasmascript seems missing.

Grégoire Welraeds gregoire.welraeds at gmail.com
Fri Feb 12 13:47:50 PST 2010


Hi Kriss,
Since I did not get your feedback on this issue. I just wanted to know what
you think about it. Sorry to bother you with this.

Regards,
Grégoire.

On Mon, Feb 8, 2010 at 9:57 PM, <gregoire.welraeds at gmail.com> wrote:

> Hi Kriss,
> Thank you for answering my email. I went to the #kde-freebsd channel to
> discuss this issue. I had an interesting discussion with one of the kde
> developper (involved in the Ark development). And here is what he told me
> (hope he don't mind me quoting him):
> [quote]
> there are two things involved here:
> 1) python support for plasma in kdebase needs kdebindings for pykde4; IIRC
> there was some sort of circular dependency in which kdebindings required
> kdelibs and kdebase (I'm not sure if this is still the case), so you might
> need to end up building kdebase twice
> 2) python support for kdebase is explicitly disabled in
> kdebase4-workspace's
> Makefile (no idea why)
> [/quote]
> So to fix this issue, one need to edit the x11/kdebase4-workspace port's
> makefile and remove the line saying -DWITH_PyKDE4:BOOL=OFF from CMAKE_ARGS.
> I tried to do that myself as I have the FreeBSD port installed, but it
> failed:
> [quote]
> CMake Error at
> /usr/local/kde4/share/apps/cmake/modules/FindKDE4Internal.cmake:1192
> (message):
>  ERROR: the installed kdelibs version 4.3.4 is too old, at least version
>  4.3.5 is required
> [/quote]
> Since I'm using the PCBSD box on daily basis for my work, I don't want to
> go
> and rebuild everything, particularly if 4.3.5 is shipped with PCBSD 8.0
> Release.
>
> My question is do you think we might expect to have the issue fixed along
> with
> this release?
>
> Best regards,
> Gregoire.
>
> On Monday 08 February 2010 06:49:01 pm Kris Moore wrote:
> > On 02/08/2010 12:45, gmail wrote:
> > > Thanks to some support in the PCBSD Forum, It looks like the issue also
> > > exists in FreeBSD 8.0/KDE 4.3.1. Have a look here:
> > > http://forums.freebsd.org/archive/index.php/t-7748.html
> > >
> > > Is there something I can do? Should I report the issue to FreeBSD
> ports?
> > >
> > > Regards,
> > >
> > > Grégoire.
> >
> > If you like go ahead and report the specifics of the issue to the
> > KDE-freebsd porting team:
> >
> > https://mail.kde.org/mailman/listinfo/kde-freebsd
> >
> > I'm on that list as well, but don't know what the issue is off the top
> > of my head, not much of a python user, but maybe one of the other guys
> > will have some tips / fixes to getting this resolved.
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20100212/c0822329/attachment.html 


More information about the Testing mailing list