[PC-BSD Testing] /media/.hal-mtab

Ian Robinson fitchkendall at gmail.com
Fri Aug 13 20:52:48 PDT 2010


On Thu, Aug 12, 2010 at 3:00 PM, Bill Sun wrote:

I did some more digging around and found a file name ".hal-mtab" in /media.
It looks like this file records the mount parameters used by HAL.

Here's an entry of one of my mount attempts via Dolphin:

# /dev/ntfs/FreeAgent Drive    1001    0    ntfs   nosuid,-u=1001,-C=UTF-8
 /media/FreeAgent Drive-3

Notice that there are spaces between the paths.  Could this be causing the
mount issues?

I tried using the paths above manually in a mount command:

# mount -t ntfs /dev/ntfs/FreeAgent Drive /media/FreeAgent Drive-3

But this gives me:

ntfs-3g: You must specify exactly one device and exactly one mount point.

I even tried using quotes around the paths and even "\" to escape the space,
but I still get the same error.

However, when I used paths with no spaces:

mount -t ntfs /dev/da0s1 /media/FreeAgent

This works.

-Bill
======================================

Bill --

You may have nailed the problem.  Perhaps you could rename the FreeAgent
Drive-3 to a name with a single word to confirm.


Here are some other examples of mount parameters that are working on my
systems:


(1) Contents of /media/.hal-mtab For an 8Gb USB Flash Drive (Fat32) named
"KINGSTON"

/dev/msdosfs/KINGSTON    1001    0    msdosfs
nosuid,-u=1001,-L=en_US.UTF-8,large,-m=644,-M=755    /media/KINGSTON


(2) Contents of /media/.hal-mtab for a 73 Gb internal mounted SCSI (NTFS)
named "Windows" (this is, by choice, not included in my fstab).

/dev/ntfs/Windows    1001    0    ntfs    nosuid,-u=1001,-C=UTF-8
/media/Windows





Long-time beta-testing contributor A. Yerenkow also discussed HAL and
.hal-mtab issues relating to PCBSD 8.0 at* *this link:*

*http://lists.pcbsd.org/pipermail/testing/2009-April/002190.html


Ian Robinson
Salem, Ohio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/testing/attachments/20100813/fbc3830c/attachment.html>


More information about the Testing mailing list