[PC-BSD Testing] Virtual Box Kris PLEASE HELP!

doverosx at gmail.com doverosx at gmail.com
Thu Apr 8 13:44:35 PDT 2010


On 03/31/2010 18:53, Brodey Dover wrote:
> That is good to know! In this case, I am using a trusty rlX NIC,
> realtek RTL8139D (is it bad that I know that by heart?) so I should be
> fine. I forgot to add that I have added the modules but thought that
> they should be in the PBI (Y).
>
> Thanks Kris!
>
> On Wed, Mar 31, 2010 at 8:04 AM, Kris Moore<kris at pcbsd.org>  wrote:
>    
>> On 03/31/2010 15:03, Josh Paetzel wrote:
>>      
>>> On Wednesday 31 March 2010 04:22:22 Kris Moore wrote:
>>>
>>>        
>>>> On 03/30/2010 22:05, doverosx at gmail.com wrote:
>>>>
>>>>          
>>>>> I just downloaded the most recent PBI for AMD64 PC-BSD 8. I think
>>>>> there is an issue with using lagg0 as the network adapter and I found
>>>>> that the kernel modules for Virtual Box are required when the network
>>>>> components can not be loaded.
>>>>>
>>>>> Is it possible to check out the addition of these two modules?
>>>>>
>>>>> vboxnetflt.ko
>>>>> vboxnetadp.ko
>>>>>
>>>>> Can someone else test VB ->    set NIC to Bridged and ensure you are
>>>>> using lagg0 as per the most recent PC-BSD release.
>>>>>
>>>>> Thank you,
>>>>> Brodey Dover
>>>>>
>>>>>            
>>>> I've fixed the PBI to load those additional network modules now. If you
>>>> want to do it manually in the meantime, do this:
>>>>
>>>> # cd /Programs/VirtualBox/modules
>>>> # cp *.ko /boot/modules/
>>>>
>>>> Add these lines to /boot/loader.conf
>>>>
>>>> vboxnetflt_load="YES"
>>>> vboxnetadp_load="YES"
>>>>
>>>> Then kldload the modules or reboot. Can you access the net now? I
>>>> noticed that pinging doesn't work inside VB, but I can surf the web just
>>>> fine.
>>>>
>>>>          
>>> Remember that bridged networking doesn't work with wireless.  This is a
>>> virtualbox and FreeBSD issue.  If you are using bridging and your lagg
>>> device
>>> kicks over to wireless VMs in virtualbox will lose connectivity.
>>>
>>>
>>>        
>> Ahh, good to know, thanks Josh!
>>
>> --
>> Kris Moore
>> PC-BSD Software
>> iXsystems
>>
>> _______________________________________________
>> Testing mailing list
>> Testing at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/testing
>>
>>      
>    
I hate to bring this back, but is there another reason why I'm getting 
this error? I loaded the modules and set the /boot/loader.conf to load 
the netflt and netadp modules on boot but the next time I boot PC-BSD I 
get the error in spite of my kldstat output indicating the appropriate 
modules are booted.

31    3 0xffffffff81f48000 420f8    vboxdrv.ko
32    2 0xffffffff81f8b000 6b80     vboxnetflt.ko
33    2 0xffffffff81f92000 14e90    netgraph.ko
34    1 0xffffffff81fa7000 25e0     vboxnetadp.ko

...confused and awaiting expert advice.

Brodey Dover


More information about the Testing mailing list