[PC-BSD Testing] kioslave for file ???

Kris Moore kris at pcbsd.org
Thu Apr 1 05:42:06 PDT 2010


On 03/30/2010 18:25, Walt Pawley wrote:
> On 3/30/10 9:30 AM +0000, Kris Moore wrote on Re: [PC-BSD
> Testing] kioslave for file ???
>
>    
>> On 03/30/2010 06:47, Walt Pawley wrote:
>>      
>>> Working with PC-BSD 7.1. Something has changed and I've been
>>> trying to find it for a couple of days, on and off as time has
>>> allowed. Mostly, I've managed to gain a thumping headache
>>> pawing through mounds of documentation, etc. Hera are some of
>>> the symptoms:
>>>
>>> Starting File Manager (Dolphin): URL cannot be listed file:///home/wump
>>>
>>> Clicking OK gets:  URL cannot be listed file:///usr/home/wump
>>>
>>> Dolphin does come up, but the file content is empty. Clicking
>>> the Root icon produces the error  URL cannot be listed file:///
>>>
>>> Clicking Network results in  URL cannot be listed remote:/
>>>
>>> Clicking Trash results in  URL cannot be listed trash:/
>>>
>>> Firing up File Manager (Administrator) results in: Could not
>>> start process. Unable to create io-slave: klauncher said:
>>> Unknown protocol 'file'.
>>>
>>> Other applications also fail attempting to use the file:
>>> protocol to access files though I'm not certain it's
>>> ubiquitous. Curiously, as of the last time I tested it, which
>>> was after noting much of the above behavior, typing the
>>> "file:///home/wump" into Firefox's location field resulted in a
>>> listing of the files in my home directory. I suspect that
>>> Firefox is not attempting to use KDE's libkio for this activity.
>>>
>>> I get the feeling this not a big job to fix ... IF one knows
>>> what to tweak. Anyone care to allay my ignorance?
>>>
>>>        
>> So at this point it sounds like dolphin isn't working at all, correct?
>> How about if you open a xterm / konsole, and run "tail -f
>> .xsession-errors" while trying to use dolphin. Any interesting messages
>> going by on the failure?
>>      
> Yup, Dolphin pretty much can't locate anything. I hope this is
> sufficiently interesting:
>
> ~$ tail -f .xsession-errors
> "
> SystemUpdater(1960): couldn't create slave: "Unable to create io-slave:
> klauncher said: Unknown protocol 'http'.
> "
> SystemUpdater(1960): couldn't create slave: "Unable to create io-slave:
> klauncher said: Unknown protocol 'http'.
> "
> SystemUpdater(1960): couldn't create slave: "Unable to create io-slave:
> klauncher said: Unknown protocol 'http'.
> "
> kdeinit4: preparing to launch /usr/local/kde4/bin/dolphin
> dolphin(85597) KLocalePrivate::initEncoding: Cannot resolve
> system encoding, defaulting to ISO 8859-1.
> [/usr/local/kde4/bin/nepomukservicestub] (ServerCore) new socket connection.
> Object::connect: No such signal DolphinView::redirection(KUrl,KUrl)
> Object::connect: No such signal DolphinView::redirection(KUrl,KUrl)
> dolphin(85597)/kdecore (trader)
> KServiceTypeTrader::defaultOffers: KServiceTypeTrader:
> serviceType  "ThumbCreator"  not found
> dolphin(85597)/kdecore (trader)
> KServiceTypeTrader::defaultOffers: KServiceTypeTrader:
> serviceType  "ThumbCreator"  not found
>
>
>    

Well, that really doesn't give a clear error on why it can't work :(

Was it working before and just stopped? Maybe something got corrupted in 
.kde4/?


-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Testing mailing list