[PC-BSD Testing] Testing 2nd alpha build

Arthur Koziol A-Koziol at neiu.edu
Tue Sep 15 09:06:05 PDT 2009


>Hey everybody! I've just uploaded the next cut of the 8.0 Alpha. 
>This release still does NOT include native 8.0 PBIs, or nvidia 
>drivers, but we will begin to include those shortly after FreeBSD 
>8.0 releases, which should be in the next
>couple of weeks.
>
>This alpha updates the base to FreeBSD BETA4, and fixes a bunch of 
>bugs in the desktop, kernel config, and software manager.  Again, 
>this is no where near production ready, but you may want to play 
>with it, to test out your hardware support on FreeBSD 8.0.
>
>Also, I've made available the 64bit version as well this time, so 
>feel free to give it a whirl also. If anybody wants to test LIVE DVD 
>mode (option 3) please do so, I need people to test it on systems 
>with 2GB of ram or less, and those with greater than
>2GB of RAM to see if it works properly in both cases. (Systems with 
>2.5GB of RAM or greater will try to load the entire DVD image into 
>memory, which should make the live mode run MUCH faster)
>
>Both the 32bit and 64bit versions may be downloaded below:
>
>ftp://ftp.pcbsd.org/pub/alpha-iso/
>
>Hopefully the next Alpha will include the new System Installer, 
>which is where the real fun begins :)

Allrighty, did a fresh install and here's some things I've noticed.

1. Bootup seems a bit faster than BETA2.

2. App loading time seems twice as fast as BETA2. Wow!

3. System Settings > System Manager complains about "kcm_pcbsdsystem" 
not found.

4. Seems that System Settings > Display > Gamma is back to closing 
down System Settings when it's double-clicked. Probably KDE's fault though.

5. System Settings > Keyboard & Mouse > Global Keyboard Shorts cuts 
throws an error about "Failed to contact the KDE global shortcuts 
daemon" Message: Could not get owner of name 'org.kde.kglobalaccel': 
no such name Error: org.freedesktop.DBus.Error.NameHasNoOwner. 
Probably a KDE issue.

6. System Seetings > Password & User Account just closes down System 
Settings when you double-click it.

7. System Settings > Printer Config says 'The service "Printer 
Configuration" does not provide an interface "KCModule" with keyboard 
'system-config-printer-kde/system-config-printer-kde.py' the factory 
does not support creating components of the specified type.

8. System Settings > Advanced tab > Power management complaining 
about PowerDevil and / or D Bus.

9. Re-running Display Setup Wizard while in KDE still hangs at the 
black screen and mouse cursor but a depression of the power button 
does shut down the system as before. A new behavior I observed as a 
consequence is that at boot, it attempts to run the failed Display 
Setup Wizard but when you click to apply the settings it fails with 
the message "The previous attempt failed, please check your settings 
and try again!" The second time it brings you back to the DSW, it 
does apply the settings, build the new X config file and boot to 
desktop. This probably fixed in the newer x server or Intel driver.

More as it comes.

Arthur 



More information about the Testing mailing list