[PC-BSD Testing] today's questions/bugs

Kris Moore kris at pcbsd.org
Wed Oct 14 08:41:50 PDT 2009


On Wed, 14 Oct 2009, Dru Lavigne wrote:

> 
> Today's comments. Mostly questions and some encrypt and compress bugs.
> 
> Cheers,
> 
> Dru
> 
> ---
> 
> KDE LIRC server should be removed from Utilities (if it isn't already)

Fixed!

> 
> will KOffice be included in base? there is no PBI for it.

There will be a PBI for it, once KOffice 2.1 is in ports. I've been waiting for it a while
now, and we have it in the KDE area51, just waiting for the commit to get done.

> 
> Is the Java PBI for backward compatability only or does Java just work now?

We don't include java in the base system right now, the PBI is the perfered way to get
it loaded up.

> 
> Do we know what version of Flash will be in PC-BSD 8?

Flash 10.xx

> 
> USB automount is real flaky. I tried 2 S3 thumbdrives, a S1 thumbdrive, and a USB hard disk. Only one of the S3 thumbdrives mounted, and
> that was unrepeatable, even across reboots. Not sure if it is my latest test system or if USB automount is just flaky :-) Note that I can
> mount manually but I'd rather tell readers that it "just works".

Yea, seen same thing here, problem with the USB stack in FreeBSD 8.0? I'm not sure that anything has changed
on the KDE side of things.

> 
> File encryption fails in dolphin when you right-click a file and select Encrypt from the Actions menu (after making your keypair). I
> suspect it is either a configuration setting in KGpg's key managment menu or a bug in this version of gnupg (Google hints at this). Also,
> the default configuration is for ASCII armour (which does not encrypt) which is a deceptive default for something that promises to
> encrypt... The error is:
> Not all files were encrypted. Details: [GNUPG] INV_RECP 0 27029B62
> I suggest that the Encrypt File option (the one with the yellow lock icon) be removed from the Actions menu. This will save user
> confusion (e.g. why are there 2 Encrypt file actions in this menu?) and will force them to use Kleopatra which actually works and
> provides more functionality. Note that we want to keep kgpg installed as users need that to generate keys (generating keys works with
> kgpg, using them does not).

Humm, I just did a successfull encrypt using this icon here. I did it of a text file, and selected my keypair, and it 
generated a .asc encrypted message. Then clicking the encrypted file, asked for my password, and decrypted it
properly.


> 
> Kleopatra gives a self-test error of "GpgSM (S/MIME Backend) installation not properly.." You can duplicate this error by right-clicking
> a file in dolphin and selecting any of the right-click Actions that have a cup with a red circle icon. Adding whatever software is
> missing should remove the error.

Fixed!

> 
> dolphin-> right-click file -> actions -> Encrypte & Sign File does nothing (it is supposed to launch the applicable menu in Kleopatra)

Fixed!

> 
> Kleopatra's Certificate Creation Wizard (in file menu) does not work which is needed to use dolphin's right-click -> Actions ->
> S/MIME-Sign File. If resolving the above self-test error doesn't fix this, I would suggest this option be removed from Action menu. Would
> be handier to get this fixed though as it is a nice cert generation interface.

Removed it from the action menu :)

> 
> dolphin-> right-click file/directory -> compress -> As RAR Archive fails with: "Failed to locate program rar in PATH"

Fixed!

> 
> dolphin-> right-click file/directory -> compress -> As ZIP/TAR Archive does the same thing as compress -> Here. I would suggest removing
> one of these (probably Here as that option gives no indication of what you're gonna get)

Done!

> 
> if you right-click a tar.gz compressed file in Dolphin and select Extract Archive Here, Autodetect Subfolder, you get a bunch of funky
> empty folders instead of the contents of the archive. If you try the same thing with a ..zip, you get the entire directory structure
> leading up to the file (which may be what is supposed to happen but it's irritating). If you select Extract Archive Here, nothing happens
> for tar.gz; for zip you get folders leading to the path of the extracted file.
> 
> I could not get right-click any type of compressed file -> Extract Archive To to work. When I selected a directory to extract to, it
> complained that it already existed. When i clicked ok anyways, the files did not get extracted to the selected directory. If I click to
> create a new folder, it does get created but nothing gets extracted.

I think these errors are all related to the bug here:

http://bugs.kde.org/show_bug.cgi?id=191821

I think its something in Ark which is screwed up, once they fix it, it'll be corrected across all these issues.

> 
> can someone confirm which filesystems are supported if you connect an external USB hard drive. e.g. NTFS? DOS? UFS? EXT2? etc.

>From my personal testing, I know UFS / msdosfs work on a USB stick, haven't tried NTFS before.

> 
> encrypting in kmail doesn't work (related to S/MIME error above). Exact error is: "Engine /usr/local/bin/gpgsm is not installed properly"

Fixed!

> 
> youtube etc. work fine in Konqueror and firefox PBI, but fails in Opera PBI

Those are the PBIs from the 7.x series right? The 8.x PBIs are still rebuilding, once opera/ff builds for 8.0,
we'll need to re-test this.

> 
> 
> !DSPAM:1,4ad524e415311991310097!
>

--
Kris Moore
PC-BSD Software



More information about the Testing mailing list