[PC-BSD Testing] 7.1 ugly crash

Jeff dejamuse at yahoo.com
Mon Nov 23 02:56:42 PST 2009


Well, thanks for the advice but I had to give up.  I could never get the RAID-0 array to start up again.  I put two new disk drives in and tried to get the old array to sync up a 2nd time but no go.  Tried resetting the array in the BIOS and using Testdisk to rebuild the partition but it wouldn't do it - one drive just slowly died to the point it was unusable.  Maybe I could have hit the offending drive with some freeze spray to get it back to some vestige of life, but screw it - I'll just start over - I didn't lose all that much - was able to get off a lot of important files before it died altogether.

Lesson learned - backup, backup, and then backup again.  I just never expected such a new box to die so soon.  Also, after putting in two new drives, I again set them to RAID - 0 and after powering down, removing the old drives and starting up again, the new RAID - 0 was broken!  Whatever performance increase I might have gotten from striping just isn't worth it - reconfigured it with RAID - 1.  Maybe 4 drives in a RAID - 10 would be ok, but no room for two extra drives in this box.  To get a real performance boost I'll just wait six more months until the Intel X25 Flash drives drop in price.  Guess I'd not recommend anyone configure two drives in a RAID - 0.  Seems it's highly sensitive to errors breaking the array.  Once the array is broken it's near impossible to retrieve data using any of the utilities out there.  I hear that a newer version of the Intel Matrix RAID manager allows fixing broken arrays, but didn't try it.  Not sure if that
 is a BIOS or Windows only solution.

...Jeff

--- On Fri, 11/20/09, Kris Moore <kris at pcbsd.org> wrote:

From: Kris Moore <kris at pcbsd.org>
Subject: Re: [PC-BSD Testing] 7.1 ugly crash
To: "PC-BSD Testing list" <testing at lists.pcbsd.org>
Date: Friday, November 20, 2009, 9:07 AM



On Fri, 20 Nov 2009, Jeff wrote:

> I tried that but I can't copy any of the files out of the directory.
> 
> Every time I try to start Dolphin SU it crashes the whole system and reboots.
> In Krusader I can initiate the copy but it immediately stalls and does nothing.
> 
> I can copy other files from the home directory for example, no problem.
> 
> In the console I did:
> 
> cd /media/disk/usr/local/warden/jails
> cp 192.168.1.12/*.* /usr/local/warden/jails
> 
> And got "no match".
> 
> Trying to copy the Drupal directory:
> 
> cp -r  /media/disk/usr/local/warden/jails/192.168.1.12/usr/local/www/apache22/data/*.* /usr/local/warden/jails/
> 
> Results in all the files shown with this error message:
> cp: /usr/local/warden/jails/index.php: Bad address
> 
> What am I doing wrong?
> 
> ...Jeff
>

Those sound like troublesome errors. Try it with tar:

# cd /media/disk/usr/local/
# tar cvzf /usr/local/warden.tgz warden
# cd /usr/local
# tar xvpzf warden.tgz
# rm warden.tgz

Does that work, or still give address errors?

--
Kris Moore
PC-BSD Software
-----Inline Attachment Follows-----

_______________________________________________
Testing mailing list
Testing at lists.pcbsd.org
http://lists.pcbsd.org/mailman/listinfo/testing



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pcbsd.org/pipermail/testing/attachments/20091123/fc832c44/attachment.html 


More information about the Testing mailing list