[PC-BSD Testing] Latest Alpha -xorg issues

Kris Moore kris at pcbsd.org
Fri Nov 6 06:27:45 PST 2009




On Fri, 6 Nov 2009, Sam Fourman Jr. wrote:

> On Fri, Nov 6, 2009 at 4:47 AM, Airy <airy at netspace.net.au> wrote:
>> Just tried the latest alpha and something was broken compared to the
>> previous alpha unfortunately.
>>
>>
>> Installed on a Asus P5E-VM HDMI board on an IDE 320gb harddisk .
>
> somewhat related, I have a confusing problem I have an Asus board that
> xorg refuses to allow a working mouse and Keyboard
> The dmesg below is Not from PCBSD it is From FreeBSD 9.0 and both
> FreeBSD 8.0 and 9.0 work.
>
> I am not sure what is different about PCBSD
>
> I also am showing the working xorg.conf from FreeBSD 9(8.0 RC2 works as well)
>
>
> Thank you
>
> Sam Fourman Jr.

Sam,

Take a look at this section from your FreeBSD systems. It looks like you
have AutoAddDevices set to Off, which is on by default in PC-BSD Alphas:

Section "ServerLayout"
     Identifier     "Layout0"
     Screen      0  "Screen0" 1440 0
     Screen      1  "Screen1" rightOf "Screen0"
     InputDevice    "Keyboard0" "CoreKeyboard"
     InputDevice    "Mouse0" "CorePointer"
     Option         "AutoAddDevices" "Off"
EndSection

Could you give that a try on a PC-BSD system? If putting that into your xorg.conf fixes
your mouse / keyboard, then we can nail down the issue as being something with HAL, since xorg
tries to probe for devices via HAL with that option turned on.



--
Kris Moore
PC-BSD Software


More information about the Testing mailing list