[PC-BSD Testing] 7.1-RC1 error report with ThinkPad T61

Arthur Koziol A-Koziol at neiu.edu
Mon Mar 30 05:42:10 PST 2009


>I installed PC-BSD 7.1 RC1(x86 version) to Lenovo ThinkPad T61.
>I got 4 errors.  Report about it.
>
>Installation note:
>* This T61 with "nVidia Quadro NVS 140M" graphic chip.(1440x900)
>* PC-BSD installed to external disk storage via USB(/dev/da0).
>* Installed PC-BSD Japanese version.
>   (Note for developer: Japanese translation finished for 7.1)
>
>
>         Error #1/4:
>nvidia-180.37 driver not worked after "Display Settings".
>But after system reboot, driver worked fine.
>
>Note:
>   nvidia-173.14.17 driver worked fine in any case.
>   nvidia-96.43.11 driver not worked(maybe, too old version).
>
>
>         Error(or specification?) #2/4:
>PC-BSD's installer goes black-out by screen saver.  I feel
>confused sometimes.
>
>I hope disable screen saver in automatically.  It is easy,
>execute 'xset s off' by installer.
>But, nothing /usr/local/bin/xset in installer.  Need bring
>xset(1) from ports/x11/xset.
>
>
>         Error #3/4:
>Plasma's some operations not worked with Japanese language
>environment(Didn't appear this bug with English environment).
>
>This bug appear with after PC-BSD 7.0.
>(Sorry I forget report to list)
>
>After left-button-click on right-top corner:
>         "Add widgets..."
>         "Appearance Settings"
>After right-button-click on desktop:
>         "Run Command..."
>         "Add widgets..."
>         "Appearance Settings"
>
>
>         Error #4/4:
>Cannot play sound with snd_hda(4).
>How to fix sound for T61: Comment-out these line in /etc/sysctl.conf
>
># Autodetect the right sound card
>hw.snd.default_auto=1
>         |
>         V
># Autodetect the right sound card
>#hw.snd.default_auto=1
>
>Technical note for sound fix:
>
>         0th codec found in FreeBSD.  But 1st codec unknown.
>         Maybe, cannot use 1st codec.
>
> >From dmesg(8) output:
>| hdac0: <Intel 82801H High Definition Audio Controller> mem 
>0xfe220000-0xfe223fff irq 17 at device 27.0 on pci0
>| hdac0: HDA Driver Revision: 20090131_0127
>| hdac0: [ITHREAD]
>| hdac0: HDA Codec #0: Analog Devices AD1984
>| hdac0: HDA Codec #1: Conexant (Unknown)
>| pcm0: <HDA Analog Devices AD1984 PCM #0 Analog> at cad 0 nid 1 on hdac0
>| pcm1: <HDA Analog Devices AD1984 PCM #1 Digital> at cad 0 nid 1 on hdac0
>
>         But, PC-BSD use 1st codec.
>
> >From 'cat /dev/sndstat' output:
>| FreeBSD Audio Driver (newpcm: 32bit 2007061600/i386)
>| Installed devices:
>| pcm0: <HDA Analog Devices AD1984 PCM #0 Analog> at cad 0 nid 1 on 
>hdac0 kld snd_hda [MPSAFE] (1p:4v/1r:4v channels duplex)
>| pcm1: <HDA Analog Devices AD1984 PCM #1 Digital> at cad 0 nid 1 on 
>hdac0 kld snd_hda [MPSAFE] (1p:2v/0r:0v channels default)
>
>         After commented-out "hw.snd.default_auto=1" and reboot,
>         PC-BSD use 0th codec and can play sound.
>
> >From 'cat /dev/sndstat' output('default' moved to #1 to #0):
>| FreeBSD Audio Driver (newpcm: 32bit 2007061600/i386)
>| Installed devices:
>| pcm0: <HDA Analog Devices AD1984 PCM #0 Analog> at cad 0 nid 1 on 
>hdac0 kld snd_hda [MPSAFE] (1p:4v/1r:4v channels duplex default)
>| pcm1: <HDA Analog Devices AD1984 PCM #1 Digital> at cad 0 nid 1 on 
>hdac0 kld snd_hda [MPSAFE] (1p:1v/0r:0v channels)
>
>
>regards,
>--
>Yamashiro, Jun                  Email: yamajun at ofug.net
>Okinawa FreeBSD Users Group

Jun-san,

You might want to try the 180.44 driver just released today.
Here: http://www.nvidia.com/object/freebsd_180.44.html

Arthur 



More information about the Testing mailing list